DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 928470 - Last Review: September 23, 2011 - Revision: 3.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

In Microsoft Windows XP Home Edition for Prepaid Computers or in Microsoft Windows XP Home Edition for Subscription Computers, you experience the following problems:
  • A race condition occurs when you try to add more time to the computer. Also, the server does not allocate more time to the client, even though the server processes the prepaid token from the client.
  • The subscription is not automatically confirmed.

CAUSE

The race condition occurs if the provisioning server does not correctly process the request to release the prepaid token. The client computer does not keep the last token that was used. If no provisioning packets or time packets are received during the first submission attempt, the client computer resubmits the request.

The subscription problem occurs because of the timing of the automatic poll. If the computer is offline during the scheduled poll, the poll does not occur.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Plactive.resources.dll5.1.2600.3079827,39219-Jan-200707:01x86
Plcomm.resources.dll5.1.2600.307932,76819-Jan-200707:01x86
Plnotify.resources.dll5.1.2600.3079499,71219-Jan-200707:01x86
Plppauth.resources.dll5.1.2600.3079143,36019-Jan-200707:01x86
Plwizlib.resources.dll5.1.2600.307990,11219-Jan-200707:01x86
Plactive.exe5.1.2600.30791,069,05619-Jan-200707:01x86
Plcertmgrmanaged.dll5.1.2600.307911,77619-Jan-200707:01x86
Plcomm.dll5.1.2600.307986,01619-Jan-200707:01x86
Plconfig.exe5.1.2600.307916,38419-Jan-200707:01x86
Plnotify.exe5.1.2600.3079704,51219-Jan-200707:01x86
Plppauth.dll5.1.2600.3079188,41619-Jan-200707:01x86
Plupm.dll5.1.2600.307452,73608-Feb-200715:06x86
Plutilsmanaged.dll5.1.2600.307924,57619-Jan-200707:01x86
Plwizlib.dll5.1.2600.3079135,16819-Jan-200707:01x86
Plactive.resources.dll5.1.2600.3079827,39219-Jan-200707:01x86
Plcomm.resources.dll5.1.2600.307932,76819-Jan-200707:01x86
Plnotify.resources.dll5.1.2600.3079499,71219-Jan-200707:01x86
Plwizlib.resources.dll5.1.2600.307990,11219-Jan-200707:01x86
Plactive.exe5.1.2600.30791,069,05619-Jan-200707:01x86
Plcertmgrmanaged.dll5.1.2600.307911,77619-Jan-200707:01x86
Plcomm.dll5.1.2600.307986,01619-Jan-200707:01x86
Plconfig.exe5.1.2600.307916,38419-Jan-200707:01x86
Plnotify.exe5.1.2600.3079704,51219-Jan-200707:01x86
Plppauth.dll5.1.2600.3079188,41619-Jan-200707:01x86
Plupm.dll5.1.2600.307452,73608-Feb-200715:11x86
Plutilsmanaged.dll5.1.2600.307924,57619-Jan-200707:01x86
Plwizlib.dll5.1.2600.3079135,16819-Jan-200707:01x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Additional issues that this update addresses include the following:
  • Users who added time received incorrect error messages when the latency of Internet connections caused problems. These error messages have been removed.
  • Error messages that relate to the Add Time feature have been made accurate.
  • Incorrect error messages that ask the user to reinstall the operating system have been removed.
  • You can now download up to 50 prepaid packets and time packets. These packets include configuration packets and bootstrap packets. Previously, you could download only up to 5 packets.
  • Restoring the computer no longer requires a re-registration action from the solution provider or from the billing agent for activation to succeed. Windows activation remains unchanged.
  • The Standby Notification dialog box now appears on the Windows logon screen when two or more users are logged on.
  • The long wait time to display the completed Add Computer Use Time Wizard on a slow Internet connection is fixed.
  • An incorrect page no longer appears on a prepaid client computer after a pending transaction is completed in Limited Access mode.
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Home Edition for Subscription Computers
  • Microsoft Windows XP Home Edition for Prepaid Computers
Keywords: 
kbautohotfix kbexpertiseinter kbwinxppresp3fix kbfix kbbug kbhotfixserver kbqfe KB928470
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support