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Article ID: 928595 - Last Review: October 9, 2011 - Revision: 9.0

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SYMPTOMS

When you install the following Windows operating systems, the installation process successfully updates the system files:
  • Microsoft Windows XP Service Pack 2 (SP2)
  • Microsoft Windows Server 2003 Service Pack 1 (SP1)
  • Microsoft Windows Server 2003 Service Pack 2 (SP2)
However, an access violation occurs, and the installation process stops responding when it tries to migrate hotfixes. When the access violation is generated, the following message might be recorded in the application log:
Date(A):  yyyy/mm/dd  Source(S): Application Error
Time(M):  hh:mm:ss  Rank(R): (100)
Kind(E): error Event ID(I): 1000
User(U): N/A
Computer(O): machine
Error Application: update.exe, Version: x.x.x.x, Error Module: ntdll.dll, Version: x.x.x.x. Error Address: 0x00000000.


For detailed information, please refer to the help and support center: http://www.microsoft.com/technet/support/ee/ee_basic.aspx (http://www.microsoft.com/technet/support/ee/ee_basic.aspx)

Windows XP log file information

When this problem occurs on a Windows XP-based computer, information that resembles the following is logged in the Svcpack.log file:
2933.438: MigrateHotfix: Hotfix KB924496 successfully migrated
2933.438: MigrateHotfixes: Return code: 3010
2933.529: Files To Attach C:\WINDOWS\svcpack.log C:\WINDOWS\svcpack.log 
2934.861: Waiting For watson First time ...
2935.562: Waiting For watson First time ...
2935.702: Waiting For watson First time ...
2942.361: Waiting For watson First time ...
2949.031: Waiting For watson First time ...
2955.700: Waiting For watson First time ...
2962.370: Waiting For watson First time ...
2969.040: Waiting For watson First time ...
2971.553: Waiting For watson First time ...

Windows Server 2003 log file information

When this problem occurs on a Windows Server 2003-based computer, information that resembles the following is logged in the Svcpack.log file:
1817.391: MigrateHotfix: Hotfix KB928255 successfully migrated
1817.391: MigrateHotfixes: Return code: 3010
1817.391: MigrateHotfix: Migrating hotfix KB928843
1817.391: Migrating QFE KB928843 with command line: update.exe -Z -Q -B:sp1rtm
1828.328: MigrateHotfix: Hotfix KB928843 successfully migrated
1828.328: MigrateHotfixes: Return code: 0
1828.328: MigrateHotfix: Migrating hotfix KB929969
1828.328: Migrating QFE KB929969 with command line: update.exe -Z -Q -B:sp1rtm
1839.235: MigrateHotfix: Hotfix KB929969 successfully migrated
1839.235: MigrateHotfixes: Return code: 0
1839.235: MigrateHotfix: Migrating hotfix KB931836
1839.235: Migrating QFE KB931836 with command line: update.exe -Z -Q -B:sp1rtm
1841.078: Update.exe failed 1603.
1841.078: MigrateHotfixes: Migration of KB931836 failed

CAUSE

This problem occurs because a buffer that is used to store the hotfix migration list is not large enough. This problem occurs when lots of software updates have been installed. Additionally, these software updates were released after Windows XP Service Pack 1 or Windows Server 2003 were released. These software updates include the updates that you obtained from the following sources:
  • Windows Update
  • Hotfixes that you received from Microsoft Customer Support Services
  • Any updates that were installed by using a Microsoft Windows Server Update Services (WSUS) server

RESOLUTION

To resolve the problem, apply the update that is described in this article before you install Windows XP Service Pack 2 or before you install a service pack for Windows Server 2003.

Update information

Windows XP

The following file is available for download from the Microsoft Download Center:

Collapse this imageExpand this image
Download
Download the Update for Windows XP (KB928595) package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=7C3CB9B8-DD93-4D1D-9515-F9888C1F6C9D)

Release Date: July 24, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other hotfixes.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows XP Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeSP requirementService branch
Acspecfc.dll5.1.2600.3072245,24825-Jan-200712:24SP2SP2GDR
Acadproc.dll5.1.2600.307239,42425-Jan-200712:36SP2SP2QFE
Acspecfc.dll5.1.2600.3072245,24825-Jan-200712:36SPSP2QFE

Windows Server 2003

The following file is available for download from the Microsoft Download Center:

Collapse this imageExpand this image
Download
Download the Update for Windows Server 2003 (KB928595) package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=D00AC9C5-4FEF-4E9A-8217-5B55550C9DE6)

Release Date: July 24, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other hotfixes.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows Server 2003 Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeSP requirementService branch
Acspecfc.dll5.2.3790.2953266,75211-Jun-200715:51SP1SP1GDR
Acspecfc.dll5.2.3790.2953266,75211-Jun-200715:56SP1SP1QFE
Acspecfc.dll5.2.3790.4097266,75211-Jun-200716:43SP2SP2GDR
Acspecfc.dll5.2.3790.4097266,75211-Jun-200716:32SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. 

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Keywords: 
atdownload kbexpertisebeginner kbfix kbbug kbqfe KB928595
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