DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 929338 - Last Review: June 13, 2014 - Revision: 5.0

On This Page

The update that this article describes has been replaced by a newer update. To resolve this problem, install the most current security update. To install the most current update, visit the following Microsoft Web site:
http://update.microsoft.com (http://update.microsoft.com)
For more technical information about the most current security updates, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/current.aspx (http://www.microsoft.com/technet/security/current.aspx)

Symptoms

A computer that is running Microsoft Windows XP with Service Pack 2 crashes. You may receive one of the following Stop error messages:

Error message 1
STOP 0x0000001a: MEMORY_MANAGEMENT
Error message 2
STOP 0x0000000a: IRQL_NOT_LESS_OR_EQUAL

Cause

This problem occurs because of a race condition in the memory manager.

Resolution

Method 1: Install security update 931784 (Recommended)

To install the most current update, visit the following Microsoft Web site:
http://update.microsoft.com (http://update.microsoft.com)
You can also install security update 931784 at the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=EEAEE4A7-4858-4B6B-9C6D-A9F1EAE19B51&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=EEAEE4A7-4858-4B6B-9C6D-A9F1EAE19B51&displaylang=en)

Method 2: Install update 929338

The following file is available for download from the Microsoft download center:
Collapse this imageExpand this image
Download
Download the WindowsXP-KB929338-x86-ENU.exe package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=3AF7DCC4-E3A1-411A-9C9B-DC23923D09E7)
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

You must have Windows XP Service Pack 2 installed to apply this update.

Restart requirement

You have to restart the computer after you apply this update.

Update replacement information

Security update 931784 replaces this update. For more information about security update 931784, click the following article number to view the article in the Microsoft Knowledge Base:
931784  (http://support.microsoft.com/kb/931784/ ) MS07-022: Vulnerability in the Windows kernel could allow elevation of privilege

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.1.2600.30512,136,06419-Dec-200614:15x86SP2
Ntkrnlpa.exe5.1.2600.30512,057,60019-Dec-200612:55x86SP2
Ntkrpamp.exe5.1.2600.30512,015,74419-Dec-200612:55x86SP2
Ntoskrnl.exe5.1.2600.30512,180,35219-Dec-200614:17x86SP2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Applies to
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Keywords: 
kbresolve atdownload kbexpertisebeginner kbtshoot kbqfe KB929338
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support