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Article ID: 931719 - Last Review: March 17, 2007 - Revision: 1.4

SYMPTOMS

When you try to connect to a shared printer in Windows Vista, you receive the following error message:
Windows cannot connect to the printer. The printer driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers.
You experience this behavior if the following conditions are true:
  • You use the Windows Point and Print feature to connect to the shared printer.

    Note The Point and Print feature lets you print to a shared printer without manually installing a new driver. For more information about this feature, see the "More Information" section.
  • The shared printer uses a kernel mode printer driver.

CAUSE

This problem occurs because Windows Vista does not support the installation of kernel mode printer drivers. Windows Vista only supports the installation of user mode printer drivers.

When you try to connect to a shared printer in Windows Vista, the following behavior occurs:
  • If a user mode driver is hosted on the Windows NT 4.0-based computer, Windows Vista installs the Point and Print driver successfully.
  • If a kernel mode driver is hosted on the Windows NT 4.0-based computer, Windows Vista tries to locate a compatible user mode printer driver. In this scenario, the following behavior occurs:
    • If Windows Vista can map a compatible user mode printer driver to the kernel mode printer driver that is hosted on the Windows NT 4.0-based computer, Windows Vista installs the printer successfully.
    • If Windows Vista cannot map a compatible user mode printer driver to the kernel mode printer driver that is hosted on the Windows NT 4.0-based computer, Windows Vista does not install the printer.
Microsoft Windows NT 4.0 supports the following types of printer drivers:
  • Kernel mode printer drivers

    Note These are also known as version 2 printer drivers. This kind of driver includes many of the printer drivers that are included with Windows NT 4.0.
  • User mode printer drivers

    Note These are also known as version 3 printer drivers.

WORKAROUND

To work around this behavior, try to obtain and install a user mode printer driver on the Windows NT 4.0-based computer. If you cannot obtain the particular user mode printer driver, try to obtain a user mode printer driver that is compatible with the kernel mode printer driver that is hosted on the Windows NT 4.0-based computer. To obtain an updated printer driver for the print device, contact the printer manufacturer.

For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

STATUS

This behavior is by design.

MORE INFORMATION

For more information about the Point and Print feature, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/techinfo/overview/pointandprint.mspx (http://www.microsoft.com/windowsserver2003/techinfo/overview/pointandprint.mspx)
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbprint kbexpertisebeginner kbtshoot kbprb KB931719
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