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Article ID: 933251 - Last Review: October 9, 2014 - Revision: 5.0

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Symptoms

Consider the following scenario. In an application, you try to open an XML document by using Windows Internet Explorer. However, the XML document is not valid. In this scenario, error code 404 is returned as expected. However, Internet Explorer may use a high percentage of the CPU resources.

Cause

This problem occurs because the Multipurpose Internet Mail Extension (MIME) viewer of Microsoft XML Parser 3.0 (MSXML 3.0) tries to open the XML document. However, the XML document is not valid.

Resolution

Windows Vista Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -
http://technet.microsoft.com/en-us/library/dd335033.aspx (http://technet.microsoft.com/en-us/library/dd335033.aspx)
Note: Currently, the list of hotfixes and security updates is available only in English.

Hotfix information for Windows Vista and Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have MSXML 3.0 installed to apply this hotfix.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces MSXML 3.0 Service Pack 8.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows XP, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msxml3.dll8.90.1010.01,118,72010-Apr-200702:55x86
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msxml3.dll8.90.1010.01,205,24811-Apr-200706:31x86
Msxml3r.dll8.20.8730.12,04811-Apr-200706:31x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msxml3.dll8.90.1010.01,888,25611-Apr-200707:44x64
Msxml3r.dll8.20.8730.12,04811-Apr-200707:44x64

Workaround

To work around this problem, visit a different page in Internet Explorer.

Note This action may not work around this problem if you use a Web browser control in the application.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
Keywords: 
kbmdd kbautohotfix kbvistasp1fix kbfix kbhotfixserver kbqfe KB933251
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