DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 935708 - Last Review: October 8, 2011 - Revision: 4.0

On This Page

SYMPTOMS

After you install a univeral serial bus (USB) telephony device on a Microsoft Windows XP-based computer, this device is unexpectedly set as the default audio device. The USB telephony device can be a USB telephone, a USB handset, or a USB headset. This behavior occurs even though other audio devices are already installed on the computer.

In this situation, the computer cannot correctly play media or record media.

CAUSE

This problem occurs because the system does not check the device type of the newly installed audio device.

RESOLUTION

Update information

The following files are available for download from the Microsoft Download Center:

Windows XP with SP2, x86-based versions

Collapse this imageExpand this image
Download
Download the 935708 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=3624FB5B-73AD-4AE7-83D1-8ECA6ACE64DE)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To apply this update, you must have Windows XP Service Pack 2 (SP2) installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP with SP2, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys5.1.2600.311560,03210-Apr-200710:08x86

WORKAROUND

To work around this problem, reset the default audio device to the device that you want. To do this, follow these steps:
  1. Click Start, and then click Control Panel.
  2. In Control Panel, double-click Sounds and Audio Devices.
  3. On the Audio tab, click the audio device that you want in the Default device list that is under Sound playback.
  4. On the Audio tab, click the audio device that you want in the Default device list that is under Sound recording.
  5. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the same problem in Windows Vista, click the following article number to view the article in the Microsoft Knowledge Base:
936004  (http://support.microsoft.com/kb/936004/ ) A USB telephony device that is installed on a Windows Vista-based computer is unexpectedly set as the default audio device
For more information about how to determine an audio device type, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms790325.aspx (http://msdn2.microsoft.com/en-us/library/ms790325.aspx)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
atdownload kbwinxppresp3fix kbexpertisebeginner kbexpertiseinter kbbug kbfix kbqfe KB935708
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support