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Article ID: 936481 - Last Review: October 8, 2011 - Revision: 5.0

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SYMPTOMS

You cannot install the Microsoft System Center Operations Manager 2007 Reporting feature in a disjointed namespace environment.

Additionally, the following error messages are logged in the MOMreporting.log file:

Message 1
Property(S): UnableToGetUserNameFromManagementServerActionAccount = SetPropertiesToManagementServerActionAndSDKAccountCA error: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException : The specified domain does not exist or cannot be contacted. Property(S): UnableToGetUserNameFromManagementServerSDKAccount = SetPropertiesToManagementServerActionAndSDKAccountCA error: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException : The specified domain does not exist or cannot be contacted. MSI (s) (F4:E0) [TIME]: MainEngineThread is returning 1603
Message 2
TimeIP addressIP address DNS DNS: QueryId = 0xD8FD, QUERY (Standard query), Query for _ldap._tcp. Domain Controller name ._sites.dc._msdcs. Primary Domain Name System suffix of type SRV on class Internet
Message 2 indicates that a network trace is querying the wrong SRV record. In the network trace, the server tries to contact the following Active Directory directory service site:
_ldap._tcp.Domain Controller name._sites.dc._msdcs.Primary Domain Name System suffix
However, this is the wrong SRV record. In a disjointed namespace environment, the Domain Name System (DNS) name of the server is not the DNS name of the domain.

CAUSE

This problem occurs because the primary DNS suffix of the computer does not match the fully qualified domain name (FQDN) of the domain in which the computer resides.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix installation instructions

This hotfix must be installed on each computer that meets any of the following criteria:
  • The computer is running System Center Operations Manager Reporting Server.
  • The computer is running System Center Operations Manager Root Management Server.
To install this hotfix, use the following two separate procedures. Perform the first procedure on the Root Management Server (RMS). Perform the second procedure on any computer that updates the Reporting2007.msi file before you use this .msi file for the report server installation.
  • Installation steps for the Root Management Server
    1. Copy the SystemCenterOpsMgr07-RTM-KB9356481-X86-AMD64-ENU.MSI file to a local folder or to a shared network folder that is available to the RMS.
    2. Open the SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI file.
    3. To install the hotfix on the RMS, finish the installation of the SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI file on the RMS. The MSI installation will prompt for a location to extract the hotfix, such as the "C:\Program Files\System Center 2007 Hotfix Utility" folder. Select the default path or another path, and then note the installation location. During installation, the hotfix files will be extracted to a subfolder of this path that has a folder name of Q936841. After the installation, you will see a System Center Operations Manager 2007 Software Update dialog box. Click Run Software Update in the dialog box when you are ready to stop the RMS services and apply the software update.
  • Installation steps for any computer that will update the Reporting2007.msi file on a copy of the media

    Note If this computer is the RMS, complete steps 1 through 3 of the first procedure, and then go to step 3 of this procedure.
    1. Copy the SystemCenterOpsMgr07-RTM-KB9356481-X86-AMD64-ENU.MSI file to a local hard disk folder.
    2. Run the SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI file for everyone, but do not select Run Software Update from the System Center Operations Manager 2007 Software Update dialog box when the installation finishes. Note the installation path that is requested during installation.

      Note The installation path is typically the following:
      Program Files\System Center Hotfix Utility
    3. Use Windows Explorer to locate the hotfix installation folder that you noted in step 3 of the first procedure. A series of subfolders will exist under the Q936481\reporting_fix folder for the x86 and AMD64 platforms. Note the path of the platform folder for the reporting installation that you will be performing.
    4. Copy the Reporting2007.msi file from the appropriate platform folder of the original System Center Operations Manager 2007 media to the Q936481\reporting_fix\platform folder.
    5. Open a command prompt, and then change the current working directory to Q936481\reporting_fix\platform. For example, type the following command:
      cd C:\Program Files\System Center 2007 Hotfix Utility\Q936481\reporting_fix\x86
    6. To apply the MSI transform, type the following at a command prompt:
      WiUseXfm.vbs Reporting2007.msi ReportingXfm86.mst
    7. To verify a successful installation, check the last modified time of the Reporting2007.msi file in Windows Explorer.
    8. After the MSI transform application is finished, copy the Reporting2007.msi file from the Q936481\reporting_fix\platform folder to the reporting\platform folder on a copy of the original System Center Operations Manager 2007 media. If you cannot do this because the media is read-only, you may install the hotfix directly from the modified reporting2007.msi file by using the following command:
      msiexec /i path of the modified .msi file \reporting2007.msi /l*v %TEMP%\MOMReporting.log
      Note Applying the MSI transform will break the digital signature on the reporting2007.msi file. You may be warned about this issue before you install the hotfix. You can safely continue the installation.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
System Center Operations Manager 2007, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Microsoft.EnterpriseManagement.OperationsManager.dll6.0.5000.22,166,78415-May-200721:44
ReportingCAManaged.dll6.0.5000.2353,68015-May-200722:25
ReportingCAManagedPac.dll1,250,97615-May-200723:16
ReportingCAPack.dll 127,88815-May-200723:16
System Center Operations Manager 2007, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Microsoft.EnterpriseManagement.OperationsManager.dll6.0.5000.22,166,78415-May-200721:44
ReportingCAManaged.dll6.0.5000.2353,68015-May-200722:25
ReportingCAManagedPac.dll1,250,97615-May-200723:16
ReportingCAPack.dll 127,88815-May-200723:16

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Essentials 2007
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbHotfixServer kbqfe KB936481
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