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Article ID: 936970 - Last Review: May 21, 2008 - Revision: 4.1

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SYMPTOMS

You are working in a Terminal Services session that is initialized by Remote Desktop Connection 6.0. When you try to save a document in a 2007 Microsoft Office program to a redirected drive, you receive the following error message:
There has been a network or file permission error. The network connection may be lost.
(\\tsclient\Path\FileName.docx)
Therefore, you cannot save the 2007 Office document to the redirected drive.

By default, the Remote Desktop Connection 6.0 component is included in Windows Vista. The Remote Desktop Connection 6.0 component can also be installed manually in Windows XP or in Windows Server 2003.

Notes
  • In the error message, Path\FileName.docx is the path and the name of the document that you are trying to save.
  • The redirected drive is a drive on the local computer that is redirected in the Terminal Services session. The redirected drive helps to make it easy to transfer files between the local host and the remote computer.

CAUSE

This problem occurs because of the file saving logic conflicts between the 2007 Microsoft Office program and the Remote Desktop Connection 6.0 component.

When you try to save a document in a 2007 Microsoft Office program, the program saves the document file to the disk by using a temporary name, and then it renames the temporary file. However, when you try to close the file, the Remote Desktop Connection 6.0 component cannot immediately close the file as expected. Therefore, the 2007 Microsoft Office program cannot rename the temporary file, and it cannot save the document.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install RDP 6.0 on computers that are running the following operating systems:
  • Windows XP with Service Pack 2 (SP2)
  • Windows Server 2003 with Service Pack 1 (SP1) or a later version

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,80615-May-200711:12Not Applicable
X86_c80cdcebb100c4200b8a72d5440a7db1_31bf3856ad364e35_6.0.6000.20598_none_c7686a7ceefb34ff.manifestNot Applicable72215-May-200711:12Not Applicable
X86_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.0.6000.20598_none_2e381519e1e11139.manifestNot Applicable168,92015-May-200711:14Not Applicable
Aaclient.dll6.0.6000.20598116,73615-May-200702:18x86
Aaclient.mofNot Applicable1,09707-Jan-200705:26Not Applicable
Mstscax.dll6.0.6000.205981,865,72815-May-200702:20x86
Mstscax.mofNot Applicable1,96707-Jan-200705:26Not Applicable
Tsgqec.dll6.0.6000.2059836,35215-May-200702:21x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_fb56ff8a0a8e92962d7b23ce65dab37e_31bf3856ad364e35_6.0.6000.20598_none_efe6a35fe754e48a.manifestNot Applicable1,09215-May-200711:12Not Applicable
Amd64_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.0.6000.20598_none_8a56b09d9a3e826f.manifestNot Applicable168,98215-May-200711:19Not Applicable
Update.mumNot Applicable2,05615-May-200711:12Not Applicable
Aaclient.dll6.0.6000.20598130,04815-May-200703:21x64
Aaclient.mofNot Applicable1,09707-Jan-200705:26Not Applicable
Mstscax.dll6.0.6000.205982,187,77615-May-200703:23x64
Mstscax.mofNot Applicable1,96707-Jan-200705:26Not Applicable
Tsgqec.dll6.0.6000.2059827,64815-May-200703:24x64
Windows XP
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File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24003-Jul-200714:39x86
Windows Server 2003 SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24004-Jul-200708:02x86
Windows Server 2003 SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24004-Jul-200708:21x86
Windows Server 2003 SP1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lhmstscx.dll6.0.6000.206122,188,28803-Jul-200717:41x64SP1Not Applicable
Wlhmstscx.dll6.0.6000.206121,866,24003-Jul-200717:41x86SP1WOW
Windows Server 2003 SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lhmstscx.dll6.0.6000.206122,188,28803-Jul-200717:48x64SP2Not Applicable
Wlhmstscx.dll6.0.6000.206121,866,24003-Jul-200717:48x86SP2WOW

WORKAROUND

To work around this problem, save the file to the disk on the terminal server. Then, move the file to the redirected drive.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about an issue in Remote Desktop Connection 6.0 that is resolved by this hot fix, click the following article number to view the article in the Microsoft Knowledge Base:
938080   (http://support.microsoft.com/kb/938080/ ) Some later keystrokes are interpreted as part of the previous keyboard shortcut in the Terminal Services session of a Remote Desktop window on a Windows Vista-based computer
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbhotfixserver kbqfe KB936970
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