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Article ID: 938656 - Last Review: October 8, 2011 - Revision: 2.0

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SYMPTOMS

On a Microsoft Windows Server 2003 R2-based domain controller, you receive the following error message when you use Active Directory Users and Computers to change the password of a user account:
The system is shutting down. Please save all work in progress and log off. Any unsaved changes will be lost. This shutdown was initiated by NT AUTHORITY\SYSTEM.

Time before shutdown: 00:00:30

The system process 'WindowsFolder\system32\lsass.exe' terminated unexpectedly with status code ErrorCode. The system will now shut down and restart.
Then, the computer automatically restarts.

This problem occurs if the following conditions are true:
  • The Identity Management for UNIX component is installed on the domain controller.
  • UNIX attributes are enabled in the user account whose password was changed.
  • Password synchronization is enabled between the Windows domain and a UNIX system.
  • Password synchronization is configured to use Message Digest 5 (MD5) as the encryption scheme.

CAUSE

This problem occurs because the password synchronization module incorrectly deallocates a resource. In this situation, an access violation causes the Lsass.exe process to stop unexpectedly.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pswdsync.dll9.0.3790.410671,16827-Jun-200715:44x86
Windows Server 2003 R2 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pswdsync.dll9.0.3790.410676,80027-Jun-200712:59x64
Windows Server 2003 R2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pswdsync.dll9.0.3790.296271,16827-Jun-200715:49x86
Windows Server 2003 R2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pswdsync.dll9.0.3790.296276,80027-Jun-200712:47x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Server for NIS configuration, visit the following Microsoft TechNet Web site:
http://technet2.microsoft.com/WindowsServer/en/library/ad4f834e-5886-4d21-b377-bbf3efbf4f8a1033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/library/ad4f834e-5886-4d21-b377-bbf3efbf4f8a1033.mspx?mfr=true)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
Keywords: 
kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbqfe KB938656
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