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Article ID: 940845 - Last Review: September 10, 2013 - Revision: 10.0

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Symptoms

After you install Microsoft Exchange Server 2007 or Microsoft Exchange Server 2010 on a global catalog server, the Exchange Server services do not start. Other services can be started manually.

Because of this problem, servers that are in this configuration may take a long time to shut down.

Additionally, the following events are recorded in the Application log, and can be viewed by using Event Viewer:
  • Event ID : 1005
    Source : MSExchangeSA
    Category : General
    Type : Error
    Description : Unexpected error The Local Security Authority cannot be contacted ID no: 80090304 Microsoft Exchange System Attendant occurred.
  • Event ID: 2601
    Source: MSExchange ADAccess
    Category: General
    Type: Warning
    Description: Process MSEXCHANGEADTOPOLOGY (PID=1624). When initializing a remote procedure call (RPC) to the Microsoft Exchange Active Directory Topology service, Exchange could not retrieve the SID for account <WKGUID=DC1301662F547445B9C490A52961F8FC,CN=Microsoft Exchange,CN=Services,CN=Configuration,...> - Error code=80040934. The Microsoft Exchange Active Directory Topology service will continue starting with limited permissions.
  • Event ID: 1121
    Source: MSExchangeIS
    Category: General
    Type: Error
    Description: Error 0x96e connecting to the Microsoft Active Directory.
  • Event ID: 5000
    Source: MSExchangeIS
    Category: General
    Type: Error
    Description: Unable to initialize the Microsoft Exchange Information Store service. - Error 0x96e.
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Note Recent versions of Microsoft Exchange Server have less dependency on the Microsoft Exchange System Attendant. For example, the Microsoft Exchange Information Store service no longer depends on the Microsoft Exchange System Attendant. Therefore, the symptoms that are described in this article may differ from the symptoms that you experience in an earlier version of Microsoft Exchange Server.

Cause

This problem may occur if the domain controller services and other Exchange-Server-dependent services have not started completely when Exchange Server 2007 or Exchange Server 2010 tries to start. Exchange Server depends on other services before it can start.

Workaround

To work around this problem, use one of the following methods.

Method 1: Manually start the services

If Windows informs you that a problem occurred when the Exchange Server services tried to start, you can manually start all required Exchange Server services. To do this, follow these steps:
  1. Log on to the affected server.
  2. On the Start menu, click Run, type services.msc, and then click OK.
  3. In the Results pane, find a Microsoft Exchange service.
  4. Right-click the service, and then click Restart.
  5. Repeat steps 3 and 4 for all Exchange services that do not start.

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    The screen shot of Services
Notes
  • Monitoring software will also detect that Exchange Server is not running.
  • On a server that uses a suitable uninterruptible power supply (UPS), restarts are usually overseen by an administrator.
  • Risks that cause additional downtime include unattended restarts or restarts that are generated by other employees.

Method 2: Change the dependencies

Use this method if an Exchange Server service does not depend on other Exchange Server services that depend directly on the Netlogon service and on the LSASS service. This method can be used to change the dependency of the Exchange Server service so that it does not try to start until the dependent services have started.

To have us change the dependencies for you, go to the "Fix it for me" section. If you prefer to change the dependencies yourself, go to the "Let me fix it myself" section.

Fix it for me

To change the dependencies automatically, click the Fix this problem link. Then, click Run in the File Download dialog box, and follow the steps in this wizard.
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Fix this problem (http://go.microsoft.com/?linkid=9705422)
Microsoft Fix it 50328
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Notes
  • This Fix it solution works for all languages. However, the wizard text may be in English for some languages.
  • If you are not currently on the computer that has the problem, save the Fix it solution to a flash drive or to a CD, and then run it on the computer that has the problem.

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  • To change the dependencies yourself on a Windows Server 2008-based server, use the values in the following table to determine the appropriate values for the dependencies.
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    Registry pathRegistry subkey (Multi_SZ)Registry value
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSADependOnServiceEventLog, RPCSS, LanmanWorkstation, LanmanServer, Netlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceNetlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeISDependOnServiceNetlogon
  • To change the dependencies yourself on a Windows Server 2003-based server, use the values in the following table to determine the appropriate values for the dependencies.
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    Registry pathRegistry subkey (Multi_SZ)Registry value
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSADependOnServiceEventLog, NtLmSsp, RPCSS, LanmanWorkstation, LanmanServer, Netlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceNetlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeISDependOnServiceNetlogon
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Note
If any Windows service cannot start, Exchange Server does not start. This method will not resolve the problem if any Windows service cannot start. However, this method should reduce the time that is required to shut down the server.

Method 3: Use BootPause to delay the startup of Exchange Server

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


Use the BootPause registry entry to delay the startup of Exchange Server. To do this, add the following registry subkey to the affected server to delay the start of the Microsoft Exchange System Attendant.
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Registry pathRegistry subkey (DWORD)Registry value (Decimal, the value is in seconds)
HKEY_LOCAL_MACHINE\\System\CurrentControlSet\Services\MSExchangeSA\ParametersBootPause 120
Note We recommend that you use 120 as a default value to resolve this issue. However, you may find that this value is not suitable for your environment. You can lower this value to shorten the delay for the Microsoft Exchange System Attendant to start, or you can increase this value to lengthen the delay, depending on your requirements.

You may also have to set the other Exchange Server services to depend on the Microsoft Exchange System Attendant. If you do not set the other Exchange Server services to depend on the Microsoft Exchange System Attendant, other Exchange Server services that access the directory will also fail. Services that depend on the Microsoft Exchange System Attendant could lead to other services shutting down when you restart the Microsoft Exchange System Attendant. The the following registry entry example shows how to set other Exchange Server services to depend on the Microsoft Exchange System Attendant.
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Registry pathRegistry subkey (Multi_SZ)Registry value
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceMSExchangeSA
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS DependOnServiceMSExchangeSA

Method 4: Set the Microsoft Exchange System Attendant and other services to restart automatically

Any service can be configured to restart automatically. If a service fails several times, let the service continue to restart on its own.

If you do not have monitoring software or monitoring event logs, the problem on the server will continue to occur. This method will not resolve the problem in this case. Additionally, the errors will still be logged. However, the Exchange Server services will eventually start.

To have us configure the Exchange Server services to restart automatically, go to the "Fix it for me" section. If you want to configure the Exchange services yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click Fix this problem. Then, click Run in the File Download dialog box, and follow the steps in this wizard.
Collapse this imageExpand this image
Fix this problem (http://go.microsoft.com/?linkid=9705835)
Microsoft Fix it 50329
Collapse this imageExpand this image

Notes
  • This Fix it solution works for all languages. However, the wizard text may be in English for some languages.
  • If you are not currently on the computer that has the problem, save the Fix it solution to a flash drive or to a CD, and then run it on the computer that has the problem.

Let me fix it myself

To configure a service to restart automatically, follow these steps:
  1. Open the properties of the Microsoft Exchange System Attendant in the Services MMC snap-in.
  2. Click Recovery.
  3. In the First failure box, click Restart the Service to restart the service on the first failure.
  4. In the Restart Service After box, type 3 so that the service restarts after three minutes.
  5. Repeat steps 1 through 4 for each Exchange Server service that does not start.

    Note You do not have to modify some newer Exchange Server services. For example, the Microsoft Exchange Transport service contains restart logic.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

Even after you follow the steps in this article, you may still have to set the other Exchange Server services to depend on the Microsoft Exchange System Attendant, as shown in the following example.
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Registry pathRegistry subkey (Multi_SZ) Registry value
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceMSExchangeSA
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeISDependOnService MSExchangeSA
Caution
  • If you do not set the other Exchange Server services to depend on the Microsoft Exchange System Attendant, other Exchange Server services that access the directory also fail.
  • Services that depend on the Microsoft Exchange System Attendant could lead to other services shutting down when you restart the Microsoft Exchange System Attendant.
Exchange Server has experienced this problem since Microsoft Exchange 2000 Server. We do not generally recommend that you run Exchange Server on a server that uses Active Directory Domain Services or Active Directory directory services. However, we do support this configuration because we recognize that it is sometimes necessary.

This problem persists in Exchange Server 2007 and in Exchange Server 2010. Some newer services, such as the Microsoft Exchange Transport service, have built-in solutions to this problem. However, the process of fixing this problem for older services is very complex. We hope to minimize this problem in future versions of Exchange Server.

For more information about event ID 1005, click the following article number to view the article in the Microsoft Knowledge Base:
318431  (http://support.microsoft.com/kb/318431/ ) An event ID 1005 error message is logged, and Microsoft System Attendant does not respond

Applies to
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard
Keywords: 
kbmsifixme kbfixme kbtshoot kbexpertiseinter kbprb KB940845
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