DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 941598 - Last Review: October 8, 2011 - Revision: 2.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

Consider the following scenario.
  • On Windows Server 2003-based computer, you create a share folder.
  • In this share folder, you create some subfolders and files.
  • You deny all users the List Folder/Read Data permission to this share folder.
  • You enable Access-based Enumeration for this share folder.
When a user tries to access the subfolders or the files in the share folder from a Windows XP-based computer, the user enters the Universal Naming Convention (UNC) paths of the subfolders or the files in the Address bar of Windows Explorer. In this situation, the user receives an error message that resembles one of the following error messages:
  • The path for the folder cannot be found.
  • Access is denied.
Notes
  • This problem will not occur if the user accesses the subfolders or the files at a command prompt.
  • This problem will not occur if you disable Access-based Enumeration for the share folder.

CAUSE

This problem occurs because of an error in the Shell32.dll file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply the hotfix, you must have Windows XP Service Pack 2 (SP2) installed.

Restart requirement

You have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Shell32.dll6.0.2900.31988,459,26421-Aug-200709:34x86SP2
Xpsp3res.dll5.1.2600.3158350,72019-Jun-200704:31x86SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Access-based Enumeration is a new feature that is included in Windows Server 2003 Service Pack 1. This feature lets users of Windows Server 2003–based file servers to list only the files and folders to which they have access when they browse content on the file server. This eliminates the confusion that may occur when users connect to a file server, and then they encounter lots of files and folders that they cannot access.

For more information about Access-based Enumeration, visit the following Microsoft Web site:
http://technet2.microsoft.com/windowsserver/en/library/f04862a9-3e37-4f8c-ba87-917f4fb5b42c1033.mspx?mfr=true (http://technet2.microsoft.com/windowsserver/en/library/f04862a9-3e37-4f8c-ba87-917f4fb5b42c1033.mspx?mfr=true)
To download Access-based Enumeration, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=04a563d9-78d9-4342-a485-b030ac442084 (http://www.microsoft.com/downloads/details.aspx?FamilyID=04a563d9-78d9-4342-a485-b030ac442084)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbfix kbexpertiseadvanced kbqfe kbHotfixServer KB941598
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support