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Article ID: 942485 - Last Review: April 30, 2008 - Revision: 3.1

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SYMPTOMS

After you install and try to start one of the Microsoft Money programs that are listed in the "Applies to" section, you may experience one of the following symptoms:
  • Money stops responding (hangs).
  • Money closes unexpectedly.
  • You receive the following error message:
    Money has stopped working

CAUSE

This issue may occur if the following conditions are true:
  • Data Execution Prevention (DEP) is turned on for all programs and services.
  • The Money program files are not in the exclusion list.
  • Certain modules on Money's home page may be taking a long time to finish loading.

    Note Some modules on Money's home page can cause Money to appear to hang or stop responding. For more information, see Microsoft Knowledge Base article in the "More Information" section.
  • There are lots of unaccepted transactions that have been downloaded but not yet processed.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Download and install Money Plus Service Pack 1

These issues were resolved in Microsoft Money Plus Service Pack (SP1).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
927811  (http://support.microsoft.com/kb/927811/ ) You receive a message when you start Money 2007 or Money Plus: "Money requires a software update"
If you are using Money 2006 or Money 2007 and if you are considering an upgrade to Money Plus, you can explore the Trial version of Money Plus. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/money/freetrial_deluxe.mspx (http://www.microsoft.com/money/freetrial_deluxe.mspx)
If you have installed Money Plus SP1 (version 17.x.xxx.1414) or if you are not using Money Plus and you still experience this issue, use one of the other methods that are described in this article.

Notes
  • When your computer is connected to the Internet, Money Plus SP1 is automatically downloaded and the dialog box that prompts you to update is displayed. To install Money Plus SP1, follow the instruction in the dialog box.
  • If the Money program stops responding or closes unexpectedly while you are trying to install Money Plus SP1, follow the steps in method 3, and then install Money Plus SP1.
  • When Money Plus SP1 is installed, restore the DEP settings.

Method 2: Add the Money executable files to the DEP exclusion list

  1. Open the Folder Options item in Control Panel.
    • In Windows Vista, click Start
      Collapse this imageExpand this image
      the Start button
      , type Folder Options in the Start Search box. Then, click Folder Options in the Programs list.

      Collapse this imageExpand this image
      User Account Control permission
      If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    • In Windows XP and in earlier versions of Windows, click Start, click Run, type Control folders, and then click OK.
  2. Click the View tab.
  3. In the Advanced settings list, click Show hidden files and folders under Hidden files and folders.
  4. Click to clear the Hide protected operating system files (Recommended) check box.
  5. Close the Folder Options dialog box. To do this, click OK.
  6. In the System Properties dialog box, open the Advanced tab. To do this, use one of the following methods:
    • In Windows Vista, click Start
      Collapse this imageExpand this image
      Start button
      , right-click Computer, click Properties, and then click Advanced system settings.

      Collapse this imageExpand this image
      User Account Control permission
      If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    • In Windows XP, click Start, right-click My Computer, click Properties, and then click the Advanced tab.
  7. Under Performance, click Settings.
  8. Click the Data Execution Prevention tab.
  9. Click Turn on DEP for all programs and services except those I select.
  10. Click Add, and then locate the MNYCoreFiles folder. By default, the MNYCoreFiles folder is located in the following folder:
    C:\Program File\Money Version
  11. Click the Money file that you want to add, and then click Open. You must add the following Money files to the Data Execution Prevention tab:
    • Activate.exe
    • Daupdate.exe
    • Extend.exe
    • Mnybb.exe
    • Mnyinsit.exe
    • Msmoney.exe
    Note Activate.exe and Extend.exe are included only with Money Plus.

    After you add the Money files, the Data Execution Prevention tab should resemble the following tab:
    Collapse this imageExpand this image
     Data Execution Prevention tab
  12. Click OK to close the Performance Options dialog box.
  13. Click OK to the following message:
    The changes you have made require you to restart your computer before they can take effect.
  14. Close the System Properties dialog box. To do this, click OK.
  15. Restart the computer.

Method 3: Change the DEP settings

  1. In the System Properties dialog box, open the Advanced tab. To do this, use one of the following methods:
    • In Windows Vista, click Start
      Collapse this imageExpand this image
      Start button
      , right-click Computer, click Properties, and then click Advanced system settings.

      Collapse this imageExpand this image
      User Account Control permission
      If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    • In Windows XP, click Start, right-click My Computer, click Properties, and then click the Advanced tab.
  2. Under Performance, click Settings.
  3. Click the Data Execution Prevention tab.
  4. Click Turn on DEP for essential Windows programs and services only, and then click OK.
  5. When you receive the following message, click OK:
    The changes you have made require you to restart your computer before they can take effect.
  6. Close the System Properties dialog box. To do this, click OK.
  7. Restart the computer.

Method 4: Accept the backlog of unaccepted transactions

Lots of transactions that may have downloaded from your financial institutions but have not yet been "accepted" into their account registers can cause Money to appear to stop responding as it tries to process them all. To resolve this issue, follow these steps:
  1. Disable your computer's network connection and verify that the computer can no longer access the Internet. This will help make sure that Money does not try to download any new transactions while it is finishing the update.
  2. Start Money with the file that is experiencing this issue.
  3. Let Money run as long as it takes to complete the “Updating accounts…” phase. Notice that if the “Updating accounts…” phase appears done, there may still be more batches of statements to process, which you can trigger by moving your pointer over the main Money window. When the “Updating accounts…” phase is completely done and moving the pointer over the main Money window does not cause it to start again, you can go to the next step.
  4. Go into each of your banking-type accounts (not loans, not investments), in the task list on the left side look for “Reconcile transactions.” If it is present, click it, and then click Accept all transactions to accept all the matches in the resulting fly-out menu.
  5. Double-check that your accounts still do not have any unaccepted matches.
You can re-enable the computer’s network connection and the next time that the statements are downloaded either manually by you or automatically by background banking, the “Updating accounts…” phase should complete fairly quickly.

To prevent your file from being stuck in this situation again, be diligent about frequently accepting unaccepted matches. These appear as bold transactions in your register. Do not let more than 100 matches build up in any given account.

Note You may want to consider enabling the Money Setting that allows for Money to automatically accept all downloaded transactions. To do this, click Settings under Tools, and then click Online Services Settings.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
926229  (http://support.microsoft.com/kb/926229/ ) Money may stop responding or close when you open the home page or when you access reports

APPLIES TO
  • Microsoft Money Essentials
  • Microsoft Money Plus Deluxe
  • Microsoft Money Plus Home & Business
  • Microsoft Money Plus Premium
  • Microsoft Money 2006 Deluxe
  • Microsoft Money 2006 Premium
  • Microsoft Money 2006 Small Business
  • Microsoft Money 2006 Standard
  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium
Keywords: 
kbgraphxlink kbcrashes kbstartprogram kbstoprespond kbtshoot kberrmsg kbexpertisebeginner kbprb KB942485
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