DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 948065 - Last Review: February 20, 2008 - Revision: 1.1

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows XP and Windows Vista

On This Page

SYMPTOMS

When you try to visit the Windows Update Web site, you receive the following error message:
0x8ddd0007 You need to restart your computer to finish installing a program or updates. You cannot view or get other updates from the site until you restart.

CAUSE

This problem occurs because of an incorrect value in a registry entry.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, use one of the following methods.

Resolution 1

Restart the computer. Then, try again to visit the Windows Update Web site.

Resolution 2

Delete the RebootRequired registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\AutoUpdate
  3. Right-click the RebootRequired registry entry, click Delete, and then click OK to confirm.
  4. Restart the computer, and then try again to visit the Windows Update Web site.

APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbtshoot kbexpertiseinter kbregistry kbprb KB948065
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support