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Article ID: 955832 - Last Review: October 8, 2011 - Revision: 2.0

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SYMPTOMS

On a Windows XP-based computer, you use Windows Internet Explorer to make a Secure Sockets Layer (SSL) connection to an HTTPS Web site. Additionally, this Web site is certified by a Digital Signature Standards (DSS) certificate. In this scenario, the SSL connection may fail, and you cannot surf the Web site by using Internet Explorer.

This problem may occur for one of the following conditions reasons:
  • The length of the prime modulus (P) of the Digital Signature Algorithm (DSA) that is used on the Web server is less than 128 bits.
  • The length of the DSS key that is used on the Web server is less than 128 bits.
Notes
  • This problem may also occur on a Windows Server 2003-based computer on which you are running Microsoft Internet Explorer 6 or Windows Internet Explorer 7.
  • This problem does not occur on a Windows Vista-based or Windows Server 2008-based computer.

CAUSE

This problem may occur when the length of the prime modulus P of the Digital Signature Algorithm (DSA) that is used on the Web Server is greater than the length of the public key that is used for the key exchange in the SSL transaction.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Schannel.dll5.1.2600.3436144,89628-Aug-200814:28x86
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Schannel.dll5.1.2600.5665144,89628-Aug-200813:45x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe KB955832
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