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Article ID: 956302 - Last Review: August 15, 2008 - Revision: 1.2

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SYMPTOMS

Assume that you are running Windows Media Center TV Pack on a Windows Vista-based computer. When you try to search for television content by using an element such as the title, a keyword, an actor, or a director, you may not receive any results. If you run the search immediately after you finish the "Set up TV" process, this is the expected behavior because the indexing process takes some time. However, even about four hours after the "Set up TV" process is complete, you may still be unable to search for television content.

CAUSE

This problem occurs when a Windows Media Center request to index the search root of the Media Center Guide is dropped.

RESOLUTION

Resolution 1: Upgrade to Windows Search 4.0

Resolution 1 contains three steps. Because any of these steps may resolve the problem, we suggest that you rerun your search after each step.

Step 1

Upgrade to Windows Search 4.0. To download Windows Search 4.0, visit the following Microsoft Web site:
http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowssearch4.mspx?tab=Install%20It (http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowssearch4.mspx?tab=Install%20It)

Step 2

Make sure that the Windows Media Center index location is listed in the Indexing Options dialog box. To do this, follow these steps:
  1. Click Start, click Control Panel, and then click System and Maintenance.

    Note If you are in Classic View mode, click Control Panel Home in the navigation pane.
  2. Click Indexing Options, and then verify that the Windows Media Center index location is listed under Included Locations in the Indexing Options dialog box.
  3. If the Windows Media Center index location is not listed, follow these steps:
    1. Click the Start, and then type cmd in the Start Search box.
    2. Right-click Command Prompt in the program list, and then click Run as administrator.
    3. At the command prompt, type cd %windir%\ehome, and then press ENTER.
    4. Run the ehprivjob /DoRegisterSearch command.

      Note There is no output from this command.
    5. Close and then reopen the Indexing Options item in Control Panel. Then, verify that the Windows Media Center index location is present and that the number of indexed items is increasing.

Step 3

If the Windows Media Center index location is present, but the problem still occurs, rebuild the indexed locations on your computer. To do this, follow these steps:
  1. In the Indexing Options window, click Advanced.
  2. Click Rebuild, and then click OK.
This operation may take several minutes or longer. During this time, you may notice that the number of indexed items increases.

Resolution 2: Re-index the search root in Windows Search 3

If you decided not to upgrade as suggested in Resolution 1, follow these steps:
  1. At a command prompt, type cd %windir%\ehome, and then press ENTER.
  2. Run the ehprivjob /DoReindexSearchRoot command.

    Note There is no output from this command.
  3. Close and then reopen the Indexing Options item in Control Panel to verify that the Windows Media Center index location is present and that the number of indexed items is increasing.
  4. Rerun your search.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Windows Search 4.0, visit the following Microsoft Web site:
http://www.microsoft.com/windows/products/winfamily/desktopsearch/default.mspx (http://www.microsoft.com/windows/products/winfamily/desktopsearch/default.mspx)
For help with Windows Search problems in Windows Vista, visit the following Microsoft web page:
Fix problems in which Windows Search is not working or searches are slower (http://support.microsoft.com/gp/windows_search)

APPLIES TO
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Ultimate
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