DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 956703 - Last Review: September 9, 2008 - Revision: 2.0

SYMPTOMS

When you try to install updates by using either the Windows Update or Microsoft Update Web site, you may receive the following error message:
0x80080008
This problem may occur in any of the following scenarios:
  • You repair your Windows XP Service Pack 2 (SP2) installation by using the Windows XP SP2 CD. Then, you install Windows XP Service Pack 3 (SP3) before you update the Windows Update software to the current version.
  • You perform a clean install of Windows XP SP2. Then, you install Windows XP SP3 before you update the Windows Update software to the current version.
  • The current version of Windows Update is not installed and registered correctly.

CAUSE

This problem occurs when the Windows Update agent file Wups2.dll is registered incorrectly. When the registry files that correspond to the Wups2.dll file are missing, update installations are unsuccessful.

RESOLUTION

To resolve this problem, use the following methods in the order in which they are presented.

Method 1: Register the Windows Update files

If you are running Windows XP, Windows Server 2003, or Windows 2000, follow these steps:
  1. Click Start, click Run, type notepad, and then click OK.
  2. Copy the following commands, and then paste them into the Notepad window:
    REGSVR32 WUPS2.DLL /S 
    REGSVR32 WUPS.DLL /S 
    REGSVR32 WUAUENG.DLL /S 
    REGSVR32 WUAPI.DLL /S 
    REGSVR32 MUCLTUI.DLL /S 
    REGSVR32 WUCLTUI.DLL /S 
    REGSVR32 WUWEB.DLL /S 
    REGSVR32 MUWEB.DLL /S 
    REGSVR32 QMGR.DLL /S 
    REGSVR32 QMGRPRXY.DLL /S
    
  3. On the Notepad File menu, click Save As.
  4. In the Save as type list, click All Files (*.*).
  5. In the File name box, type register.bat.
  6. Save the register.bat file to your desktop.
  7. Double-click the register.bat file to register the Windows Update files.
  8. Try to install updates again.
If you are running Windows Vista or Windows Server 2008, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , and then type notepad in the Start Search box.
  2. Click Notepad in the Programs list.
  3. Copy the following commands, and then paste them into the Notepad window:
    REGSVR32 WUPS2.DLL /S 
    REGSVR32 WUPS.DLL /S 
    REGSVR32 WUAUENG.DLL /S 
    REGSVR32 WUAPI.DLL /S 
    REGSVR32 WUCLTUX.DLL /S 
    REGSVR32 WUWEBV.DLL /S  
    REGSVR32 JSCRIPT.DLL /S 
    REGSVR32 MSXML3.DLL /S
    
  4. On the Notepad File menu, click Save As.
  5. In the Save as type list, click All Files.
  6. In the File name box, type register.bat.
  7. Save the register.bat file to your desktop.
  8. Right-click the register.bat file, and then click Run as administrator.
    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  9. Try to install updates again.
Note If this method does not resolve your problem, go to Method 2.

Method 2: Download and install the Windows Update agent

For more information about how to download and install the latest Windows Update agent, click the following article number to view the article in the Microsoft Knowledge Base:
949104  (http://support.microsoft.com/kb/949104/ ) How to obtain the latest version of the Windows Update Agent to help manage updates on a computer

MORE INFORMATION

Error 0x80080008 is most frequently triggered by missing Wups2.dll registry keys. However, this problem may also occur when other keys are missing. By registering the Wups2.dll file and the other .dll files that are listed in Method 1, you make sure that any additional keys are also registered.

APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbtshoot kbexpertiseinter kbprb KB956703
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support