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Article ID: 957792 - Last Review: January 20, 2012 - Revision: 3.2

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SYMPTOMS

When you try to import an organization to Microsoft Dynamics CRM 4.0, you receive the following error message:
Error| Import Organization (Name=Company_Name, Id=OrganizationID) failed with Exception:
Microsoft.Crm.Metadata.EntityMetadataNotFoundException: The entity with a name = entity name was not found in the MetadataCache.
at Microsoft.Crm.Metadata.DynamicMetadataCache.GetEntity(String entityName, NameMappingType mapping)
at Microsoft.Crm.Metadata.DynamicMetadataCache.GetEntity(String entityName)
at Microsoft.Crm.Tools.Admin.PublishHelper.GetEntityMetadata(IOrganizationContext context, String entityName)
at Microsoft.Crm.ObjectModel.WorkflowServiceInternal`1.AddSdkMessageDependencies(List`1 dependencies, ExecutionContext context, WorkflowStep workflowStep)
at Microsoft.Crm.ObjectModel.WorkflowServiceInternal`1.CreateDefinitionFromObjectModel(ExecutionContext context, WorkflowEntity definition, List`1 dependencies, List`1 customActivityIds)
at Microsoft.Crm.ObjectModel.WorkflowServiceInternal`1.PublishInPlace(WorkflowEntity definition, ExecutionContext context)
at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.RepublishWorkflow(ExecutionContext context, WorkflowUIData workflowData)
at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.ProcessWorkflowUIData(ExecutionContext context)
at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.Import(Guid organizationId, String organizationUniqueName, String organizationFriendlyName, String sqlServerName, String databaseName, Uri reportServerUrl, String privilegedUserGroupName, String sqlAccessGroupName, String userGroupName, String reportingGroupName, String privilegedReportingGroupName, ICollection`1 users, MultipleTenancy multipleTenancy)

CAUSE

This problem occurs because the MetadataCache lookup does not use the correct NameMappingType parameter when an organization is imported. This occurs if you import to a deployment that already contains published workflows that have the SystemUser lookup and the onUpdate trigger.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM software hotfix and update package naming standards

APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kberrmsg kbfix kbautohotfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver KB957792
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