DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 958055 - Last Review: September 26, 2008 - Revision: 1.0

On This Page

SYMPTOMS

When you search for available updates on the Windows Update Web site or the Microsoft Update Web site, you receive the following error code:
0x8007064C

CAUSE

This problem may occur if Windows Update or Microsoft Update cannot locate the downloaded update.

RESOLUTION

To resolve this problem, follow the steps that are listed in the following methods. Start with method 1. If method 1 does not resolve the problem, go to method 2.

Method 1: Rename the Windows Update Download folder

To resolve the problem, rename the Windows Update temporary download folder.

To rename the Windows Update temporary download folder, follow the steps that are appropriate for your version of Windows.

Important Updates that are currently downloaded but that have not yet been installed must be downloaded again by using the Windows Update Web site or the Microsoft Update Web site.

Windows Vista and Windows Server 2008

For Windows Vista and Windows Server 2008, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
     Start button
    , type notepad in the Start Search box, and then press ENTER.
  2. Paste the following commands into the new Notepad document:
    net stop wuauserv

    cd %systemroot%\SoftwareDistribution

    ren Download Download.old

    net start wuauserv
  3. On the File menu, click Save As.
  4. In the Save in box, click Desktop.
  5. In the Save as type box, click All Files.
  6. In the File name box, type Rename.bat.
  7. Click Save.
  8. On the File menu, click Exit to exit Notepad.
  9. On your desktop, right-click Rename.bat and then click Run as Administrator.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  10. Try to install the update by using the Windows Update Web site or the Microsoft Update Web site.
  11. If the update is installed successfully, delete the Rename.bat file that you saved in steps 1 through 7.

Windows 2000, Windows XP, and Windows Server 2003

For Windows 2000, Windows XP, and Windows Server 2003, follow these steps:
  1. Click Start, click Run, type notepad in the Open box, and then click OK.
  2. Paste the following commands into the new Notepad document:
    net stop wuauserv

    cd %systemroot%\SoftwareDistribution

    ren Download Download.old

    net start wuauserv
  3. On the File menu, click Save As.
  4. In the Save in box, click Desktop.
  5. In the Save as type box, click All Files.
  6. In the File name box, type Rename.bat.
  7. Click Save.
  8. On the File menu, click Exit to exit Notepad.
  9. On your desktop, double-click Rename.bat.
  10. Try to install the update by using the Windows Update Web site or the Microsoft Update Web site.
  11. If the update is installed successfully, delete the Rename.bat file that you saved in steps 1 through 7.
Notes
  • If the problem is not resolved, go to method 2.
  • If the problem is resolved and you can successfully download and install updates, you can safely delete the Download.old folder to recover disk space.

Method 2: Download and install the update manually

To download and install the update manually, follow these steps:
  1. Determine the Microsoft Knowledge Base article number of the failed update. To do this, take one of the following actions:
    • View the error code message.
    • View the update history on the Windows Update Web site or on the Microsoft Update Web site. To do this, follow these steps:
      1. Visit the following Microsoft Update Web site:
        http://update.microsoft.com (http://update.microsoft.com)
      2. Click Review your update history under Options.
      3. In the Update column, determine the Microsoft Knowledge Base article number of the failed update.
  2. Visit the following Windows Download Web site:
    http://www.microsoft.com/windows/downloads/default.aspx (http://www.microsoft.com/windows/downloads/default.aspx)
  3. In the Search box on the Downloads Web page, type the Microsoft Knowledge Base article number that you determined in step 1, and then click Go.

    Note If the Microsoft Knowledge Base article number that is listed for the update is KB123456, type 123456 in the Search box on the Downloads Web page, and then click Go.
  4. Browse the list of returned content to locate the Knowledge Base article that has a link to the download.

    Note You may be prompted to validate Windows. If you are prompted, follow the instructions to validate Windows, and then continue with the download.
  5. Click Download, and then click Save when you are prompted to save the download. Save the download to your desktop.
  6. After the download has finished, click Open to install the update.
Note The installation of the update may still fail if the update is incorrect for your version of Windows.

APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbexpertisebeginner kbtshoot kberrmsg kbprb KB958055
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support