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Article ID: 959923 - Last Review: October 8, 2011 - Revision: 2.0

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SYMPTOMS

Consider the following scenario:
  • Active Directory Federation Services (AD FS) is installed on a Windows Server 2003 R2-based server.
  • You connect AD FS to an Active Directory Application Mode (ADAM) store.
  • The Enable Transport Layer Security (TLS) and Secure Sockets Layer (SSL) protocols check box is selected.
In this scenario, the connection between AD FS and the ADAM store fails. Additionally, you receive the following error message:
The server is not operational
When this issue occurs, the following information is logged in the Federation Server Debug log:

[INFO] GetClaimsForUserNameWorker (LDAP): called for user user name
[VERBOSE] GetClaimsForUserNameWorker (LDAP): Got COMException 18446744071562534970: The server is not operational.

CAUSE

This issue occurs because AD FS in Windows Server 2003 R2 does not support the connection to ADAM over SSL connections.

RESOLUTION

To resolve the issue, install hotfix 959923 on the Windows Server 2003 R2-based server that has AD FS installed. After you install this hotfix, AD FS can connect to ADAM stores over SSL connections.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 R2 and AD FS installed on the server.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.32847,68020-Jan-200913:29x86SP1
System.web.security.singlesignon.dll5.2.3790.3284581,63221-Jan-200907:29x86SP1
Windows Server 2003 R2 Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.44497,68020-Jan-200913:35x86SP2
System.web.security.singlesignon.dll5.2.3790.4449581,63221-Jan-200907:55x86SP2
Windows Server 2003 R2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.32849,21621-Jan-200906:29x64SP1
System.web.security.singlesignon.dll5.2.3790.3284581,63221-Jan-200906:29x86SP1
Windows Server 2003 R2 Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.44499,21621-Jan-200906:41x64SP2
System.web.security.singlesignon.dll5.2.3790.4449581,63221-Jan-200906:41x86SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

AD FS is a component of Windows Server 2003 R2. For more information, visit the following Microsoft TechNet Web site:
http://technet2.microsoft.com/WindowsServer/en/library/050392bc-c8f5-48b3-b30e-bf310399ff5d1033.mspx (http://technet2.microsoft.com/WindowsServer/en/library/050392bc-c8f5-48b3-b30e-bf310399ff5d1033.mspx)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB959923
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