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Article ID: 968225 - Last Review: October 7, 2011 - Revision: 2.0

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SYMPTOMS

Consider the following scenario:
  • Active Directory Application Mode (ADAM) Service Pack 1 (SP1) is installed on a computer that is running Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2).
  • Account lockout policy is configured and applied to ADAM. When you configure the Account lockout policy, you specify the number of invalid logon attempts that causes a user account to be locked in the Account Lockout Threshold Group Policy setting.
  • You try to bind to ADAM by using an ADAM user account whose password has expired.
In this scenario, the account lockout policy does not work correctly, and the BadPwdCount attribute on the user object is not incremented.

For example, the Account lockout policy is configured to lock a user account after three bad password attempts. In this scenario, the user account is not locked. Users can still try different passwords after three attempts.

Note This issue also occurs if administrators force ADAM users to change their passwords by setting the value of the pwdlastset attribute to 0.

CAUSE

ADAM does not increment the value of the BadPwdCount attribute when a wrong password is entered after the original password expires.

RESOLUTION

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.3299461,82423-Feb-200910:33x86
Windows Server 2003 SP2, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.4464454,65623-Feb-200910:48x86
Windows Server 2003, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.32991,059,32823-Feb-200908:29x64
Windows Server 2003 SP2, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.44641,059,32823-Feb-200908:35x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the BadPwdCount attribute, click the following article number to view the article in the Microsoft Knowledge Base:
900215  (http://support.microsoft.com/kb/900215/ ) How the BadPwdCount attribute works in Windows 2000 and in Windows Server 2003
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
919336  (http://support.microsoft.com/kb/919336/ ) Error message if you try to bind to ADAM by using an account that is locked out or that has an expired password
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684   (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB968225
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