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Article ID: 973678 - Last Review: February 15, 2011 - Revision: 3.0

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SYMPTOMS

Consider the following scenario:
  • You have two computers in a workgroup environment. One of the computers is running Windows Server 2003 Service Pack (SP2). The other computer is running Windows Server 2008 or Windows Server 2008 R2.
  • You install Active Directory Application Mode (ADAM) on the computer that is running Windows Server 2003 SP2.
  • You install Active Directory Lightweight Directory Services (AD LDS) on the computer that is running Windows Server 2008 or Windows Server 2008 R2.
  • You try to perform a replication between the ADAM database and the AD LDS database.
In this scenario, the replication process fails. Additionally, an Error event that resembles the following is logged to the ADAM event log of one of the computers:

Log Name: ADAM (instance)
Source: ADAM [instance] Replication
Date: date
Event ID: 1084
Task Category: Replication
Level: Error
Keywords: Classic
User: ANONYMOUS LOGON
Computer: ComputerName
Description:
Internal event: Active Directory Lightweight Directory Services could not update the following object with changes received from the following source directory service. This is because an error occurred during the application of the changes to Active Directory Lightweight Directory Services on the directory service.

Object:
object
Object GUID:
object GUID
Source directory service:
source

Synchronization of the directory service with the source directory service is blocked until this update problem is corrected.

This operation will be tried again at the next scheduled replication.

User Action
Restart the local computer if this condition appears to be related to low system resources (for example, low physical or virtual memory).

Additional Data
Error value:
2148074288 The specified data could not be decrypted.

CAUSE

In a workgroup environment, ADAM and ADLDS use NTLM for authentication and secure data exchange. NTLM sets up a session between ADAM in Windows Server 2003 and ADLDS in Windows Server 2008 or in Windows Server 2008 R2, and then NTLM exchanges a session key (public key) for this session. This key is generally used to encrypt and decrypt the data and is stored in NTLM.

For Windows Server 2003-based computers, NTLM returns no key to ADAM. Therefore, the default key is used to encrypt data. For computers that run Windows Server 2008 or Windows Server 2008 R2, NTLM returns the session key to ADLS. Therefore, the session key is used to encrypt data. Because different keys are used, a checksum mismatching occurs. This causes the replication failure that is described in the “Symptoms” section.

RESOLUTION

To resolve the issue, install the hotfix on the affected Windows Server 2003 SP2-based computer. After applying the hotfix, a registry value must be added on the Windows Server 2003 server to enable replication from each ADAM instance to the corresponding AD LDS instance on Windows Server 2008 and Windows Server 2008 R2:

Reg Subkey = "HKLM\System\CurrentControlSet\Services\<ADAM_Instance_Name>\Parameters"
Registry Value = NTLMSessionKey
Type = DWORD
Value = 0x1

The registry value has to be added on a per instance basis. 


Note After you apply the hotfix and set the registry value to 0x1, the following replications will fail:
  • Replications between ADAM in Windows XP and patched ADAM in Windows Server 2003.
  • Replications between patched ADAM in Windows Server 2003 and unpatched ADAM in Windows Server 2003.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your must be running Windows Server 2003 SP2. For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Adamdsa.dll1.1.3790.47141,633,79224-May-201006:02x86SP2SP2QFE
Ksecdd.sys5.2.3790.4530135,16815-Jun-200917:07x86SP2SP2QFE
Msv1_0.dll5.2.3790.4714146,94424-May-201006:02x86SP2SP2QFE
Schannel.dll5.2.3790.4530151,04016-Jun-200907:21x86SP2SP2QFE
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Adamdsa.dll1.1.3790.47142,961,92024-May-201009:54x64SP2SP2QFE
Ksecdd.sys5.2.3790.4530190,97624-May-201009:55x64SP2SP2QFE
Msv1_0.dll5.2.3790.4714265,21624-May-201009:55x64SP2SP2QFE
Schannel.dll5.2.3790.4530259,07224-May-201009:56x64SP2SP2QFE
Wmsv1_0.dll5.2.3790.4714146,94424-May-201009:56x86SP2WOW
Wschannel.dll5.2.3790.4530151,04024-May-201009:56x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ksecdd.sys5.2.3790.4530322,04824-May-201009:55IA-64SP2SP2QFE
Msv1_0.dll5.2.3790.4714396,80024-May-201009:55IA-64SP2SP2QFE
Schannel.dll5.2.3790.4530474,62424-May-201009:56IA-64SP2SP2QFE
Wmsv1_0.dll5.2.3790.4714146,94424-May-201009:56x86SP2WOW
Wschannel.dll5.2.3790.4530151,04024-May-201009:56x86SP2WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about ADAM, view the following Microsoft website:
ADAM Concepts (http://technet.microsoft.com/en-us/library/cc776349(WS.10).aspx)
For more information about Active Directory, view the following Microsoft website:
General information about Active Directory (http://www.microsoft.com/windowsserver2008/en/us/ad-main.aspx)
For more information about Windows Data Protection, view the following Microsoft website:
General information about Windows Data Protection (http://msdn.microsoft.com/en-us/library/ms995355.aspx)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbqfe kbautohotfix kbHotfixServer kbexpertiseadvanced kbfix kbsurveynew KB973678
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