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Article ID: 976658 - Last Review: December 8, 2009 - Revision: 1.1

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SYMPTOMS

When you enable Internet Protocol security (IPsec) for the network communication on a computer that is running Windows Server 2008 R2 or Windows 7, the memory of the nonpaged pool may leak. This memory leak can cause the computer to stop responding. Therefore, you may have to restart the computer. Additionally, the following event may be logged in the Application log:

Event Type: Error
Event Source: Application Popup
Event Category: Srv
Event ID: 2019
Date: date
Time: time
User: N/A
Computer: computer name
Description: The server was unable to allocate from the system nonpaged pool because the pool was empty.

Note The issue occurs more frequently when the computer uses Internet Key Exchange (IKE) protocol version 2.

Consider the following scenario as an example:
  • The virtual private network (VPN) server role is installed on a computer that is running Windows Server 2008 R2.
  • IPsec is enabled for the network communication.
  • IKE protocol version 2 is used on the VPN server.
In this scenario, users cannot make a VPN connection to the VPN server, or the connected users lose their connections. Additionally, you have to restart the server to recover from the issue.

CAUSE

The issue is caused by the Tcpip.sys driver. After IPsec is enabled, the networking layer of the TCP/IP stack invokes the IPsec module for each IP datagram. When the IPsec module asynchronously finishes the call and reports a failure, the Tcpip.sys driver incorrectly leaks the nonpaged pool memory.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows 7

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 R2 and Windows 7 file information note
The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385187,47214-Jul-200901:20x86
Tcpip.sys6.1.7600.205661,287,24004-Nov-200907:17x86
For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385288,33614-Jul-200901:47x64
Tcpip.sys6.1.7600.205661,899,08004-Nov-200907:36x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385482,89614-Jul-200901:58IA-64
Tcpip.sys6.1.7600.205663,778,63204-Nov-200906:17IA-64


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 R2 and for Windows 7

Additional files for all supported x86-based versions of Windows 7


Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_for_kb976658_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,94704-Nov-200910:39Not Applicable
X86_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20566_none_b394a748e0c654cd.manifestNot Applicable3,78004-Nov-200910:43Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7


Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20566_none_0fb342cc9923c603.manifestNot Applicable3,78404-Nov-200910:46Not Applicable
Package_for_kb976658_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable2,18104-Nov-200910:39Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2


Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20566_none_b3964b3ee0c45dc9.manifestNot Applicable3,78204-Nov-200910:40Not Applicable
Package_for_kb976658_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,68304-Nov-200910:39Not Applicable

REFERENCES

For more information about the IKE protocol version 2, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/dd469817(WS.10).aspx (http://technet.microsoft.com/en-us/library/dd469817(WS.10).aspx)

For more information about Request for Comments (RFC) 4306, visit the following Web site:
Internet Key Exchange (IKEv2) Protocol: http://www.ietf.org/rfc/rfc4306.txt (http://support.microsoft.com/?scid=internet%20key%20exchange%20%28ikev2%29%20protocol%3a%20http%3a%2f%2fwww.ietf.org%2frfc%2frfc4306.txt)

APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexpertiseinter kbsurveynew KB976658
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