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Article ID: 977629 - Last Review: April 14, 2010 - Revision: 1.0

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SYMPTOMS

Consider the following scenario:
  • You configure some Group Policy settings under the following node in Group Policy Object Editor on a Windows Server 2003-based terminal server:
    Computer Configuration\Administrative Templates\Windows Components\Terminal Services
  • The termsrv.dll file version is upgraded to either version 5.2.3790.3340 or to the latest file version by applying hotfix 970870 or other updates.
In this scenario, the new policy settings that you configured may not take effect after you restart the terminal server.

CAUSE

This issue occurs because of a similar timing issue to the one that is described in KB article 970870. After the timing issue occurs, the Terminal Service retrieves blank policies when it tries to apply Terminal Services Group Policies. The hotfix in KB article 97870 fixed the background policy update problem. However, it introduces a new timing issue that only occurs during startup. Therefore, after a terminal server restarts, Terminal Services Group Policies may not be applied.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replace a previously released hotfix 970870.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Regapi.dll5.2.3790.467656,83206-Mar-201004:51x86SP2
Termsrv.dll5.2.3790.4676246,27206-Mar-201004:51x86SP2
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.4676111,61606-Mar-201003:27x64SP2Not Applicable
Termsrv.dll5.2.3790.4676365,05606-Mar-201003:27x64SP2Not Applicable
Wregapi.dll5.2.3790.467656,83206-Mar-201003:27x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.4676144,89606-Mar-201003:26IA-64SP2Not Applicable
Termsrv.dll5.2.3790.4676699,39206-Mar-201003:26IA-64SP2Not Applicable
Wregapi.dll5.2.3790.467656,83206-Mar-201003:26x86SP2WOW

WORKAROUND

To work around this issue, run the gpupdate /force command to apply Terminal Services Group Policies.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about hotfix 970870, click the following article number to view the article in the Microsoft Knowledge Base:
970870  (http://support.microsoft.com/kb/970870/ ) On a Windows Server 2003-based terminal server, terminal service-related settings may not be effective if the "Process even if the group policy objects have not changed" option is enabled for Registry Policy Processing
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB977629
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