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Article ID: 978972 - Last Review: January 9, 2012 - Revision: 2.0

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SYMPTOMS

Consider the following scenario:
  • You have a computer that is running Windows Server 2003.
  • You install some mini-filter drivers. For example, you install Kaspersky Antivirus Client. This program will automatically install a mini-filter driver on the computer.
  • You rename a file or folder by using a Distributed File System (DFS) shared path.
In this scenario, the computer restarts automatically. Additionally, you receive the following Stop error message:

STOP: 0x000000027 (parameter1, parameter2, parameter3, parameter4)
RDR_FILE_SYSTEM (27)
Notes
  • The parameters in the Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x00000027" error messages are caused by this problem.

CAUSE

This problem occurs because of an interaction problem between the filter manager, the Distributed File System (DFS), the Multiple UNC Provider (MUP) and the Redirected Drive Buffering SubSystem (Rdbss.sys) driver. The filter manager frees a structure. However, the length of this structure is not set to zero by the MUP. When the Rdbss.sys driver tries to access this structure, the system triggers the Stop error because of an inconsistent state.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4651103,42418-Jan-201021:37x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4651180,22420-Jan-201001:53x64
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4651312,32020-Jan-201001:52IA-64

WORKAROUND

To work around this problem, uninstall the software that installs mini-filter drivers. For example, uninstall Kaspersky Antivirus Client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Keywords: 
kbexpertiseinter kbprb kbsurveynew kbHotfixServer kbautohotfix kbqfe kbfix KB978972
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