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Base de connaissances

Numéro d'article: 216783 - Dernière mise à jour: mardi 27 février 2007 - Version: 6.4

 

Sommaire

Symptômes

Une fois un client Terminal Server perd la connexion à un serveur Terminal Server, la session sur le serveur Terminal Server ne peut pas passer à un état déconnecté, au lieu de cela, il peut rester actif même si le client est déconnecté physiquement le serveur Terminal Server. Si le client ouvre une session dans le même serveur Terminal Server, une totalement nouvelle session peut être établie et la session d'origine peut toujours rester active.

Cause

Ce problème peut se produire parce que Terminal Server implémente un mécanisme Keep Alive.

Résolution

Important Cette section, la méthode ou la tâche contient vous explique comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous que vous procédez comme suit. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre en cas de problème. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
322756  (http://support.microsoft.com/kb/322756/ ) Comment faire pour sauvegarder et restaurer le Registre de Windows

Windows NT 4.0 Édition Terminal Server

Pour contourner ce problème, procédez comme suit :
  1. Appliquez le dernier service pack pour Windows NT 4.0, Édition Terminal Server.
  2. Utilisez l'Éditeur du Registre pour ajouter une valeur DWORD KeepAliveEnable, avec une valeur numérique positive de 1 (qui représente une minute) de la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. Dans l'outil Configuration des connexions Terminal Server, double-cliquez sur rdp-tcp, puis cliquez sur Avancé.
  4. Sur la sur une connexion interrompue ou expiré, <Connectez l'action > la session ligne, désactivez l'option hériter de la configuration de l'utilisateur. Cliquez sur déconnecter sur sur une connexion interrompue ou expiré, <Connectez l'action > la session, puis cliquez sur OK.

Windows 2000 Server

Pour contourner ce problème, procédez comme suit :
  1. Utilisez l'Éditeur du Registre pour ajouter une valeur DWORD KeepAliveEnable, avec une valeur numérique positive de 1 (qui représente l'activer) de la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  2. Ouvrir la Configuration des Services Terminal Server dans les Outils d'administration, double-cliquez sur RDP-Tcp dans le dossier connexions et cliquez sur l'onglet sessions.
  3. Sélectionnez Remplacer les paramètres de l'utilisateur, assurez-vous que l'option déconnexion de la session est sélectionnée, puis cliquez sur OK.

Windows XP et Windows Server 2003

Pour contourner ce problème, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez sur exécuter, tapez gpedit.msc et cliquez sur OK.
  2. Développez Configuration ordinateur, développez Modèles d'administration, développez Composants Windows, puis cliquez sur Services Terminal Server.
  3. Dans le volet droit, double-cliquez sur Connexions persistantes.
  4. Cliquez sur activé, puis cliquez sur OK.
  5. Éditeur d'objets de stratégie de groupe Fermer, cliquez sur OK et fermez Active Directory utilisateurs et ordinateurs.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Mots-clés : 
kbmt kbnetwork kbprb kbui KB216783 KbMtfr
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La version anglaise de cet article est la suivante: 216783  (http://support.microsoft.com/kb/216783/en-us/ )
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