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Base de connaissances

Numéro d'article: 2258121 - Dernière mise à jour: samedi 14 mai 2011 - Version: 4.0

Sommaire

Symptômes

Lorsque vous essayez d'installer des mises à jour pour des applications Microsoft Office par le biais de Windows Update ou Microsoft Update, l'un des codes d'erreur suivants peut s'afficher :

Erreur 1
0x80070646

Erreur 2
646

Erreur 3
« Erreur 1606. Impossible d'accéder à l'emplacement réseau %APPDATA% »

Cause

Ce problème se produit lorsque Windows Installer rencontre une erreur. Les codes d'erreur 0x80070646 et 646 sont générés par Windows Installer. Ces erreurs génériques indiquent que Windows Installer a rencontré un problème. Lorsque vous rencontrez les erreurs décrites dans la section « Symptômes », le problème peut être causé par une valeur incorrecte dans le Registre.

Résolution

Pour mettre à jour automatiquement les clés de Registre concernées, cliquez sur le bouton dans la section « Aidez-moi ». Si vous préférez vérifier et mettre à jour ces clés vous-même, consultez la section « Je résous le problème moi-même ».


Aidez-moi


Résoudre ce problème
Microsoft Fix it 50461

Remarque Cet Assistant peut n'exister qu'en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.

Remarque Si vous n'utilisez pas actuellement l'ordinateur sur lequel ce problème survient, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM et l'exécuter ensuite sur l'ordinateur concerné par le problème.


Je résous le problème moi-même

Pour résoudre ce problème, vérifiez la valeur de la clé AppData dans le Registre. Pour ce faire, suivez les étapes de la procédure qui s'applique à votre système d'exploitation :


Pour les utilisateurs de Windows 7 et de Windows Vista
  1. Cliquez sur Démarrer, puis dans la zone Rechercher, tapez regedit.
  2. Dans la liste des programmes, cliquez avec le bouton droit de la souris sur Regedit.exe, puis cliquez sur Exécuter en tant qu'administrateur. Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe ou cliquez sur Continuer.
  3. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  4. Dans le volet d'informations de l'Éditeur du Registre, recherchez AppData. La valeur de cette clé doit être % USERPROFILE%\\AppData\Roaming.
  5. Si la valeur n'est pas définie sur % USERPROFILE%\AppData\Roaming, cliquez avec le bouton droit sur AppData dans le volet d'informations, puis cliquez sur Modifier.
  6. Entrez %USERPROFILE%\AppData\Roaming dans la zone Données de la valeur, puis cliquez sur OK.
  7. Fermez l'Éditeur du Registre.
  8. Essayez de réinstaller la mise à jour. Si le problème persiste, répétez cette procédure mais en utilisant les sous-clés de Registre suivantes plutôt que celle spécifiée à l'étape 3 :
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Pour les utilisateurs de Windows XP
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Dans la liste Programmes, cliquez sur Regedit.exe. Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe ou cliquez sur Continuer.
  4. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  5. Dans le volet d'informations de l'Éditeur du Registre, recherchez AppData. La valeur de cette clé doit être %USERPROFILE%\\Application Data.
  6. Si la valeur n'est pas définie sur %USERPROFILE%\Application Data, cliquez avec le bouton droit sur AppData dans le volet d'informations, puis cliquez sur Modifier.
  7. Dans la zone Données de la valeur, entrez %USERPROFILE%\Application Data, puis cliquez sur OK.
  8. Fermez l'Éditeur du Registre.
  9. Essayez de réinstaller la mise à jour. Si le problème persiste, répétez cette procédure mais en utilisant les sous-clés de Registre suivantes plutôt que celle spécifiée à l'étape 4 :

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Update
Mots-clés : 
kbfixme kbmsifixme KB2258121
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