DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 823093 - Dernière mise à jour: lundi 30 octobre 2006 - Version: 5.2

 

Symptômes

Lorsque vous utilisez l'Assistant tâches planifiées pour planifier une tâche, la tâche s'exécute comme prévu. Toutefois, si vous utilisez l'outil de ligne de commande Schtasks.exe pour créer une grille pour la même tâche, la tâche ne s'exécute pas en temps lorsque vous planifié. En outre, lorsque vous affichez la tâche dans la boîte de dialogue tâches planifiées , le texte suivant s'affiche dans la colonne État :
N'a pas pu démarrer

Cause

Ce problème se produit si le chemin d'accès de la tâche planifiée contient un espace. Par exemple, ce problème se produit si vous créez une planification pour la tâche suivante à l'aide de Schtasks.exe :
« \task.bat c:\ foldername containing spaces »
Dans cet exemple, Schtasks.exe traite tout après le premier espace dans le chemin d'accès comme un argument de ligne de commande.

Contournement

Pour contourner ce problème, mettez la partie de chemin d'accès de la tâche (sans compter les arguments ou les commutateurs) entre la barre oblique inverse (\) et les combinaisons de caractères entre guillemets (''), par exemple \ ». Placez le chemin de la tâche (y compris les arguments ou des interrupteurs) accès complet entre guillemets comme d'habitude lorsque vous créez un chemin d'accès ou la commande qui contient des espaces.

Par exemple, la tâche d'exemple suivantes ne s'exécute pas lorsque vous planifiez il :
SCHTASKS /Create /tn « ma tâche « /tr » c:\foldername contenant des arguments spaces\script.bat » /sc fois /sd 29/07/2003 /st 10:01
Toutefois, lorsque vous placez le chemin d'accès de la tâche entre la barre oblique inverse et combinaisons de caractères entre guillemets comme dans l'exemple suivant, la tâche planifiée exécute correctement :
SCHTASKS /Create /tn /tr ma tâche " \ " nom c:\foldername contenant spaces\script.bat \ " arguments " /sc fois /sd 29/07/2003 /st 10:01

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Mots-clés : 
kbmt kbprb kbnofix kbbug KB823093 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 823093  (http://support.microsoft.com/kb/823093/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store