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Base de connaissances

Numéro d'article: 842827 - Dernière mise à jour: jeudi 25 octobre 2007 - Version: 1.3

 
 

Sommaire

Symptômes

Lorsque vous déconnectez d'un ordinateur Windows XP, le système ne peut pas décharger votre profil utilisateur correctement. En outre, l'erreur suivante peut être enregistrée dans le journal d'application :

Type d'événement : Erreur
Source de l'événement : Userenv
Catégorie d'événement : aucune
L'ID d'événement : 1524
Description :
Windows ne peut pas décharger votre fichier de Registre de classes - il est toujours en cours d'utilisation par d'autres applications ou services. Le fichier sera déchargé lorsqu'il n'est plus en cours d'utilisation.

Lorsque vous reconnectez à l'ordinateur, la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes n'est pas chargée. En outre, certaines opérations COM échouer. Par exemple, les opérations de COM pour les formulaires Outlook échoue.

Cause

Ce problème se produit car, lorsque vous ouvrez une session sur l'ordinateur, le service client WebDav caches un handle vers la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes lors de l'initialisation par utilisateur.

La sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes est le fichier Usrclass.dat dans votre profil utilisateur. La sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes est utilisée pour les enregistrements de COM par utilisateur. Par conséquent, la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes ne peut pas être déchargée lorsque vous déconnectez de l'ordinateur en raison de la poignée mis en cache.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Windows XP SP2 pour appliquer ce correctif doit être.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeDemande de Service PackSuccursale de service
Advapi32.dll5.1.2600.3039617,47222-Nov-200613:07x 86SERVICE PACK 2SP2QFE
Webclnt.dll5.1.2600.303968,09622-Nov-200613:07x 86SERVICE PACK 2SP2QFE

Contournement

Pour contourner ce problème, utiliser le Microsoft utilisateur profil ruche nettoyage service (UPHClean). UPHClean contrôle l'ordinateur lorsque Windows décharge les profils utilisateur. UPHClean force les ressources qui sont ouverts pour la fermer. Par conséquent, l'ordinateur peut décharger les profils utilisateur.

Pour télécharger et installer UPHClean, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582 (http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582)

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

La sous-arborescence de Registre HKEY_CLASSES_ROOT est l'affichage fusionné de la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes et de la sous-clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Classes. Lorsque le système lit à partir de la sous-arborescence de Registre HKEY_CLASSES_ROOT, les données par utilisateur qui se trouve sous la sous-arborescence de Registre HKEY_CURRENT_USER remplace les données par ordinateur qui se trouve sous la sous-arborescence de Registre HKEY_LOCAL_MACHINE. Si le système écrit à la sous-arborescence de Registre HKEY_CLASSES_ROOT, les données sont redirigées vers la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes. La sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes est le fichier Usrclass.dat dans le ’s profil utilisateur. Par conséquent, les utilisateurs peuvent créer leurs propres enregistrements de classe COM car les utilisateurs standard ont généralement accès en lecture seule à la sous-clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Classes.

Lorsque le problème décrit dans cet article se produit, la sous-clé de Registre HKEY_CURRENT_USER\SOFTWARE\Classes n'apparaît dans le Registre la prochaine fois que l'utilisateur ouvre une session sur l'ordinateur. Par conséquent, les enregistrements de COM par utilisateur sont manquantes.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbpubtypekc kbqfe kbhotfixserver kbtshoot kbexpertiseinter kbprb KB842827 KbMtfr
Traduction automatiqueTraduction automatique
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La version anglaise de cet article est la suivante: 842827  (http://support.microsoft.com/kb/842827/en-us/ )
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