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Base de connaissances

Numéro d'article: 886346 - Dernière mise à jour: jeudi 29 novembre 2007 - Version: 6.3

Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre de Microsoft Windows

Symptômes

Lorsque vous synchronisez votre appareil mobile avec Microsoft Exchange Server 2003, le message d'erreur suivant s'affiche :
Code d'erreur : HTTP_500

La synchronisation a échoué en raison d'une erreur sur le serveur. Réessayez.

Cause

Exchange ActiveSync recherche généralement la boîte aux lettres en utilisant la partie gauche de l'adresse SMTP principale. Le problème décrit dans la section Symptômes se produit si les conditions suivantes sont vraies :
  • L'utilisateur possède plusieurs adresses SMTP.
  • L'adresse SMTP principale ne correspond pas à la Stratégie de destinataire par défaut.

Résolution

Pour résoudre ce problème, installez Microsoft Exchange Server 2003 Service Pack 2 (SP2). S'il n'est pas possible d'installer Exchange Server 2003 SP2, ajoutez une clé de Registre pour forcer Exchange ActiveSync à rechercher la boîte aux lettres en utilisant les adresses SMTP secondaires. Pour cela, procédez comme suit :

Avertissement Toute modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou d'une autre méthode peut entraîner des problèmes sérieux. Ces problèmes peuvent vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Remarque Cette modification nécessite le redémarrage du service Admin de Microsoft Internet Information Services (IIS).
  1. Cliquez sur Démarrer, sur Exécuter, tapez regedit dans la zone Ouvrir, puis cliquez sur OK.
  2. Recherchez la clé de Registre suivante : HKEY_Local_Machine\System\CurrentControlSet\Services\MasSync\Parameters\
  3. Cliquez avec le bouton droit sur Paramètres, pointez sur Nouveau, puis cliquez sur Valeur chaîne.
  4. « Nouvelle valeur #1 » est sélectionné. Tapez SMTPProxy, puis appuyez sur Entrée pour renommer la valeur. Cliquez avec le bouton droit sur SMTPProxy, puis cliquez sur Modifier.
  5. Dans la ligne Valeur chaîne, tapez le domaine SMTP de votre Stratégie de destinataire par défaut. Par exemple, tapez contosoltd.com.
  6. Cliquez sur OK pour quitter l'Éditeur du Registre.
  7. Redémarrez le service d'administration IIS. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, sur Exécuter, tapez services.msc, puis cliquez sur OK.
    2. Dans la liste de services, cliquez avec le bouton droit sur Service d'administration IIS, puis cliquez sur Redémarrer.
Une fois le nouveau paramètre du Registre appliqué, Exchange ActiveSync analysera toutes les adresses SMTP pour localiser la boîte aux lettres. Par exemple, un utilisateur de Contoso Ltd. a la configuration SMTP suivante :
SMTP :admin@contoso.com <------------Adresse SMTP principale
smtp:admin@contosoltd.com
Une fois la valeur SMTPProxy ajoutée et définie sur contosoltd.com, Exchange ActiveSync recherchera correctement la boîte aux lettres admin@contosoltd.com.

Important
  • Assurez-vous que le serveur de boîte aux lettres principal exécute une version d'Exchange Server ultérieure à Microsoft Exchange Server 2003 Service Pack 1 (build 6.5.7226).
  • Pour que cette solution fonctionne, vous devez désactiver l'entrée de Registre DisableSMTPMailboxAddressing, si elle existe, sur les serveurs Exchange. Pour désactiver cette entrée de Registre, définissez la valeur de l'entrée de Registre suivante sur 0 :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\DisableSMTPMailboxAddressing

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft ActiveSync 4.1
Mots-clés : 
kbprb KB886346
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