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Base de connaissances

Numéro d'article: 902225 - Dernière mise à jour: jeudi 7 novembre 2013 - Version: 5.0

Sommaire

Symptômes

Après l'installation de la mise à jour de sécurité 896358 ou de Microsoft Windows Server 2003 Service Pack 1 (SP1), vous pouvez rencontrer un ou plusieurs des problèmes suivants lorsque vous cliquez sur un lien vers un fichier d'aide HTML (.chm ) dans Internet Explorer :
  • Les rubriques du fichier .chm ne peuvent pas être affichées lorsque vous cliquez sur Ouvrir plutôt que sur Enregistrer dans la boîte de dialogue Téléchargement de fichier.
  • Les rubriques du fichier .chm ne peuvent pas être affichées lorsque vous cliquez sur Enregistrer dans la boîte de dialogue Téléchargement de fichier, puis que vous essayez d'ouvrir le fichier
Remarque Les informations contenues dans cet article complètent celles des articles suivants de la Base de connaissances Microsoft :
232077  (http://support.microsoft.com/kb/232077/fr/ ) Exécution de fichiers par lien hypertexte et la boîte de dialogue Téléchargement de fichier
896054  (http://support.microsoft.com/kb/896054/fr/ ) Impossible d'ouvrir un contenu distant à l'aide du protocole InfoTech après l'installation de la mise à jour de sécurité 896358, de la mise à jour de sécurité 840315 ou de Windows Server 2003 Service Pack 1
896358  (http://support.microsoft.com/kb/896358/ ) MS05-026 : Une vulnérabilité dans HTML Help pourrait permettre l'exécution de code à distance

Cause

La mise à jour de sécurité 896358 et Windows Server 2003 SP1 incluent des modifications du protocole InfoTech qui bloquent la capacité d'afficher un contenu distant. Ces modifications ont été introduites afin de réduire les problèmes de sécurité dans l'Aide HTML. Après l'installation de la mise à jour 896358 ou de Windows Server 2003 SP1, les fichiers du dossier Fichiers Internet temporaires sont traités comme contenu de la zone Internet. Par conséquent, les fichiers peuvent être bloqués lorsque vous cliquez sur Ouvrir dans la boîte de dialogue Téléchargement de fichier. En outre, après l'installation de 896358 ou de Windows Server 2003 SP1, le Gestionnaire de pièces jointes peut traiter un fichier .chm téléchargé comme fichier non fiable. Par conséquent, vous ne pourrez peut-être pas ouvrir ce fichier. Ces problèmes sont une conséquence prévue et souhaitée de l'installation de la mise à jour de sécurité et de Windows Server 2003 SP1.

Résolution

Résolution pour les utilisateurs finaux

Avertissement Si vous êtes invité à ouvrir ou à enregistrer un fichier .chm à partir d'un site web, faites-le uniquement si vous avez besoin du fichier et si le site web qui fournit le fichier est un site fiable.

Dans la boîte de dialogue Téléchargement de fichier, cliquez sur Enregistrer, puis sélectionnez l'emplacement d'enregistrement du fichier .chm. Vous pouvez aussi utiliser l'une des méthodes suivantes :

Méthode 1

  1. Double-cliquez sur le fichier .chm.
  2. Dans la boîte de dialogue Fichier ouvert-Avertissement de sécurité,désactivez la case à cocher Toujours demander avant d'ouvrir ce fichier.
  3. Cliquez sur Ouvrir.

Méthode 2

  1. Cliquez avec le bouton droit sur le fichier .chm, puis cliquez sur Propriétés.
  2. Cliquez sur Débloquer.
  3. Double-cliquez sur le fichier .chm pour l'ouvrir.

Résolution pour les administrateurs système

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Utilisation de chemins d'accès UNC et de partages de fichiers pour les liens vers les fichiers .chm

Si votre page web d'intranet utilise le schéma d'URL HTTP pour les liens vers les fichiers .chm, la mise à jour de sécurité 896358 peut empêcher les utilisateurs d'afficher les rubriques du fichier .chm. En remplaçant le chemin de fichier HTTP par un chemin UNC, vous serez peut-être en mesure d'ouvrir des fichiers .chm à partir de la page Web.

Pour utiliser un chemin d'accès UNC plutôt qu'une URL HTTP, procédez comme suit :
  1. Placez les fichiers .chm sur un serveur de partage de fichiers auquel vous pouvez accéder à l'aide d'un chemin UNC.

    Un chemin d'accès UNC utilise la forme suivante :
    \\productmanuals\helpfiles
  2. Utilisez la valeur ItssRestrictions\UrlAllowList pour permettre aux systèmes de votre intranet d'accéder aux fichiers .chm à partir de ce partage de fichiers.

    Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    896054  (http://support.microsoft.com/kb/896054/fr/ ) Impossible d'ouvrir un contenu distant à l'aide du protocole InfoTech après l'installation de la mise à jour de sécurité 896358, de la mise à jour de sécurité 840315 ou de Windows Server 2003 Service Pack 1
  3. Mettez à jour les liens sur votre page Web d'intranet pour utiliser des chemins d'accès UNC dans les URL liées aux fichiers .chm.
Remarque Cette méthode fonctionne uniquement pour les pages provenant de la zone Intranet. Elle ne fonctionne pas pour celles provenant de la zone Internet.

Configuration d'applications web pour télécharger des fichiers .chm

Sur la page web liée aux fichiers .chm, ajoutez des instructions à l'attention des utilisateurs pour enregistrer le fichier plutôt que de l'ouvrir directement. Pour plus d'informations, reportez-vous à la section « Résolution pour les utilisateurs finaux ».

Vous pouvez également utiliser la balise <META> DownloadOptions pour supprimer le bouton Ouvrir de la boîte de dialogue Téléchargement de fichier qui apparaît lorsqu'un utilisateur clique sur un lien vers le fichier .chm. Placez cette balise à l'intérieur de la balise <head> de votre page HTML. Cet usage est illustré dans l'exemple ci-dessous.
<head>
<META name="DownloadOptions" content="noopen">
</head>
Pour plus d'informations, reportez-vous au site web de Microsoft à l'adresse suivante :
http://msdn.microsoft.com/fr-fr/library/ms534184.aspx (http://msdn.microsoft.com/fr-fr/library/ms534184.aspx)
Remarque L'utilisation de la balise <META> DownloadOptions est prise en charge uniquement sous Microsoft Windows XP Service Pack 2 et Windows Server 2003 Service Pack 1.

Plus d'informations

Présentation et exemples pour les administrateurs système

Pour plus d'informations sur la mise à jour de sécurité 896358 et sur la façon de réactiver les applications Web concernées par cette mise à jour, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
896358  (http://support.microsoft.com/kb/896358/ ) MS05-026 : Une vulnérabilité dans HTML Help peut permettre l'exécution de code à distance

Internet Explorer

Pour plus d'informations sur l'ouverture de fichiers par lien hypertexte dans Internet Explorer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
232077  (http://support.microsoft.com/kb/232077/fr/ ) Exécution de fichiers par lien hypertexte et la boîte de dialogue Téléchargement de fichier
Pour plus d'informations sur la façon d'utiliser les zones de sécurité dans Internet Explorer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
174360  (http://support.microsoft.com/kb/174360/fr/ ) Comment faire pour utiliser les zones de sécurité dans Internet Explorer

Support technique pour les versions x64 de Microsoft Windows

Sur les ordinateurs qui exécutent des versions x64 de Microsoft Windows, vous devrez peut-être adapter les instructions de la section « Résolution » concernant la modification du Registre. Par exemple, vous devrez peut-être modifier une partie différente du Registre, selon que vous souhaitez modifier la fonctionnalité 32 bits ou 64 bits. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
896459  (http://support.microsoft.com/kb/896459/fr/ ) Modifications du Registre dans les systèmes d'exploitation Windows Édition x64
Le fabricant de votre matériel fournit une assistance et un support technique pour les versions x64 de Windows. Le fabricant de votre matériel fournit un support technique car une version x64 de Windows était fournie avec votre matériel. Le fabricant de votre matériel peut avoir personnalisé l'installation de Windows avec des composants uniques. Ceux-ci peuvent inclure des pilotes de périphériques spécifiques ou des paramètres facultatifs ayant pour but d'optimiser les performances du matériel. Microsoft vous fournira une assistance raisonnable si vous avez besoin d'aide technique avec votre version x64 de Windows. Toutefois, vous devrez peut-être contacter directement le fabricant de votre matériel. Celui-ci est le plus qualifié pour assurer la prise en charge des logiciels qu'il a installés sur le matériel.

Pour des informations produit sur Microsoft Windows XP Professionnel Édition x64, reportez-vous au site web de Microsoft à l'adresse suivante :
http://windows.microsoft.com/fr-fr/windows/windows-help?os=winxp#windows=windows-xp (http://windows.microsoft.com/fr-fr/windows/windows-help?os=winxp#windows=windows-xp)
Pour des informations produit sur les versions x64 de Microsoft Windows Server 2003, reportez-vous au site web de Microsoft à l'adresse suivante :
http://technet.microsoft.com/fr-fr/windowsserver/bb430829.aspx (http://technet.microsoft.com/fr-fr/windowsserver/bb430829.aspx)

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003 Service Pack 1 sur le système suivant
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Mots-clés : 
kbsecurity kbexpertiseinter kbexpertiseadvanced kbtshoot kbprb KB902225
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