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Base de connaissances

Numéro d'article: 902409 - Dernière mise à jour: jeudi 15 novembre 2007 - Version: 4.6

 
 
important Cet article explique comment modifier le Registre. Veillez à sauvegarder le Registre avant de le modifier. Assurez-vous que que vous savez comment restaurer le Registre en cas de problème. Pour plus d'informations sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre Microsoft Windows

Sommaire

Symptômes

Envisagez le scénario suivant :
  • Le serveur Web utilise l'en-tête HTTP d'autorisation de négociation pour authentifier les clients sur un site Web.
  • Vous utilisez Microsoft Internet Explorer 6 pour accéder à ce site Web à partir d'un ordinateur client.
  • Vous êtes invité à entrer le nom d'utilisateur et le mot de passe.
  • Après avoir entré le nom d'utilisateur et le mot de passe et cliquez sur OK , vous recevez une page HTML de l'authentification sur Forms qui inclut un formulaire Web. Ce formulaire Web contient un champ de nom d'utilisateur et un champ de mot de passe. La page Web inclut également un message indiquant que le serveur Web refuse l'authentification NTLM.
  • Entrez le nom d'utilisateur et le mot de passe dans le formulaire Web et puis envoyer le formulaire Web.
Dans ce scénario, le formulaire Web n'envoient pas le nom d'utilisateur et le mot de passe sur le serveur Web.

Cause

Ce problème se produit car le fichier Wininet.dll empêche les données d'être envoyé lorsque le client utilise l'authentification NTLM et le serveur Web attend une réponse simple et SPNEGO (Protected GSSAPI Negotiation mécanisme).

Lorsque vous envoyez le nom d'utilisateur et le mot de passe pour la première fois, le fichier Wininet.dll sur l'ordinateur client ajoute une réponse NTLM pour l'en-tête Negotiate d'autorisation. Si le serveur Web attend une réponse SPNEGO, le serveur Web peut envoyer une réponse qui n'est pas «401 accès refusé. " La réponse n'est pas «401 accès refusé», Wininet.dll incorrectement suppose que l'authentification a réussi. Lorsque Wininet.dll suppose que s'est produite une authentification réussie, Wininet.dll supprime les données d'authentification qu'il enregistrés et ne pas renvoyer les données.

Résolution

Windows XP

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contient ce correctif.

Si le correctif est disponible pour téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle de Microsoft et de support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si n'importe quelle résolution des problèmes sont requis, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète de numéros de téléphone Microsoft Services de support technique ou à créer une demande de service distincte, site Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.
Conditions préalables
Pour appliquer ce correctif nécessite Windows XP Service Pack 1 (SP1) ou Windows XP Service Pack 2 (SP2).
La nécessité de redémarrer
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif ne remplace pas d'autres correctifs.
Informations sur les fichiers
La version anglaise de ce correctif dispose les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers figurent en temps universel (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:02  6.0.2900.2754  660,480  Wininet.dll         SP2
   07-Sep-2005  00:09  5.1.2600.2754   30,720  Arpidfix.exe        SP2
   06-Sep-2005  10:36  6.0.2800.1521  585,728  Wininet.dll         SP1

Windows Server 2003

Informations sur le service pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows Server 2003. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
889100  (http://support.microsoft.com/kb/889100/ ) Comment obtenir le dernier pack service pour Windows Server 2003

Informations sur le correctif

Conditions préalables
Aucune condition préalable n'est nécessaires.
La nécessité de redémarrer
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif ne remplace pas d'autres correctifs.
Informations sur les fichiers
La version anglaise de ce correctif dispose les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers figurent en temps universel (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:29  6.0.3790.404   628,224  Wininet.dll
   07-Sep-2005  02:50  6.0.3790.2524  663,040  Wininet.dll         SP1
   07-Sep-2005  00:29  5.2.3790.2524   32,256  Arpidfix.exe        SP1

Instructions d'installation correctif

Avertissement Problèmes sérieuses peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

Après avoir appliqué ce correctif, activer le correctif en ajoutant deux entrées de Registre dans le Registre. Pour ajouter ces entrées de Registre, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Pour activer ce correctif sur chaque utilisateur, cliquez sur une des sous-clés de Registre suivantes :
    • HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_CURRENT_USER\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Remarque Vous devrez ajouter les entrées de Registre à un des ces sous-clés de Registre.

    Pour activer ce correctif sur une base par ordinateur, cliquez sur une des sous-clés de Registre suivantes :
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_LOCAL_MACHINE\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Remarque Vous devrez ajouter les entrées de Registre à un des ces sous-clés de Registre.
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  4. Tapez FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409 et appuyez sur ENTRÉE.
  5. Cliquez sur FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409 .
  6. Dans le menu Edition , pointez sur Nouveau et cliquez sur Valeur DWORD .
  7. Tapez iexplore.exe pour nommer la nouvelle valeur DWORD, puis appuyez sur ENTRÉE.
  8. Double-cliquez sur iexplore.exe , tapez 1 dans la zone données de la valeur et cliquez sur OK pour activer le correctif.

    Remarque Pour désactiver le correctif, tapez 0 dans la zone données de la valeur .
  9. Pour ajouter l'entrée de Registre Explorer.exe, répétez les étapes 3 à 5. Dans l'étape 4, tapez Explorer.exe au lieu du fichier Iexplore.exe .
  10. Quittez l'Éditeur du Registre.

Contournement

Pour contourner ce problème, configurez le serveur Web pour prendre en charge l'authentification NTLM. Pour obtenir plus d'informations sur comment configurer le serveur Web pour effectuer l'authentification NTLM, contactez le fournisseur du serveur Web.

Pour informations sur le fabricant de votre matériel, site suivant Web :
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)

Statut

Microsoft a confirmé le que de ce problème dans les produits Microsoft répertoriés dans la section «S'applique à». Ce problème a été corrigé dans Windows Server 2003 Service Pack 2.

Plus d'informations

Pour plus d'informations concernant la terminologie utilisée dans cet article, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684  (http://support.microsoft.com/kb/824684/ ) Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 6.0 SP1 sur le système suivant
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows XP Édition familiale
    • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinserv2003sp1fix kbwinserv2003presp1fix kbwinxpsp2fix kbwinxppresp2fix kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug kbpubtypekc kbhotfixserver KB902409 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 902409  (http://support.microsoft.com/kb/902409/en-us/ )
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