DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 908002 - Dernière mise à jour: lundi 3 décembre 2007 - Version: 4.4

 

Sommaire

Symptômes

Lorsque vous utilisez Visual Studio 2005 pour créer des compléments, documents intelligents ou balises actives, vous pouvez rencontrer les problèmes suivants :
  • Impossible de charger des compléments, les documents actives ou les balises actives dans n'importe quelle application Microsoft Office.
  • Les compléments, les documents dynamiques ou les balises actives ne pas s'exécuter dans la version de Microsoft Office.
Ce problème se produit lorsque vous créez des compléments, les documents dynamiques ou les balises actives sur un ordinateur sur lequel Microsoft .NET Framework 2.0 est installé.

note Ce problème ne se produit pas lorsque vous ouvrez une session sur à l'aide d'un compte d'utilisateur Microsoft Windows a restreint.

Résolution

La mise à jour pour Visual Studio 2005 qui est décrit dans cet article vous permet de redistribuer les correctifs requis dans Office et .NET Framework avec les solutions que vous écrivez dans Visual Studio 2005. Cette mise à jour ajoute une nouvelle partagés Add-in support mise à jour pour Microsoft .NET Framework 2.0 (KB908002) option pour la liste de conditions préalables Visual Studio 2005. Lorsque vous créez un projet d'installation d'un complément géré, smart document ou la balise, vous devez activer cette option dans le projet d'installation qui inclut les requis mises à redistribuables jour vers Office et de .NET Framework.

Pour résoudre ce problème pour les développeurs de Visual Studio 2005, une version redistribuable de la mise à jour pour Visual Studio 2005 est disponible.

Le fichier suivant est téléchargeable à partir du Centre de téléchargement Microsoft :
Réduire cette imageAgrandir cette image
Download
Download the VS2005-KB908002-ENU-x86.EXE package now. (http://download.microsoft.com/download/b/6/7/b6711d3b-b509-4567-8599-98bf3473310f/vs2005-kb908002-enu-x86.exe)

Pour plus d'informations sur la façon de télécharger les fichiers de prise en charge Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
119591  (http://support.microsoft.com/kb/119591/ ) Comment obtenir des fichiers de prise en charge Microsoft auprès des services en ligne
Microsoft a analysé ce fichier de virus. Microsoft utilisé les logiciels de détection de virus plus récente ne sont associé à la date à laquelle le fichier a été validé. Le fichier est stocké sur des serveurs sécurisés empêcher toute modification non autorisée dans le fichier.

Pour installer cette mise à jour pour Visual Studio 2005, nous vous recommandons de suivre ces étapes :
  1. Enregistrer le package de téléchargement sur votre ordinateur.
  2. Double-cliquez sur le package de téléchargement pour exécuter le package.
  3. Lisez et puis acceptez les termes du contrat de licence logiciel Microsoft.
Après avoir installé cette mise à jour, vous devez inclure le partagés Add-in support mise à jour pour Microsoft .NET Framework 2.0 (KB908002) option parmi les conditions préalables du projet d'installation solution lorsque vous créez un projet de complément partagé dans Visual Studio 2005. Pour ce faire, procédez comme suit :
  1. Dans l'Explorateur de solutions, cliquez avec le bouton droit sur le projet programme d'installation de solution, puis cliquez sur Propriétés .
  2. Cliquez sur Conditions préalables .
  3. Cliquez pour sélectionner la partagés Add-in support mise à jour pour Microsoft .NET Framework 2.0 (KB908002) case à cocher.
note Vous devez activer cette condition préalable séparément pour les deux le débogage et version crée.

note Cette mise à jour est installée sur chaque utilisateur. Par conséquent, installer la mise à jour pour chaque compte d'utilisateur qui nécessite la mise à jour.

Lorsque vous créez votre projet d'installation, Visual Studio 2005 inclut les mises à jour redistribuables avec votre projet dans un dossier nommé KB908002. Ce dossier se trouve dans l'application Paramètres dossier. Le contenu du dossier KB908002 est requis pour la solution logique de paramètres pour fonctionner correctement. Le fichier Setup.exe que Visual Studio 2005 crée le programme d'installation projet va appliquer les mises à jour à l'ordinateur destination lorsque la solution est installée.

note Le .NET Framework 2.0 et Microsoft Windows Installer 2.0 sont nécessaires pour les correctifs être installé correctement sur l'ordinateur de destination.

note Ce fichier .msi n'est aucune spécification ALLUSERS. Par conséquent, lorsque vous installez ce fichier .msi, le fichier est installé dans l'utilisateur contexte par utilisateur au lieu de par ordinateur.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Procédure pour reproduire le problème

  1. Démarrez Microsoft Visual Studio 2005.
  2. Créer un complément partagé. Pour ce faire, procédez comme suit :
    1. Dans le menu Fichier , cliquez sur Nouveau , puis cliquez sur le projet .
    2. Dans la boîte de dialogue Nouveau projet , cliquez sur Autres types de projet , puis cliquez sur Extensibility .
    3. Cliquez sur complément partagé , tapez un nom dans la zone Nom et puis cliquez sur OK .
    4. Suivez les instructions de l'Assistant Complément partagé pour créer un complément Word.
  3. Générez le projet. Pour ce faire, procédez comme suit :
    1. Dans le menu projet , cliquez sur Propriétés YourProjectName.
    2. Sous l'onglet YourProjectName, cliquez sur Créer , puis cliquez sur publication dans la liste de configuration .
    3. Dans le menu Générer , cliquez sur Créer solution .
  4. Dans le menu Fichier , cliquez sur Quitter pour quitter Visual Studio.
  5. Déployez le complément. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer , puis cliquez sur Mes documents .
    2. Ouvrez le dossier suivant :
      Visual Studio 2005\Projects\ YourProjectName \ YourProjectName Setup\Debug
      Par défaut, le projet que vous avez créé dans l'étape 3 est enregistré dans le dossier de Visual Studio 2005.
    3. Copiez les fichiers suivants sur le Bureau sur un deuxième ordinateur :
      • Setup.exe
      • YourProjectNameSetup.msi
    4. Double-cliquez sur le fichier Setup.exe et puis accepte tous les paramètres par défaut.
  6. Démarrez Microsoft Word.
  7. Dans le menu Outils , cliquez sur Modèles et compléments .
  8. Cliquez sur Ajouter . Vous recevez un message d'erreur dans une boîte de dialogue Compléments COM .

Références

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
907417  (http://support.microsoft.com/kb/907417/ ) Description de la mise à jour pour Office 2003 : 13 décembre 2005
note La mise à jour qui est décrite dans Base de connaissances Microsoft. article 907417 permet aux utilisateurs finaux de Microsoft Office 2003 corriger uniquement la Otkloadr.dll émettre. L'article ne résout pas les versions de Microsoft Office qui diffèrent de Office 2003 ou problème Extensibility.dll.

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
908003  (http://support.microsoft.com/kb/908003/ ) CORRECTIF : Office 2003 se bloque lorsque vous essayez de fermer un document Word ou une feuille de calcul Excel d'un contrôle WinForm dans un Visual Studio Tools pour la solution Office System version 2003
908004  (http://support.microsoft.com/kb/908004/ ) CORRECTIF : vous ne pouvez pas exécuter une personnalisation a été créée dans Visual Studio Tools pour Microsoft Office System version 2003

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft .NET Framework 2.0
  • Microsoft Visual Studio 2005 Tools for the Microsoft Office System
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Express Edition
  • Microsoft Office 2000 Édition Standard
  • Microsoft Office 97 Standard
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
Mots-clés : 
kbmt kbnofix kbbug kbtshoot KB908002 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 908002  (http://support.microsoft.com/kb/908002/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store