DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 920114 - Dernière mise à jour: lundi 3 mai 2010 - Version: 2.0

 
Bogue : 451014 (SQLBUDT)

Symptômes

Lorsque vous essayez d'installer Microsoft SQL Server 2005 Express Edition ou Microsoft SQL Server Express Edition with Advanced Services, vous recevez message d'erreur suivantes :
Le service SQL Server n'a pas pu démarrer. Pour plus d'informations, consultez les rubriques de la documentation en ligne, «How à: afficher les fichiers SQL Server 2005 mise en journal» et «démarrage de SQL Server manuellement. "
Lorsque vous examinez le journal des erreurs de SQL Server, vous recevez message d'erreur suivantes :
Démarrage de la base de données 'mssqlsystemresource'.
Erreur : 15209, Severity : 16, état: 1.
Une erreur s'est produite pendant le chiffrement.
Pour plus d'informations sur la façon d'afficher le journal des erreurs de SQL Server, reportez-vous au site Web de MSDN (Microsoft Developer Network) à l'adresse suivante :
http://msdn2.microsoft.com/en-us/library/ms187885.aspx (http://msdn2.microsoft.com/en-us/library/ms187885.aspx)
Ce problème peut se produire lorsque vous essayez d'installer SQL Server Express Edition ou SQL Server Express Edition with Advanced Services sur Microsoft Windows XP Service Pack 2 (SP2) - basé sur ordinateur.

Cause

Ce problème se produit car le compte de service réseau ne dispose pas des autorisations sur le dossier suivant :
C:\Documents and Settings\NetworkService\Application Data\Microsoft\Protect

Contournement

Pour contourner ce problème, accordez au compte service réseau l'autorisation contrôle total sur le dossier de protéger. Pour ce faire, procédez comme suit :
  1. Ouvrez le poste de travail.
  2. Tapez C:\Documents and Settings\NetworkService\Application Data\Microsoft dans la barre d'adresses et appuyez sur ENTRÉE.
  3. Cliquez avec le bouton droit sur le dossier de protéger, puis cliquez sur Propriétés.
  4. Dans la boîte de dialogue Propriétés de dossier, cliquez sur l'onglet sécurité.
  5. Sous noms d'utilisateur ou de groupe, déterminez si l'option NETWORK SERVICE est répertorié. Si le SERVICE réseau n'est pas répertorié, procédez comme suit pour ajouter ce compte :
    1. Cliquez sur Ajouter pour afficher la boîte de dialogue Sélectionnez utilisateurs ou groupes.
    2. Cliquez sur emplacements, sélectionnez votre nom de l'ordinateur dans la boîte de dialogue emplacements et puis cliquez sur OK pour revenir à la boîte de dialogue Sélectionnez utilisateurs ou groupes.
    3. Entrez Service réseau dans la zone Entrez les noms des objets à sélectionner, puis cliquez sur Vérifier les noms.
    4. Cliquez sur OK pour fermer la boîte de dialogue Sélectionnez utilisateurs ou groupes.
  6. Cliquez sur SERVICE réseau sous noms d'utilisateur ou de groupe et puis activez la case à cocher la case à cocherContrôle total sous autorisations pour NETWORK SERVICE.
  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du dossier.
  8. Cliquez sur Réessayer dans la boîte de dialogue message d'erreur pour poursuivre l'installation de SQL Server Express Edition ou SQL Server Express Edition with Advanced Services.
Pour un problème connexe qui peut-être se produire lorsque vous installez SQL sur les partitions FAT, consultez le blog suivant publier sur MSDN :
https://blogs.msdn.com/blakhani/archive/2009/11/24/sql-server-2005-express-setup-failure-with-error-an-error-occurred-during-encryption.aspx (https://blogs.msdn.com/blakhani/archive/2009/11/24/sql-server-2005-express-setup-failure-with-error-an-error-occurred-during-encryption.aspx)

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "S'applique à".

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SQL Server 2005 Express Edition
  • Microsoft SQL Server 2005 Express Edition with Advanced Services
Mots-clés : 
kbmt kbsql2005setup kbsql2005express kbexpertiseadvanced kbtshoot kbprb KB920114 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 920114  (http://support.microsoft.com/kb/920114/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store