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Base de connaissances

Numéro d'article: 923155 - Dernière mise à jour: mardi 11 septembre 2007 - Version: 1.3

 
 
important Cet article contient des informations sur la modification du Registre. Assurez-vous de sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre Microsoft Windows

Sommaire

Symptômes

Envisagez le scénario suivant. Sur un ordinateur Windows XP SP2, vous utilisez Microsoft Internet Explorer 6 pour ouvrir une page Web. Vous essayez d'utiliser la méthode POST pour publier des données sur le serveur Web qui héberge la page Web. Dans ce scénario, vous ne peut pas publier des données sur le serveur Web. Ce problème se produit si le serveur Web utilise la version protocole d'authentification Kerberos 5 pour améliorer la sécurité.

note Ce problème se produit uniquement lorsque vous utilisez la méthode POST pour la première fois. Si vous cliquez sur le bouton précédent pour revenir à la page Web, et que vous vous validez les données à nouveau, vous pouvez comptabiliser correctement les données sur le serveur Web.

Cause

Ce problème se produit en raison d'un défaut dans le fichier WinINet.dll. Lorsque vous tentez de publier des données sur le serveur Web dans Internet Explorer 6, le fichier WinINet.dll obtient les nouvelles informations d'identification et ensuite le fichier WinINet.dll libère le contexte de sécurité d'origine. Ensuite, le fichier WinINet.dll appelle la fonction InitializeSecurityContext pour lancer le contexte de sécurité côté client sortant.

Dans ce scénario, le fichier WinINet.dll ne vérifie pas la si le schéma d'authentification du serveur Web est l'authentification NTLM ou authentification Kerberos. En raison des défauts, le fichier WinINet.dll attend que le serveur Web utilise le modèle d'authentification NTLM. Par conséquent, l'authentification échoue et vous ne pouvez pas publier des données sur le serveur Web.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer le correctif, Windows XP Service Pack 2 (SP2) doit être installé sur l'ordinateur.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace pas les autres correctifs précédemment publiés.

Informations de Registre

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

Pour activer le correctif logiciel, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et puis appuyez sur ENTRÉE.
  2. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  4. Tapez le nom de sous-clé suivant et appuyez sur ENTRÉE :
    FEATURE_FIX_KERBEROS_POST_KB923155
  5. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  6. Tapez iexplore.exe , puis appuyez sur ENTRÉE.
  7. Dans le menu Edition , cliquez sur Modifier .
  8. Dans la zone données de la valeur , tapez 1 et puis cliquez sur OK .
  9. Quittez l'Éditeur du Registre.
note Pour désactiver le correctif logiciel, tapez 0 dans la zone données de la valeur de l'étape 8.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP avec Service Pack 2, x 86 versions
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Wininet.dll6.0.2900.2992664,576Sep-08-200612:51x 86

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur la fonction InitializeSecurityContext , reportez-vous au site de Web Microsoft suivant :
http://msdn2.microsoft.com/en-us/library/aa375506.aspx (http://msdn2.microsoft.com/en-us/library/aa375506.aspx)
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684  (http://support.microsoft.com/kb/824684/ ) Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Home Edition SP2
Mots-clés : 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB923155 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 923155  (http://support.microsoft.com/kb/923155/en-us/ )
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