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Base de connaissances

Numéro d'article: 925336 - Dernière mise à jour: mardi 22 mai 2007 - Version: 3.1

 
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre de Microsoft Windows

Sommaire

Symptômes

Lorsque vous essayez d'installer un package Microsoft Windows Installer (.msi) volumineux ou un package correctif Microsoft Windows Installer (.msp) volumineux sur un ordinateur Microsoft Windows Server 2003 ou Microsoft Windows XP, le message d'erreur suivant s'affiche :
Erreur 1718. Le fichier NomFichier a été rejeté par la stratégie de signature numérique.
En outre, l'événement suivant peut être enregistré dans le journal d'applications :
Type : Erreur
Source : MsiInstaller
Catégorie : Aucune
ID de l'événement : 1008
Date : date
Heure : heure
Utilisateur : Na
Ordinateur : nom_ordinateur

Description : L'installation de nom_fichier n'est pas autorisée en raison d'une erreur lors du traitement de la stratégie de restriction logicielle. La confiance en l'objet ne peut pas être établie.

Cause

Ce problème se produit si la mémoire virtuelle contiguë du processus Windows Installer est insuffisante pour vérifier la signature du package .msi ou .msp.

Résolution

Un correctif est disponible pour Windows Server 2003. Aucun correctif n'est disponible pour Windows XP.

Informations sur le correctif Windows Server 2003

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Il ne doit être appliqué qu'aux systèmes rencontrant ce problème spécifique. Ce correctif peut être soumis à des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, Microsoft vous recommande d'attendre la prochaine version de Service Pack Windows Server 2003 qui comprendra ce correctif.

Pour résoudre ce problème dès à présent, procurez-vous le correctif auprès des services de Support technique Microsoft. Pour obtenir la liste complète des numéros de téléphone des services de Support technique Microsoft et des informations sur les frais engendrés, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/default.aspx?scid=fh;FR;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;fr;cntactms)
Remarque Dans certains cas, aucuns frais de support technique par téléphone ne vous seront facturés si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non directement liés à la mise à jour en question.Remarque Pour installer le correctif logiciel, suivez les instructions fournies plus loin dans cet article.

Mise à jour pour Windows Server 2003 (KB925336)

Vous pouvez télécharger le fichier suivant à partir du Centre de téléchargement Microsoft :

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Télécharger le package de mise à jour pour Windows Server 2003 (KB925336) maintenant. (http://www.microsoft.com/downloads/details.aspx?FamilyId=8EFFE1D9-7224-4586-BE2B-42C9AE5B9071&displaylang=fr)

Pour plus d'informations sur la façon de télécharger des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
119591  (http://support.microsoft.com/kb/119591/ ) Comment faire pour obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.
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Nom du fichierVersion du fichierTaille du fichierDateHeurePlate-formeExigences SPDossier
Advapi32.dll5.2.3790.2895620 54407/03/200707:05x86SP1SP1QFE
Advapi32.dll5.2.3790.4036619 00807/03/200707:02x86SP2SP2QFE

Mise à jour pour Windows Server 2003 Édition x64 (KB925336)

Vous pouvez télécharger le fichier suivant à partir du Centre de téléchargement Microsoft :

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Télécharger le package de mise à jour pour Windows Server 2003 Édition x64 (KB925336) maintenant. (http://www.microsoft.com/downloads/details.aspx?FamilyId=4BBC5917-C1AC-402C-86D9-0A8E3B9921FF&displaylang=fr)

Pour plus d'informations sur la façon de télécharger des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
119591  (http://support.microsoft.com/kb/119591/ ) Comment faire pour obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.
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Nom du fichierVersion du fichierTaille du fichierDateHeurePlate-formeExigences SPDossier
Advapi32.dll5.2.3790.28951 051 64807/03/200707:52x64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620 54407/03/200707:52x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361 052 16007/03/200716:52x64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619 00807/03/200716:52x86SP2SP2QFE\WOW

Mise à jour pour Windows Server 2003 pour les systèmes Itanium (KB925336)

Vous pouvez télécharger le fichier suivant à partir du Centre de téléchargement Microsoft :

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Télécharger le package de mise à jour pour Windows Server 2003 pour systèmes Itanium (KB925336) maintenant. (http://www.microsoft.com/downloads/details.aspx?FamilyId=B75A5876-590F-4AC2-8063-7A04DAF6CA1A&displaylang=fr)

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119591  (http://support.microsoft.com/kb/119591/ ) Comment faire pour obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.
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Nom du fichierVersion du fichierTaille du fichierDateHeurePlate-formeExigences SPDossier
Advapi32.dll5.2.3790.28951 481 21607/03/200711:42IA-64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620 54407/03/200711:42x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361 482 24007/03/200716:53IA-64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619 00807/03/200716:53x86SP2SP2QFE\WOW

Conditions préalables

Aucune.

Nécessité d'un redémarrage

Vous devez redémarrer votre ordinateur après l'application de ce correctif.

Informations sur le remplacement de correctif logiciel

Ce correctif logiciel n'en remplace pas d'autre.

Informations sur les fichiers

La version anglaise de ce correctif logiciel possède les attributs de fichier indiqués dans le tableau suivant ou ceux d'une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties à l'heure locale. Pour connaître le décalage entre l'heure GMT et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.

Contournement

Cette solution de contournement concerne Windows Server 2003 et Windows XP.

Avertissement Des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou toute autre méthode. Ces problèmes peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Pour contourner ce problème, définissez la valeur de Registre PolicyScope sur 1 avant d'installer le package. Pour cela, procédez comme suit :

Remarque Si l'ordinateur est joint à un domaine, une mise à jour de stratégie de domaine peut remplacer les modifications de Registre effectuées. Nous vous recommandons vivement de déconnecter l'ordinateur du domaine avant de suivre ces étapes.
  1. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
  2. Dans l'Éditeur du Registre, recherchez la clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers

    Remarque Avant de modifier cette clé, nous vous recommandons de la sauvegarder. Pour cela, cliquez avec le bouton droit sur CodeIdentifiers, puis cliquez sur Export. Enregistrez le fichier à un emplacement où vous pouvez le trouver sur l'ordinateur.
  3. Modifiez la valeur de Registre PolicyScope. Pour cela, double-cliquez sur PolicyScope, puis remplacez la valeur 0 par 1.
  4. Fermez l'Éditeur du Registre.
  5. Cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK pour ouvrir une fenêtre d'invite de commandes.
  6. À l'invite de commandes, tapez la commande suivante, puis appuyez sur la touche Entrée :
    net stop msiserver
    Cette command arrête le service Windows Installer si ce dernier est lancé en arrière-plan. Lorsque le service est arrêté, fermez la fenêtre Invite de commandes, puis passez à l'étape 7.

    Remarque Si le message suivant s'affiche à l'invite de commandes, fermez la fenêtre Invite de commandes, puis passez à l'étape 7 :
    Le service Windows Installer n'est pas arrêté.
  7. Installez le package que vous étiez en train d'essayer d'installer lorsque vous avez reçu le message d'erreur mentionné dans la section « Symptômes ».
  8. Une fois le package installé, répétez les étapes 1 et 2. Redéfinissez ensuite la valeur de Registre PolicyScope sur 0.
  9. Si vous avez déconnecté l'ordinateur d'un domaine, rejoignez ce dernier, puis redémarrez l'ordinateur.

    Remarque Si vous n'avez pas déconnecté l'ordinateur d'un domaine, vous n'avez pas a le redémarrer.
Si les étapes précédente ne résolvent pas le problème, procédez comme suit :
  1. Cliquez sur Démarrer, sur Exécuter, tapez control admintools, puis cliquez sur OK.
  2. Double-cliquez sur Stratégie de sécurité locale.
  3. Cliquez sur Stratégies de restriction logicielle.

    Remarque En l'absence de restrictions logicielles, cliquez avec le bouton droit sur Stratégies de restriction logicielle, puis cliquez sur Créer une nouvelle stratégie.
  4. Sous Type d'objet, double-cliquez sur Contrôle obligatoire.
  5. Cliquez sur Tous les utilisateurs exceptés les administrateurs locaux, puis sur OK.
  6. Redémarrez l'ordinateur.
Important Après avoir suivi les étapes précédentes, les administrateurs locaux peuvent installer le package .msi ou .msp. Une fois le package installé, réinitialisez le niveau de contrôle obligatoire en appliquant les étapes précédentes. À l'étape 5, cliquez sur Tous les utilisateurs à la place de Tous les utilisateurs exceptés les administrateurs locaux.

Remarques
  • La solution de contournement peut ne pas fonctionner dans un environnement de domaine Active Directory. Dans un environnement de domaine Active Directory, une actualisation de stratégie de domaine a pour effet de remplacer les stratégies de restriction logicielle locales.
  • L'ajout de mémoire vive (RAM) à l'ordinateur ne résout pas le problème.

Plus d'informations

Avec Microsoft Windows XP, une stratégie de sécurité nommée Stratégies de restriction logicielle (ou SAFER) est proposée pour éviter que les utilisateurs n'exécutent des fichiers potentiellement dangereux. Windows Installer utilise les Stratégies de restriction logicielle pour vérifier les signatures des fichiers de package .msi et .msp signés. Windows Installer fait cela pour s'assurer que les fichiers n'ont pas été falsifiés avant d'être installés sur l'ordinateur. Dans Windows XP et Windows Server 2003, il est nécessaire que l'ensemble du fichier de package .msi ou .msp soit chargé dans un emplacement contigu de mémoire dans l'espace d'adressage du processus Windows Installer.

Si un fichier package .msi ou .msp est trop volumineux pour large pour être contenu dans un emplacement de mémoire virtuelle contigu, Windows Installer ne peut pas vérifier que le package est correct. Dans ce scénario, vous rencontrez les problèmes décrits dans la section « Symptômes ». Le correctif qui est décrit dans cet article permet aux stratégies de restriction logicielle d'utiliser moins de mémoire virtuelle pour effectuer la vérification de signature. Par conséquent, Windows Installer peut vérifier les fichiers de toute taille.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional
Mots-clés : 
kberrmsg atdownload kbexpertiseinter kbhotfixserver kbwinserv2003sp2fix KB925336
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