DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 926047 - Dernière mise à jour: vendredi 16 janvier 2015 - Version: 3.0

 
 
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Important Cet article contient des informations sur la façon de modifier le Registre. Veillez à sauvegarder le Registre avant de le modifier. Assurez-vous que vous savez comment restaurer le Registre si un problème survient. Pour plus d'informations sur la façon de sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756  (http://support.microsoft.com/kb/322756/ ) Comment faire pour sauvegarder et restaurer le Registre dans Windows

Sommaire

Symptômes

La zone AutoComplete d'un objet iframe n'apparaisse pas dans l'emplacement correct dans Microsoft Internet Explorer 6.

Cause

Dans certains cas, ce problème se produit car la valeur de la propriété window.screenTop est calculée de manière incorrecte. Dans les autres cas, si l'objet iframe possède un style de position relative, l'offset de l'objet iframe est incorrect lorsqu'il est utilisé pour calculer la position de la zone de Saisie semi-automatique .

Résolution

Windows XP

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et soutien technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :
http://support.Microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables
Vous devez avoir Microsoft Windows XP Service Pack 2 (SP2) pour appliquer ce correctif.
Nécessite un redémarrage
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif remplace le correctif qui est décrit dans l'article 920681 de la Base de connaissances Microsoft.

Informations concernant le Registre

Avertissement Des problèmes graves peuvent se produire si vous modifiez le Registre incorrectement à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent nécessiter que vous réinstallez le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Modifiez le Registre à vos risques et périls.

Après avoir appliqué ce correctif, vous devez ajouter et configurer une valeur de Registre. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, type Regedit, puis cliquez sur OK.
  2. Recherchez, puis cliquez sur la clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Dans le menu Edition , pointez sur Nouveau, puis cliquez sur clé.
  4. Tapez FEATURE_SKIP_ROW_IN_OFFSET_HEIGHT_CALCULATION_KB920681, puis appuyez sur ENTRÉE.

    Notez que le nom de la clé de Registre ne correspond pas le numéro de l'article en cours. La version d'origine de ce correctif a été publiée dans le correctif logiciel 920681. Le correctif a été révisé puis dans cet article de la Base de connaissances Microsoft, et l'article d'origine a été supprimé.
  5. Dans le menu Edition , pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  6. Tapez Iexplore.exe, puis appuyez sur ENTRÉE.
  7. Cliquez droit sur iexplore.exe, puis cliquez sur Modifier.
  8. Tapez 1, puis cliquez sur OK.
  9. Quittez l'Éditeur du Registre.
  10. Redémarrez Internet Explorer.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet fuseau horaire dans l'élément de Date et heure dans le panneau de configuration.

Windows XP avec Service Pack 2 (SP2), les versions basées sur x 86
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Mshtml.dll6.0.2900.30093,060,73605-Oct-200612:30x 86

Windows Server 2003

Informations sur le service pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows Server 2003. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
889100  (http://support.microsoft.com/kb/889100/ ) Comment faire pour obtenir le dernier service pack pour Windows Server 2003

Informations sur le correctif

Pour résoudre ce problème dans Microsoft Windows Server 2003, appliquez le correctif décrit dans l'article suivant de la Base de connaissances Microsoft (KB) :
931306  (http://support.microsoft.com/kb/931306/ )

Statut

Microsoft a confirmé l'existence de ce problème dans Microsoft Internet Explorer 6. Ce problème a été corrigé dans Windows Server 2003 Service Pack 2.

Plus d'informations

Procédure pour reproduire le problème

  1. Ajoutez l'exemple de code suivant dans un fichier texte, puis enregistrez le fichier sous Top.htm.
    <HTML>
    <BODY>
    <DIV style="POSITION: relative;">
        	<IFRAME src="TabFrame2.htm"></IFRAME>
    </DIV>
    </BODY>
    </HTML>
    
  2. Ajoutez le code suivant dans un fichier texte et puis enregistrez le fichier sous Tabframe2.htm.
    <HTML>
    <BODY>
    <FORM>
    <INPUT  name=txtDisplayName>
    </FORM>
    </BODY>
    </HTML>
    
  3. Enregistrer Top.htm et Tabframe2.htm à un serveur Web.
  4. Ouvrir Top.htm, type Hello dans la zone de texte, puis appuyez sur ENTRÉE.
  5. Tapez h dans la zone de texte.
La zone de saisie semi-automatique n'apparaît pas dans l'emplacement correct.
Mots-clés : 
kbnosurvey kbarchive kbautohotfix kbwinserv2003sp2fix kbHotfixServer kbqfe kbfix kbbug kbmt KB926047 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.
La version anglaise de cet article est la suivante: 926047  (http://support.microsoft.com/kb/926047/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store