DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 927391 - Dernière mise à jour: dimanche 25 septembre 2011 - Version: 2.0

Pour continuer à recevoir des mises à jour de sécurité pour Windows, assurez-vous que vous exécutez Windows Vista avec Service Pack 2 (SP2). Pour plus d'informations, reportez-vous à la page Web suivante de Microsoft : Certaines versions de Windows ne seront bientôt plus prises en charge (http://windows.microsoft.com/fr-fr/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs?os=xp)

Le support pour Windows Vista sans service packs installés a pris fin le 13 avril 2010. Pour continuer à recevoir des mises à jour de sécurité pour Windows, assurez-vous que vous exécutez Windows Vista avec le Service Pack 2 (SP2). Pour plus d'informations, consultez la page Web Microsoft suivante : Le support prend fin pour certaines versions de Windows (http://windows.microsoft.com/fr-fr/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs)

Sommaire

Symptômes

Lorsque vous démarrez Windows Vista, le message d'erreur suivant peut s'afficher :
Fichier : \Boot\BCD
Statut : 0xc0000034
Info : Le fichier de données de configuration de démarrage de Windows ne contient pas les informations requises

Cause

Ce problème se produit lorsque l'une ou l'autre des conditions suivantes est remplie :
  • L'entrée Gestionnaire de démarrage Windows (Bootmgr) n'est pas présente dans le magasin de données de configuration de démarrage (BCD).
  • Le fichier Boot\\BCD sur la partition active est endommagé ou manquant.

Résolution

Pour résoudre ce problème, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

Méthode 1 : réparer le magasin BCD en utilisant l'option Réparation du démarrage

Vous pouvez utiliser l'option Réparation du démarrage dans l'environnement de récupération Windows pour réparer le magasin BCD. Pour ce faire, procédez comme suit :
  1. insérez le disque d'installation de Windows Vista dans le lecteur, puis démarrez l'ordinateur.
  2. Appuyez sur une touche lorsque le système vous y invite.
  3. Sélectionnez une langue, une heure, une devise, un clavier ou une méthode d'entrée, puis cliquez sur Suivant.
  4. Cliquez sur Réparer votre ordinateur.
  5. Cliquez sur le système d'exploitation que vous voulez réparer, puis sur Suivant.
  6. Dans la boîte de dialogue Options de récupération système, cliquez sur Réparation du démarrage.
  7. Redémarrez votre ordinateur.

Méthode 2 : reconstruire le magasin BCD en utilisant l'outil Bootrec.exe

Si la méthode précédente ne permet pas de résoudre le problème, vous pouvez reconstruire le magasin BCD en utilisant l'outil Bootrec.exe dans l'environnement de récupération Windows. Pour ce faire, procédez comme suit :
  1. insérez le disque d'installation de Windows Vista dans le lecteur, puis démarrez l'ordinateur.
  2. Appuyez sur une touche lorsque le système vous y invite.
  3. Sélectionnez une langue, une heure, une devise, un clavier ou une méthode d'entrée, puis cliquez sur Suivant.
  4. Cliquez sur Réparer votre ordinateur.
  5. Cliquez sur le système d'exploitation que vous voulez réparer, puis sur Suivant.
  6. Dans la boîte de dialogue Options de récupération système, cliquez sur Invite de commandes.
  7. Tapez Bootrec /RebuildBcd et appuyez sur ENTRÉE.
    • Si l'outil Bootrec.exe s'exécute correctement, il vous propose un chemin d'installation d'un répertoire Windows. Pour ajouter l'entrée au magasin BCD, tapez Oui. Un message de confirmation s'affiche et indique que l'entrée a été ajoutée avec succès.
    • Si l'outil Bootrec.exe ne parvient pas à localiser les installations manquantes de Windows, vous devez supprimer le magasin BCD, puis le recréer. Pour cela, tapez les commandes suivantes en respectant l'ordre dans lequel elles sont présentées. Appuyez sur ENTRÉE après chaque commande.
      Bcdedit /export C:\BCD_Backup
      ren c:\boot\bcd bcd.old
      Bootrec /rebuildbcd
  8. Redémarrez votre ordinateur.

Méthode 3 : reconstruire le magasin BCD en utilisant l'outil Bootrec.exe

Si la méthode précédente ne permet pas de résoudre le problème, vous pouvez reconstruire manuellement le magasin BCD en utilisant l'outil Bcdedit.exe dans l'environnement de récupération Windows. Pour ce faire, procédez comme suit :
  1. insérez le disque d'installation de Windows Vista dans le lecteur, puis démarrez l'ordinateur.
  2. Appuyez sur une touche lorsque le système vous y invite.
  3. Sélectionnez une langue, une heure, une devise, un clavier ou une méthode d'entrée, puis cliquez sur Suivant.
  4. Cliquez sur Réparer votre ordinateur.
  5. Cliquez sur le système d'exploitation que vous voulez réparer, puis sur Suivant.
  6. Dans la boîte de dialogue Options de récupération système, cliquez sur Invite de commandes.
  7. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    cd /d Partition:\Windows\System32
    Remarque Partition représente la lettre de la partition sur laquelle Windows Vista est installé. En général, il s'agit du lecteur C.
  8. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit /enum all
    Dans la section Chargeur de démarrage Windows des résultats de cette commande, notez le GUID qui est répertorié pour resumeobject. Vous utiliserez ce GUID plus tard.
  9. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit -create {bootmgr} -d "Description"
    Remarque Description représente la description pour la nouvelle entrée.
  10. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit -set {bootmgr} device partition=Partition"
    Remarque Partition représente la lettre de la partition. En général, il s'agit de la lettre C.
  11. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit /displayorder {GUID}
    Remarque GUID représente le GUID que vous avez obtenu à l'étape 8.
  12. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit /default {GUID}
    Remarque GUID représente le GUID que vous avez obtenu à l'étape 8.
  13. Tapez la commande suivante, puis appuyez sur ENTRÉE :
    bcdedit /timeout Valeur
    Remarque Valeur représente le temps en secondes avant que le Gestionnaire de démarrage Windows ne sélectionne l'entrée par défaut que vous avez créée à l'étape 12.
  14. Redémarrez votre ordinateur.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Vista Édition Intégrale
  • Windows Vista Entreprise
  • Windows Vista Professionnel
  • Windows Vista Édition Familiale Premium
  • Windows Vista Édition Familiale Basique
  • Windows Vista Professionnel 64 bits
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Windows Vista Édition Intégrale 64 bits
Mots-clés : 
kbexpertiseadvanced kbtshoot kbprb KB927391
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store