DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 933251 - Dernière mise à jour: mercredi 29 août 2007 - Version: 2.4

 
 

Sommaire

Symptômes

Envisagez le scénario suivant. Dans une application, vous essayez d'ouvrir un document XML à l'aide de Windows Internet Explorer. Toutefois, le document XML n'est pas valide. Dans ce scénario, code d'erreur 404 est renvoyée comme prévu. Toutefois, Internet Explorer peut utiliser un pourcentage élevé des ressources du processeur.

Cause

Ce problème se produit car la visionneuse MIME (Multipurpose Internet Mail Extension) de Microsoft XML Parser 3.0 (MSXML 3.0) tente d'ouvrir le document XML. Toutefois, le document XML n'est pas valide.

Résolution

Informations sur le Windows Vista service pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows Vista. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
935791  (http://support.microsoft.com/kb/935791/ ) Comment obtenir le dernier pack de service Windows Vista

Mises à correctifs et de sécurité jour inclus dans le Service Pack 2 pour Windows Vista service et pour Windows Server 2008

Pour plus d'informations sur les correctifs et les mises à jour de sécurité sont incluses dans SP2 pour Windows Vista et pour Windows Server 2008, site le Microsoft TechNet Web suivant:-
http://technet.microsoft.com/en-us/library/dd335033.aspx (http://technet.microsoft.com/en-us/library/dd335033.aspx)
Remarque : Actuellement, la liste des correctifs et de sécurité mises à jour est disponible uniquement en anglais.

Informations sur le correctif Windows Vista et Windows XP

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Vous devez avoir installé pour appliquer ce correctif MSXML 3.0.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif remplace le MSXML 3.0 Service Pack 8.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Microsoft Windows XP x 86 versions
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Msxml3.dll8.90.1010.01,118,72010 Avril 200702:55x 86
Windows Vista, versions 86 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Msxml3.dll8.90.1010.01,205,24811-Avril 200706:31x 86
Msxml3r.dll8.20.8730.12,04811-Avril 200706:31x 86
Windows Vista, versions 64 bits
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Msxml3.dll8.90.1010.01,888,25611-Avril 200707:44x 64
Msxml3r.dll8.20.8730.12,04811-Avril 200707:44x 64

Contournement

Pour contourner ce problème, visitez une page différente dans Internet Explorer.

note Cette action peut contourner pas ce problème si vous utilisez un contrôle de navigateur Web dans l'application.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684  (http://support.microsoft.com/kb/824684/ ) Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft XML Parser 3.0
Mots-clés : 
kbmt kbautohotfix kbvistasp1fix kbfix kbhotfixserver kbqfe kbpubtypekc KB933251 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 933251  (http://support.microsoft.com/kb/933251/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store