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Base de connaissances

Numéro d'article: 935760 - Dernière mise à jour: mercredi 29 août 2007 - Version: 2.1

 
 

Sommaire

Symptômes

Lorsqu'un ordinateur se connecte à un serveur Web à l'aide d'une connexion SSL (Secure Sockets LAYER), une fuite de mémoire se produit dans un processus qui utilise Windows HTTP Services (WinHTTP). Après que ce processus exécution en continu pendant une longue période, il est impossible d'ouvrir toutes les applications. Ou, le système peut cesser de répondre. Par exemple, le système peut cesser de répondre après que le processus d'exécution pour une semaine ou plus.

Ce problème se produit si les conditions suivantes sont remplies :
  • L'ordinateur exécute Microsoft Windows XP avec Service Pack 2 (SP2).
  • La connexion au serveur Web requiert une authentification qui utilise la méthode de base ou la méthode Digest.

Cause

Ce problème se produit en raison d'une erreur dans le fichier WinHTTP.dll.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez être installé Windows XP Service Pack 2 (SP2).

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP, versions 32 bits
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
WinHTTP.dll5.1.2600.3113352,76808-Avril 200707:54x 86

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur les services HTTP Windows, reportez-vous au site de Web Microsoft suivant :
http://msdn2.microsoft.com/en-us/library/aa384273.aspx (http://msdn2.microsoft.com/en-us/library/aa384273.aspx)
Pour plus d'informations sur l'authentification, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/windows/windows2000/en/advanced/iis/htm/core/iiabasc.htm (http://www.microsoft.com/windows/windows2000/en/advanced/iis/htm/core/iiabasc.htm)
Pour plus d'informations sur un problème semblable dans Windows Server 2003, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
918689  (http://support.microsoft.com/kb/918689/ ) Une fuite de mémoire se produit lorsque vous utilisez WinHTTP pour accéder à un serveur Web via une connexion SSL
Pour plus d'informations sur les conditions qui servent à décrire les mises à jour logicielles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684  (http://support.microsoft.com/kb/824684/ ) Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB935760 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 935760  (http://support.microsoft.com/kb/935760/en-us/ )
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