DetailPage-MSS-KB

Base de connaissances

Numéro d'article: 953823 - Dernière mise à jour: mercredi 5 février 2014 - Version: 10.0

Sommaire

INTRODUCTION

Important : Office 2004 pour Mac est arrivé au terme de son cycle de vie de support et ne reçoit plus de support assisté ni de mises à jour de Microsoft. Nous vous recommandons d'effectuer une mise à niveau vers Office 2011 pour Mac (http://www.microsoft.com/france/mac/) pour bénéficier d'une version prise en charge de Microsoft Office. Pour plus d'informations sur la fin du support pour Office 2004 pour Mac, reportez-vous au site Politique de support Microsoft (http://support.microsoft.com/lifecycle/?p1=2490) .


Si vous avez installé la mise à jour Microsoft Office 2004 pour Mac 11.5.0 et le convertisseur de formats de fichier Microsoft Office Open XML pour Mac, vous pouvez utiliser les applications Office 2004 pour ouvrir et enregistrer des fichiers au format Open XML appliqué dans Microsoft Office System 2007 pour Windows et dans Microsoft Office 2008 pour Mac.

Remarque Pour vérifier que votre système d'exploitation Mac répond à cette configuration minimale, cliquez sur À propos de ce Mac dans le menu Apple.

Vous devez télécharger les deux packages suivants sur votre Mac.
  • Pour télécharger la mise à jour de Microsoft Office 2004 pour Mac 11.5.0, visitez le centre de téléchargement Microsoft à l'adresse suivante :
    Réduire cette imageAgrandir cette image
    Télécharger
    Télécharger maintenant la mise à jour de Microsoft Office 2004 pour Mac 11.5.0. (http://www.microsoft.com/fr-fr/download/details.aspx?id=9416)
    Configuration requise : Apple Mac OS X 10.2.8 (Jaguar) ou une version ultérieure de Mac OS
  • Pour télécharger la mise à jour du convertisseur de formats de fichier Open XML pour Mac, visitez le centre de téléchargement Microsoft à l'adresse suivante :
    Réduire cette imageAgrandir cette image
    Télécharger
    Télécharger maintenant le package du convertisseur de formats de fichier Open XML pour Mac. (http://www.microsoft.com/fr-fr/download/details.aspx?id=17091)
    Important Pour ouvrir les documents convertis, Office 2004 version 11.4.0 ou ultérieure ou Office version X 10.1.9 ou ultérieure doit être installé sur l'ordinateur. Nous vous recommandons d'installer la mise à jour Office 2004 11.5.1 ou une mise à jour ultérieure pour Office 2004 pour Mac.

    Configuration requise : Mac OS X version 10.4.9 (Tiger) ou une version ultérieure de Mac OS

Plus d'informations

Formats de fichiers pris en charge

Les fichiers aux formats Open XML suivants peuvent être ouverts et enregistrés dans Office 2004 pour Mac lorsque la mise jour Office 2004 pour Mac 11.5.0 et le convertisseur de formats de fichier Open XML pour Mac sont installés :
  • Document Word 2008 (.docx)
  • Document Word 2008 prenant en charge les macros (.docm)
  • Classeur Excel 2008 (.xlsx)
  • Classeur binaire Excel 2008 (.xlsb)
  • Classeur Excel 2008 prenant en charge les macros (.xlsm)
  • Modèle Excel 2008 (.xltx)
  • Modèle Excel 2008 prenant en charge les macros (.xltm)
  • Complément Excel 2008 (.xlam)
  • Présentation PowerPoint 2008 (.pptx)
  • Présentation PowerPoint 2008 prenant en charge les macros (.pptm)
  • Modèle PowerPoint 2008 (.potx)
  • Modèle PowerPoint 2008 prenant en charge les macros (.potm)
  • Diaporama PowerPoint 2008 (.ppsx)
  • Diaporama PowerPoint 2008 prenant en charge les macros (.ppsm)

Fichiers de conversion

Lorsque la mise à jour Office 2004 pour Mac 11.5.0 et le convertisseur de formats de fichier Open XML pour Mac sont installés, Office 2004 pour Mac reconnait les fichiers de conversion dans le dossier de conversion /Library/Application Support/Microsoft/Office. Les fichiers de conversion suivants sont requis :
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • Open XML pour Charts.app
  • Open XML pour Excel.app
  • Open XML pour Excel.framework
  • Open XML pour Word.app
  • Open XML pour Word.framework
  • pptfc.app
  • SmartArt.framework
Microsoft Office 2008 pour Mac utilise également les fichiers de conversion. Vous ne devez donc pas supprimer ces fichiers de l'ordinateur si vous décidez de supprimer Office 2004 ou le convertisseur Open XML.

Les mises à jour pour les fichiers de conversion sont disponibles dans Microsoft AutoUpdate. Pour savoir s'il existe des mises à jour des fichiers de conversion, ouvrez le convertisseur Open XML. Cliquez ensuite sur Rechercher des mises à jour dans le menu Aide.

Important Vous ne pouvez pas utiliser les versions bêta du convertisseur Open XML avec Office 2004 11.5.0 ou une version ultérieure d'Office 2004. Si une version bêta du convertisseur est installée sur l'ordinateur, téléchargez et installez la version 1.0 ou une version ultérieure du convertisseur Open XML. Pour cela, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://www.microsoft.com/france/mac/ (http://www.microsoft.com/france/mac/)

Polices

Si Microsoft Office 2004 pour Mac est installé sur l'ordinateur, les polices suivantes sont installées dans le dossier /Library/Fonts/Microsoft ou /User/nom_utilisateur/Library/Fonts/Microsoft lorsque vous installez le convertisseur de formats de fichier Open XML pour Mac :
  • Cambria
  • Calibri
  • Consolas
  • Constantia
  • Corbel
  • Candara
Ces polices optimisent la compatibilité des documents et la fidélité des documents lorsque vous ouvrez des documents créés dans Microsoft Office 2007 pour Windows et Microsoft Office 2008 pour Mac.

Problèmes connus d'utilisation des fichiers au format Open XML dans Word 2004

Lorsque vous utilisez un document Word au format Open XML dans Word 2004, vous pouvez rencontrer les problèmes suivants :
  • Les objets Word 2007 Équation ne sont pas conservés.
  • Les nouvelles dispositions et mises en forme de documents disponibles dans Word 2008 pour Mac ou Word 2007 pour Windows ne s'affichent pas correctement dans les fichiers convertis.
  • Les objets HTML, tels que les zones de liste et les zones de texte, sont tronqués dans les fichiers convertis.
  • Les modèles Word 2008 (.dotx) et Word 2008 prenant en charge les macros (.dotm) ne peuvent pas être convertis.
  • Les documents protégés par un mot de passe ou par gestion des droits relatifs à l'information (Information Rights Management, IRM) ne peuvent pas être convertis.
  • Les puces dessinées peuvent être converties en puces standard.
  • Les champs bibliographiques et de citations sont convertis en texte et ne sont pas actualisés automatiquement dans les fichiers convertis.
  • Les couleurs des marques de révision du suivi des modifications ne sont pas nécessairement conservées.
  • Le contenu qui a été déplacé lorsque le suivi des modifications est activé est converti en insertions et suppressions.
  • Les images recoloriées sont converties à la couleur d'origine.
  • Les styles de ligne image sont convertis au style de ligne d'origine.
  • Les annotations manuscrites sont converties en images.
  • Les graphiques et les graphiques SmartArt sont convertis en images.
  • Les filigranes qui contiennent des polices Hiragana ne sont pas conservés.
  • Les polices sont substituées lorsque du texte horizontal qui utilise la police Meiryo est changé en texte vertical dans un fichier converti.
  • Les avertissements et les erreurs liés à la conversion au format Open XML sont toujours affichés en anglais.
  • Impossible d'ouvrir ou de modifier les objets qui sont créés à l'aide de l'Éditeur d'équations dans les fichiers convertis.
  • Les documents au format Open XML qui sont enregistrés dans Word 2004 ne conservent pas les styles de formatage rapide lorsqu'ils sont ouverts dans Word 2007.
  • Vous ne pouvez pas enregistrer simultanément plusieurs documents au format Open XML dans Word 2004.
  • Le contenu du document n'est pas affiché correctement, car il peut contenir un graphique incompatible. Les documents Open XML qui sont enregistrés dans Word 2004 sont enregistrés en mode de compatibilité. Le contenu créé dans Word 2007 pour Windows ou Word 2008 pour Mac peut ne pas être affiché ou ne pas fonctionner comme prévu lorsque vous ouvrez le document dans ces applications. Pour restaurer le contenu, ouvrez le document dans Word 2008, double cliquez sur le graphique pour le modifier puis, à l'invite, sélectionnez le graphique. Après la conversion, revenez à Word et enregistrez le document.
  • Si vous modifiez un graphique SmartArt dans Word 2004, l'arrière-plan peut parfois devenir noir.
  • Les graphiques SmartArt en ligne sont inopinément convertis en images lorsque vous enregistrez un document au format Open XML dans Word 2004.
  • Les présentations PowerPoint 2007, les graphiques et feuille Excel 2007 et les graphiques et feuilles Excel 2008 incorporés dans les documents au format Open XML ne peuvent pas être modifiés dans Word 2004.
  • L'option Envoyer ver e-mail du menu Fichier dans Word 2004 envoie les documents au format document de Word (.doc). Cela se produit même si le fichier que vous envoyez est au format Open XML.
  • Lorsque vous ouvrez un document au format Open XML, l'indicateur de progression dans Word 2004 n'indique pas précisément la progression.
  • Si vous enregistrez un document au format Open XML, qui ne contient pas de macro au format Word 2008 prenant en charge les macros (.docm), le message d'erreur « Fichier introuvable » s'affiche. Vous pouvez ignorer ce message en toute sécurité.
  • Envisagez le scénario suivant :
    1. Vous ouvrez un document Microsoft Office Word qui utilise l'extension de nom de fichier .docm.
    2. Ce document Office Word ne contient pas de macro ni de code Visual Basic.
    3. Vous ouvrez l'éditeur Visual Basic à l'aide du sous-menu Macro du menu Outils.
    Dans ce scénario, Visual Basic Editor s'ouvre sans projet disponible pour le document Office Word.

    Pour résoudre ce problème, enregistrez le document au format de document Word (.docx), fermez et rouvrez le document, puis ouvrez Visual Basic Editor.
  • Envisagez le scénario suivant :
    1. Les utilisateurs de Mac OS X 10.5 (Leopard) ouvrent un document au format Open XML.
    2. Ce document est stocké sur un volume réseau.
    3. Les utilisateurs se connectent au volume réseau à l'aide du protocole SMB
    Dans ce scénario, le document s'ouvre en lecture seule dans Word 2004.

Problèmes connus d'utilisation des fichiers au format Open XML dans Excel 2004

Lorsque vous utilisez un classeur Excel au format Open XML dans Excel 2004, vous pouvez rencontrer les problèmes suivants :
  • Les classeurs protégés par un mot de passe ou par gestion des droits relatifs à l'information (Information Rights Management, IRM) ne peuvent pas être convertis.
  • Les données au-delà de la ligne 65 256 ou de la colonne 256 ne sont pas conservées. Les formules qui font référence à des données dans cette région renvoient la valeur d'erreur « #REF! ».
  • Plusieurs règles de mise en forme conditionnelle dans une cellule ne sont pas conservées. Excel arrête l'évaluation après l'évaluation et l'affichage de la première condition.
  • Les nouvelles fonctions dans Excel 2008 ne sont pas conservées. Ces fonctions renvoient la valeur d'erreur #NAME? au lieu des résultats calculés.
  • Des formules avec plus de 29 arguments définis par l'utilisateur ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #VALUE! ».
  • Les contrôles ActiveX non initialisés ne sont pas conservés.
  • Les formules contenant des références à des tableaux d'autres classeurs ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #REF! ».
  • Les formules contenant plus de 30 arguments dans une cellule ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #VALUE! ».
  • Les types de mise en forme conditionnelle dans une plage non adjacente ne sont pas conservés.
  • Les rapports de tableau croisé dynamique qui ont plus de 8 000 éléments ne peuvent pas être convertis.
  • Les formules qui dépassent la limite de longueur interne (1 800 caractères) ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #VALUE! ».
  • Les formules qui dépassent la limite de niveau d'imbrication de 7 niveaux ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #VALUE! ».
  • Les dates dans des formats de calendrier non pris en charge sont inopinément converties au format de calendrier grégorien.
  • Les formats de cellules uniques qui dépassent la limite interne (4 050 caractères) ne sont pas conservés.
  • La mise en forme conditionnelle de l'option Mettre en forme la ligne complète n'est pas conservée.
  • Les formules de validation de date qui ont plus de 255 caractères ne sont pas conservées.
  • Les cellules avec plus de trois formats conditionnels affichent uniquement les trois premières conditions.
  • Les effets Excel 2008 appliqués aux objets ne sont pas conservés.
  • Les formats de polices uniques qui dépassent les limites internes ne sont pas conservés.
  • Les formules qui contiennent plus de 40 opérandes ne sont pas conservées. Ces formules sont converties en valeur d'erreur « #VALUE! ».
  • Les filtres de données suivants ne sont pas conservés :
    • personnalisé
    • par icône
    • par couleur
    • groupe de dates
    • 10 premiers
    • couleur de police
    • par barre de données
  • Plus de deux critères de tri ne sont pas conservés.
  • Les paramètres spécifiques de Windows pour la publication automatique sur le Web ne sont pas conservés.
  • Plusieurs filtres sur un tri ne sont pas conservés.
  • Les graphiques SmartArt sont convertis en images.
  • Les documents Word 2008, les classeurs Excel 2008 et les présentations PowerPoint 2008, liés ou incorporés, ne peuvent pas être ouverts ni modifiés dans des fichiers convertis.
  • Vous ne pouvez pas enregistrer simultanément plusieurs classeurs au format Open XML dans Excel 2004.

Problèmes connus d'utilisation des fichiers au format Open XML dans PowerPoint 2004

Lorsque vous utilisez une présentation PowerPoint au format Open XML dans PowerPoint 2004, vous pouvez rencontrer les problèmes suivants :
  • Les présentations protégées par un mot de passe ou par gestion des droits relatifs à l'information (Information Rights Management, IRM) ne peuvent pas être converties.
  • Le soulignement double est converti en soulignement simple.
  • Les paramètres d'espacement de caractères personnalisés ne sont pas conservés.
  • Les paramètres de mosaïque ne sont pas conservés dans les présentations converties si une image en mosaïque a été utilisée comme arrière-plan d'une diapositive.
  • Les présentations PowerPoint qui contiennent des objets ayant des effets 3D peuvent être longs à convertir.
  • Les dates japonaises empilées ne s'affichent pas correctement dans les fichiers convertis.
  • Les graphiques SmartArt sont convertis en images.
  • Les listes à puces avec plus de cinq niveaux sont converties en images.
  • Le contenu converti en images contient des polices de substitution si les polices de la présentation d'origine ne sont pas installées sur l'ordinateur.
  • Les ombres douces sont converties en ombres marquées.
  • Les nouvelles diapositives qui sont ajoutées à un fichier converti ont une disposition brute à la place d'une disposition en liste à puces.
  • Vous ne pouvez pas enregistrer simultanément plusieurs présentations au format Open XML dans PowerPoint 2004.
  • Les documents Word 2008, les classeurs Excel 2008 et les présentations PowerPoint 2008 incorporés ne peuvent pas être ouverts ni modifiés dans des fichiers convertis.
  • Lorsque des modèles PowerPoint 2008 (.potx) et des modèles PowerPoint 2008 prenant en charge les macros (.potm) sont convertis, la boîte de dialogue Enregistrer sous ne s'ouvre pas à l'enregistrement d'un fichier. Vous pouvez toutefois cliquer sur l'option Enregistrer sous du menu Fichier pour ouvrir la boîte de dialogue Enregistrer sous.
  • Les graphiques créés dans PowerPoint 2007 pour Windows ou PowerPoint 2008 pour Mac peuvent ne pas s'afficher ou ne pas fonctionner comme prévu si vous enregistrez une présentation dans PowerPoint 2004 et que vous ouvrez le document dans PowerPoint 2007 ou dans PowerPoint 2008. Pour restaurer le contenu, ouvrez le document dans PowerPoint 2008, double cliquez sur le graphique pour le modifier et, à l'invite, choisissez la conversion du graphique. Après la conversion, revenez à PowerPoint et enregistrez le document.
  • Les graphiques qui ont été créés dans PowerPoint 2007 pour Windows ou dans PowerPoint 2008 pour Mac s'affichent comme des images dans PowerPoint 2004.
  • Les présentations prenant en charge les macros ne peuvent pas être enregistrées dans un format de fichier ne prenant pas en charge les macros dans PowerPoint 2004. En outre, ce problème se produit même si vous supprimez toutes les macros de la présentation.
  • PowerPoint 2004 peut ajouter plusieurs extensions de nom de fichier au nom du fichier. Par exemple, le nom de fichier peut être « monfichier.pptx.pptm ». Ce problème se produit lorsque vous ouvrez une présentation qui utilise un format ne prenant pas en charge les macros, que vous lui ajoutez une macro et que que vous l'enregistrez dans un format prenant en charge les macros. Pour résoudre ce problème, avant d'enregistrer le fichier, supprimez l'extension de nom de fichier ne prenant pas en charge les macros du nom du fichier dans la boîte de dialogue Enregistrer sous.
  • Si PowerPoint 2004 ne répond plus lorsqu'il convertit une présentaton au format Open XML, vous devez redémarrer l'ordinateur ou lancer le Moniteur d'activité dans le dossier /Applications/Utilities pour fermer le processus Pptfc.app avant d'ouvrir ou d'enregistrer de nouveau des présentations au format Open XML.

Plus d'informations

Rubrique connexe concernant les dernières mises à jour que vous pouvez installer

Cliquez sur les liens suivants pour trouver d'autres options au cas où cet article ne peur résoudre votre problème : Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office 2004 pour Mac Edition Professionnelle
  • Microsoft Office 2004 pour Mac Edition Standard
  • Microsoft Office 2004 pour Mac Edition Etudiants and Enseignants
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft Word 2004 for Mac
Mots-clés : 
dftsdahomeportal kbexpertisebeginner kbinfo KB953823
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Partager
Options de support supplémentaire
Forums du support Microsoft Community
Nous contacter directement
Trouver un partenaire Microsoft Certified Partner
Microsoft Store