DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 177321 - Ultima modifica: venerdì 30 novembre 2012 - Revisione: 5.0

 
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I177321

In questa pagina

Sintomi

Quando si prova a visualizzare un file pdf (Portable Document Format) in Internet Explorer, viene visualizzata una finestra o cornice vuota anziché il file pdf. Ciò può verificarsi anche se il programma Adobe Acrobat Reader è installato ed è di solito possibile visualizzare file pdf utilizzando tale programma.

Cause

Questo funzionamento può essere causato da una delle seguenti situazioni:

  • È necessaria una versione aggiornata di Adobe Acrobat Reader in grado di utilizzare l'attivazione diretta. L'attivazione diretta è una funzione che consente di aprire un file di programma in Internet Explorer e visualizzare le barre degli strumenti del programma associato.
  • Il livello di sicurezza per quest'area è impostato su Alta in Internet Explorer 4.0, 4.01 o 5. Per informazioni sulle aree di sicurezza in Internet Explorer, vedere l'articolo seguente nella Knowledge Base:
    174360  (http://support.microsoft.com/kb/174360/it/ ) Come utilizzare le aree di sicurezza in Internet Explorer 4.0
  • Sono attivate restrizioni d'accesso in Internet Explorer 3.02 oppure il livello di sicurezza è impostato su Alta.
  • Il file pdf si serve di una versione precedente di alcuni server Web (ad esempio Microsoft Internet Information Server versione 2.0).
  • Questo problema può essere correlato a una connessione lenta, a un ingente carico di lavoro del server o alla grande dimensione del file pdf.
  • Si utilizza una versione di Internet Explorer precedente alla 5.5.
Questo problema può essere causato da un controllo ActiveX danneggiato. Per utilizzare l'attivazione diretta di Adobe Acrobat Reader 4 con Internet Explorer, è necessario che i file Pdf.ocx e Pdf.tlb siano presenti nella cartella x:\Programmi\Adobe\Acrobat 4.0\Acrobat\ActiveX\ dove x è la lettera di unità nella quale è installato Adobe Acrobat Reader. Se uno di questi file non è presente, è possibile che venga visualizzata una finestra vuota di Internet Explorer durante l'apertura di un file pdf.

Risoluzione

Per risolvere il problema, attenersi alle procedure della sezione pertinente riportate qui di seguito:

Effettuare l'aggiornamento a Internet Explorer 5.5

In Internet Explorer 5.5 il problema della visualizzazione di una pagina vuota durante il recupero di un file PDF è stato risolto mediante il metodo POST. Con l'aggiornamento alla versione 5.5 di Internet Explorer il problema viene risolto. Visitare il seguente sito Web:
http://windows.microsoft.com/it-it/internet-explorer/download-ie (http://windows.microsoft.com/it-it/internet-explorer/download-ie)

Internet Explorer 4.0, 4.01 e 5

Se si utilizza la versione 3.0 di Adobe Acrobat Reader o quella precedente, passare alla versione 4.0 o a quella successiva. Se si utilizza già la versione 4.0 o quella successiva, attenersi alla seguente procedura:
  1. Modificare il livello di sicurezza utilizzato in Internet Explorer in media o bassa. Per poter visualizzare file pdf in Internet Explorer 4.0, 4.01 o 5, è necessario impostare la sicurezza su media o bassa. Per modificare il livello di sicurezza, attenersi alla seguente procedura.

    NOTA: se non si desidera ridurre il livello di sicurezza dell'area, passare al punto 2.
    1. Avviare Internet Explorer, quindi scegliere Opzioni Internet dal menu Visualizza. Per Internet Explorer 5.0 scegliere Opzioni Internet dal menu Strumenti.
    2. Fare clic sulla scheda Sicurezza, selezionare Area Internet nella casella relativa all'area, scegliere Media (scelta più sicura) o Bassa e fare clic su OK.
  2. Scaricare il file pdf e aprirlo utilizzando il programma Adobe Acrobat Reader.

Internet Explorer 3.02

Se si utilizza la versione 3.0 di Adobe Acrobat Reader o quella precedente, passare alla versione 3.01 o a quella successiva. Se si utilizza già la versione 3.01 o quella successiva, utilizzare uno o entrambi dei seguenti metodi:

Disattivazione delle restrizioni in Internet Explorer

Per disattivare le restrizioni in Internet Explorer, attenersi alla seguente procedura:
  1. Avviare Internet Explorer, quindi scegliere Opzioni dal menu Visualizza.
  2. Scegliere Disattiva restrizioni dalla scheda Sicurezza, quindi fare clic su OK.
  3. Chiudere Internet Explorer.
  4. Scaricare il file pdf e aprirlo utilizzando il programma Adobe Acrobat Reader.

Riduzione del livello di sicurezza

Modificare il livello di sicurezza utilizzato in Internet Explorer in media o bassa. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Visualizza.
  2. Nella scheda Sicurezza, scegliere Livello di sicurezza.
  3. Scegliere Media e fare clic su OK due volte.
  4. Chiudere Internet Explorer.
  5. Scaricare il file pdf e aprirlo utilizzando il programma Adobe Acrobat Reader.

Connessione lenta

Se la connessione di cui si dispone è lenta, il server è occupato o si sta tentando di scaricare un file di grandi dimensioni, attendere che sia terminato il download del file prima di visualizzarlo.

Disinstallare e reinstallare Adobe Acrobat Reader 4

  1. Nel Pannello di controllo, fare doppio clic su Installazione applicazioni.
  2. Fare doppio clic su Adobe Acrobat Reader 4 per disinstallare l'applicazione. Seguire la procedura guidata per disinstallare l'applicazione.
  3. Scaricare Adobe Acrobat Reader 4 dal sito Web di Adobe se necessario.
  4. Cercare il file Rs405eng.exe e quindi fare doppio clic per avviare la reinstallazione dell'applicazione.
  5. Nonostante non venga richiesto di riavviare il computer durante l'installazione, chiudere e riavviare il computer.
  6. Dovrebbe essere visualizzato il file pdf in Internet Explorer quando si fa clic su un collegamento a un file pdf su Internet.

Soluzione alternativa

  1. Aprire Adobe Acrobat Reader 4, nel menu File, fare clic su Preferenze, quindi fare clic su Generale.
  2. Deselezionare la casella di controllo Integrazione browser Web, quindi scegliere OK.
  3. Quando si fa clic su un collegamento a un file pdf, viene richiesto di salvare il file nella finestra di dialogo Download file. È possibile salvare il file, quindi fare doppio clic su di esso per aprirlo. Ciò consente di aprire il file in Adobe Acrobat Reader.

    Se si sceglie Apri file dalla posizione corrente, il file dovrebbe aprirsi in Adobe Acrobat Reader 4 e non in Internet Explorer.

Informazioni

Con Internet Explorer è possibile utilizzare il visualizzatore di Adobe Acrobat come controllo. In seguito a una modifica del modello di oggetti da Internet Explorer 3.0 a Internet Explorer 4.0, Adobe ha dovuto aggiornare il visualizzatore in modo che potesse funzionare con il modello di oggetti di Internet Explorer 4.0. Per ottenere una versione aggiornata di Adobe Acrobat, contattare Adobe.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
253213  (http://support.microsoft.com/kb/253213/it/ ) Indirizzo non corretto passato durante l'utilizzo del metodo POST o del metodo GET
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.
Chiavi: 
kbenv kbui KB177321
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Articolo KB ritiratoDichiarazione di non responsabilità per articoli della Microsoft Knowledge Base su prodotti non più supportati
Questo articolo è stato scritto sui prodotti per cui Microsoft non offre più supporto. L’articolo, quindi, viene offerto ‘così come è’ e non verrà più aggiornato.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store