DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 2646563 - Ultima modifica: mercoledì 11 gennaio 2012 - Revisione: 1.0

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 

In questa pagina

Sintomi

Si consideri il seguente scenario:
  • Si accede a una cartella condivisa da un computer che esegue Windows 7 o Windows Server 2008 R2.
  • La cartella condivisa si trova su un computer remoto.
  • Il computer in uso è sotto un carico pesante.
  • Viene eliminato un file nella cartella condivisa.
  • Si tenta di creare un nuovo file nella cartella condivisa che ha lo stesso nome di file del file eliminato.
In questo scenario, il tentativo di creazione del file potrebbe avere esito negativo. Inoltre, viene visualizzato il seguente messaggio di errore:
FILE_EXISTS

Cause

Questo problema si verifica a causa di un problema di temporizzazione del redirector di Server Message Block (SMB) versione 2 (Mrxsmb20.sys). Quando si verifica questo problema di temporizzazione, è possibile che la cache della directory non viene aggiornato correttamente.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix vengano eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il prossimo aggiornamento software contenente tale hotfix.

Se l'aggiornamento rapido è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" nella parte superiore di questo articolo della Knowledge Base riportato di seguito. Se non viene visualizzato in questa sezione, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è richiesta la risoluzione dei problemi, è necessario creare una richiesta di assistenza separata. I costi di supporto usuali verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire uno dei seguenti sistemi operativi:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
976932  (http://support.microsoft.com/kb/976932/ ) Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per applicare l'hotfix descritto in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo aver applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e gli orari di questi file sono elencati nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e i tempi cambiano quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows 7 e Windows Server 2008 R2
  • I file che si applicano a un prodotto specifico, un'attività cardine (RTM, SPn), e il ramo del servizio (LDR, GDR) può essere identificato esaminando i numeri di versione del file, come illustrato nella tabella riportata di seguito:
    Riduci questa tabellaEspandi questa tabella
    VersioneProdottoAttività cardineRamo del servizio
    6.1.760 0,21xxxWindows 7 e Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 e Windows Server 2008 R2SP1LDR
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente Nella sezione "ulteriori informazioni sui file per Windows Server 2008 R2 e Windows 7". MUM e i file di manifesto e i file di catalogo (CAT) di protezione associati sono estremamente importanti mantenere lo stato dei componenti aggiornati. I file del catalogo di protezione per il quale gli attributi non sono elencati, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni basate su x86 di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mrxsmb20.sys6.1.7600.2109797,28024-Nov-201104: 14x86
Mrxsmb20.sys6.1.7601.2186696.76824-Nov-201104: 09x86
Per tutte le versioni basate su x64 di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mrxsmb20.sys6.1.7600.21097128,51224-Nov-201104: 32x64
Mrxsmb20.sys6.1.7601.21866128.00024-Nov-201104: 23x64
Per tutte le versioni supportate basati su IA-64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mrxsmb20.sys6.1.7600.21097313,34424-Nov-201103: 30IA-64
Mrxsmb20.sys6.1.7601.21866310,78424-Nov-201103: 20IA-64

Workaround

Per aggirare questo problema, disattivare la cache della directory SMB2.

NotaDisattivando la cache della directory SMB2 potrebbe avere effetti negativi sulle prestazioni. Per ulteriori informazioni su come disabilitare la cache della directory, visitare il seguente sito Web Microsoft:
Informazioni generali sulla cache dei redirector client SMB2 (http://technet.microsoft.com/library/ff686200(WS.10).aspx)

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2

File aggiuntivi per tutte le versioni basate su x86 di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileX86_2465794767a198d1a0ccdca868a588df_31bf3856ad364e35_6.1.7600.21097_none_c9ce436080d07b94.manifest
Versione del fileNon applicabile
Dimensione del file701
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileX86_aa2298554b62be7b0158384060f322e9_31bf3856ad364e35_6.1.7601.21866_none_30a99312e1e81ad6.manifest
Versione del fileNon applicabile
Dimensione del file701
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21097_none_8b31fad2043d89d5.manifest
Versione del fileNon applicabile
Dimensione del file4,035
Data (UTC)24-Nov-2011
Ora (UTC)07: 21
Nome del fileX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21866_none_8d37f116014c527c.manifest
Versione del fileNon applicabile
Dimensione del file4,035
Data (UTC)24-Nov-2011
Ora (UTC)07: 24
File aggiuntivi per tutte le versioni basate su x64 di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileAmd64_8e7cad98418286868f94fa69d5eee171_31bf3856ad364e35_6.1.7601.21866_none_2d1b5d6a354e9637.manifest
Versione del fileNon applicabile
Dimensione del file705
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileAmd64_b59a5b0efe06ee1e6e8a48449685528c_31bf3856ad364e35_6.1.7600.21097_none_8e57f20c983c52c0.manifest
Versione del fileNon applicabile
Dimensione del file705
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21097_none_e7509655bc9afb0b.manifest
Versione del fileNon applicabile
Dimensione del file4,039
Data (UTC)24-Nov-2011
Ora (UTC)08: 21
Nome del fileAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21866_none_e9568c99b9a9c3b2.manifest
Versione del fileNon applicabile
Dimensione del file4,039
Data (UTC)24-Nov-2011
Ora (UTC)08: 13
File aggiuntivi per tutte le versioni supportate basati su IA-64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileIa64_3b48ce75767948f8e2dbbb95c42bd44a_31bf3856ad364e35_6.1.7600.21097_none_1ae25ed5eb4a5f45.manifest
Versione del fileNon applicabile
Dimensione del file703
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileIa64_99a0b8152c34ab008c08b96bf87e387b_31bf3856ad364e35_6.1.7601.21866_none_98fede0929eecb57.manifest
Versione del fileNon applicabile
Dimensione del file703
Data (UTC)24-Nov-2011
Ora (UTC)12: 40
Nome del fileIa64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21097_none_8b339ec8043b92d1.manifest
Versione del fileNon applicabile
Dimensione del file4,037
Data (UTC)24-Nov-2011
Ora (UTC)07: 47
Nome del fileIa64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21866_none_8d39950c014a5b78.manifest
Versione del fileNon applicabile
Dimensione del file4,037
Data (UTC)24-Nov-2011
Ora (UTC)07: 39

Le informazioni in questo articolo si applicano a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Chiavi: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2646563 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2646563  (http://support.microsoft.com/kb/2646563/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store