DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 320397 - Ultima modifica: mercoledì 8 gennaio 2014 - Revisione: 1.0

Sintomi

Se vengono copiati molti file nella cartella principale di un volume di avvio che utilizza il file system NTFS, al successivo riavvio del computer è possibile che venga visualizzato il seguente messaggio di errore:
NTLDR mancante.
Premere CTRL+ALT+CANC per riavviare.
Se si rimuovono i file copiati nella cartella principale, l'indice di allocazione della tabella file master (MFT, Master File Table) non viene ridotto alla dimensione originale.

Nota Se si utilizza Windows XP con Service Pack 2 (SP2) o Microsoft Windows 2000 con Service Pack 4 (SP4), questo non è un problema. Per problemi simili, visualizzare la sezione "Ulteriori informazioni".

Cause

Questo problema può verificarsi se la cartella principale della MFT è particolarmente frammentata. Se nella cartella principale della MFT sono presenti numerosi file, questa potrebbe diventare talmente frammentata da causare la creazione di un ulteriore indice di allocazione. Poiché negli indici di allocazione il mapping dei file viene effettuato alfabeticamente, è possibile che il file NTLDR venga spostato nel secondo indice di allocazione. In questo caso viene visualizzato il messaggio di errore riportato nella sezione "Sintomi".

Di solito non vengono scritti file nella cartella principale. Questa condizione può verificarsi se vengono creati e rimossi regolarmente file temporanei nella cartella principale da parte di un programma oppure se in essa vengono copiati per errore molti file.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura: 
  1. Contattare il supporto tecnico clienti Microsoft per ottenere lo strumento Bcupdate2.exe. Per ulteriori informazioni su come contattare il Servizio Supporto Tecnico Clienti Microsoft, visitare il seguente sito Web Microsoft:
    http://support.microsoft.com/contactus/?ws=support&ln=it (http://support.microsoft.com/contactus/?ws=support&ln=it)
  2. Creare un disco di avvio per avviare il computer. Per ulteriori informazioni sulla creazione di un disco di avvio per un computer basato su Windows XP, fare clic sul seguente numero di articolo per visualizzare l'articolo nella Microsoft Knowledge Base:
    305595  (http://support.microsoft.com/kb/305595/ ) HOW TO: Creare un disco di avvio per una partizione NTFS o FAT con Windows XP
  3. Eseguire il comando riportato di seguito al prompt dei comandi per estrarre il programma di Bcupdate2.exe dall'aggiornamento software:

    Espandere lettera_unità: \bcupdate2.ex_ lettera_unità: \bcupdate2.exe
  4. Eseguire il comando riportato di seguito al prompt dei comandi per aggiornare il codice di avvio del settore di avvio NTFS:

    Bcupdate2.exe c: /F

    Nota Sono supportati altri parametri della riga di comando:
    /q - modalità non interattiva (è necessario includere /y)
    /y - Non conferma
    /f - Forza l'aggiornamento del volume in uso
    /t - Solo test per il precedente codice di avvio
  5. Premere Y se viene richiesto di aggiornare il volume. Dopo aver eseguito questa utilità, viene visualizzato il seguente messaggio:
    Il codice di avvio è stato aggiornato correttamente.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati all'inizio del presente articolo.
Questo problema è stato corretto per la prima volta nel Service Pack 2 per Windows XP.
Questo problema è stato corretto per la prima volta in Windows 2000 Service Pack 4. Per ulteriori informazioni su come ottenere i Service Pack più recenti, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito: 
322389  (http://support.microsoft.com/kb/322389/ ) Acquisizione della versione più recente del service pack di Windows 2000
260910  (http://support.microsoft.com/kb/260910/ ) Acquisizione della versione più recente del service pack di Windows 2000
Nota Se si installa il Service Pack per Windows XP o per Windows 2000, non verranno risolti i problemi relativi a un volume esistente. Sarà necessario eseguire lo strumento per aggiornare separatamente il codice di avvio. Il Service Pack consentirà solo la scrittura del codice di avvio corretto per i nuovi volumi.

Informazioni

Per ulteriori informazioni su un argomento correlato, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
318728  (http://support.microsoft.com/kb/318728/ ) Come risolvere il messaggio di errore "NTLDR mancante" in Windows 2000
886215  (http://support.microsoft.com/kb/886215/ ) È possibile che venga visualizzato un messaggio di errore "NTLDR mancante. Premere qualsiasi tasto per riavviare" quando si aggiorna un computer basato su Windows 98 a Windows 2000 Professional
816793  (http://support.microsoft.com/kb/816793/ ) Come risolvere il messaggio di errore "NTLDR manca" in Windows Server 2003
842009  (http://support.microsoft.com/kb/842009/ ) Errore "NTLDR mancante" quando si tenta di eseguire il ripristino automatico di sistema in Windows Server 2003
883275  (http://support.microsoft.com/kb/883275/ ) Non è possibile avviare il computer dopo aver modificato le autorizzazioni in Windows Server 2003, Windows XP o Windows 2000
315261  (http://support.microsoft.com/kb/315261/ ) Impossibile avviare il computer dopo la modifica della partizione attiva mediante lo strumento Gestione disco
812492  (http://support.microsoft.com/kb/812492/ ) Messaggio di errore quando si avvia il computer con un disco non di sistema
228004  (http://support.microsoft.com/kb/228004/ ) La modifica della partizione attiva può impedire l'avvio del sistema
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo (http://go.microsoft.com/fwlink/?LinkId=151500) .

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Chiavi: 
kbresolve kbwinxpsp2fix kbwin2ksp4fix kbbug kbfix KB320397
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store