DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 324767 - Ultima modifica: venerdì 31 gennaio 2014 - Revisione: 1.0

In questa pagina

Sintomi

Se si tenta di avviare o installare un programma per MS-DOS o Windows a 16 bit in un computer con Windows XP, è possibile che venga visualizzato un messaggio di errore analogo al seguente:
Sottosistema MS-DOS a 16 bit
percorso del programma che si sta tentando di avviare o installare
C:\Winnt\System32\config.nt Il file di sistema non è adatto all'esecuzione di applicazioni DOS e Microsoft Windows. Scegliere "Chiudi" per terminare l'applicazione.
Sottosistema MS-DOS a 16 bit
percorso del programma che si sta tentando di avviare o installare
config.nt Il file di sistema non è adatto all'esecuzione di applicazioni DOS e Microsoft Windows. Scegliere "Chiudi" per terminare l'applicazione.
Sottosistema MS-DOS a 16 bit
percorso del programma che si sta tentando di avviare o installare
C:\Windows\System32\Autoexec.nt Il file di sistema non è adatto all'esecuzione di applicazioni DOS e Microsoft Windows. Scegliere "Chiudi" per terminare l'applicazione.
Sebbene sia offerta la possibilità di chiudere il programma o ignorare il messaggio di errore, entrambe le opzioni determinano la chiusura del programma.

Cause

Il problema può verificarsi in caso di mancanza o danneggiamento di uno o più dei seguenti file:
  • Config.nt
  • Autoexec.nt
  • Command.com

Risoluzione

Per risolvere il problema, utilizzare uno dei seguenti metodi.

Metodo 1

  1. Inserire il CD nell'unità CD-ROM o DVD-ROM.
  2. Fare clic sul pulsante Start, quindi scegliere Esegui.
  3. Nella casella Apri digitare cmd, quindi scegliere OK.
  4. Al prompt dei comandi, digitare i comandi riportati di seguito premendo INVIO dopo ogni comando:

    expand lettera dell'unità CD-ROM:\i386\config.nt_ c:\windows\system32\config.nt
    expand lettera dell'unità CD-ROM:\i386\autoexec.nt_ c:\windows\system32\autoexec.nt
    expand lettera dell'unità CD-ROM:\i386\command.co_ c:\windows\system32\command.com
    exit
  5. Avviare o installare il programma. Se il problema è stato risolto, ignorare i passaggi rimanenti. Se il problema persiste, procedere con il passaggio successivo.
  6. Nota: durante il processo riportato di seguito non viene modificato o creato il file Command.com. Per questo motivo può essere necessario espanderlo dal CD di Windows XP.

    Avviare il Blocco note.
  7. Nel Blocco note digitare quanto segue:
       dos=high, umb device=%SYSTEMROOT%\system32\himem.sys files=40
  8. Scegliere Salva con nome dal menu File.
  9. Nella casella Nome file digitare Config.nt, quindi scegliere Salva. Chiudere il file Config.nt.
  10. Scegliere Nuovo dal menu File.
  11. Nel nuovo documento vuoto digitare quanto segue:
    @echo off lh %SYSTEMROOT%\system32\mscdexnt.exe lh %SYSTEMROOT%\system32\redir lh %SYSTEMROOT%\system32\dosx SET BLASTER=A220 I5 D1 P330 T3
  12. Scegliere Salva con nome dal menu File.
  13. Nella casella Nome file digitare Autoexec.nt, quindi scegliere Salva. Chiudere il file Autoexec.nt.
  14. Avviare Esplora risorse. Individuare e fare clic con il pulsante destro del mouse sul file Config.nt, quindi scegliere Copia.
  15. Fare clic con il pulsante destro del mouse sulla cartella %SYSTEMROOT%\System32, quindi scegliere Incolla.
  16. Individuare e fare clic con il pulsante destro del mouse sul file Autoexec.nt, quindi scegliere Copia.
  17. Fare clic con il pulsante destro del mouse sulla cartella %SYSTEMROOT%\System32, quindi scegliere Incolla.
  18. Individuare e fare clic con il pulsante destro del mouse sul file Command.com espanso, quindi scegliere Copia.
  19. Fare clic con il pulsante destro del mouse sulla cartella %SYSTEMROOT%\System32, quindi scegliere Incolla. Riavviare il computer.
Se il problema persiste, copiare i file Autoexec.nt e Config.nt dalla cartella Repair di Windows alla cartella System. A questo scopo, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare c:\windows\repair, quindi scegliere OK.
  2. Fare clic con il pulsante destro del mouse sul file Autoexec.nt, quindi scegliere Copia.
  3. Fare clic sul pulsante Start, scegliere Esegui, digitare c:\windows\system32, quindi scegliere OK.
  4. Fare clic con il pulsante destro del mouse in un punto qualsiasi della cartella, quindi scegliere Incolla.
  5. Fare clic con il pulsante destro del mouse sul file Autoexec.nt appena copiato, quindi scegliere Proprietà.
  6. Selezionare Sola lettura, quindi scegliere OK.
  7. Ripetere i passaggi da 1 a 6 per copiare il file Config.nt.
Nota È necessario attivare le autorizzazioni di sola lettura, altrimenti i file verranno rimossi dopo il riavvio di Windows.

Metodo 2

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare c:\windows\repair, quindi scegliere OK.
  2. Fare clic con il pulsante destro del mouse sul file Autoexec.nt, quindi scegliere Copia.
  3. Fare clic sul pulsante Start, scegliere Esegui, digitare %windir%\system32, quindi scegliere OK.
  4. Nella cartella System32 premere Ctrl + V per incollarvi il file Autoexec.nt.

Informazioni

Per ulteriori informazioni sui programmi per MS-DOS in Windows, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
305521  (http://support.microsoft.com/kb/305521/it/ ) Il messaggio di errore del sottosistema MS-DOS a 16 bit viene visualizzato quando si esegue un programma per MS-DOS o Windows a 16 bit in Windows Server 2003 o in Windows 2000 Server
314106  (http://support.microsoft.com/kb/314106/it/ ) Risoluzione dei problemi di programmi MS-DOS in Windows XP
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo (http://go.microsoft.com/fwlink/?LinkId=151500) .

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Chiavi: 
kberrmsg kbprb KB324767
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store