DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 834427 - Ultima modifica: martedì 26 settembre 2006 - Revisione: 2.1

In questa pagina

Sommario

Il componente aggiuntivo per la rimozione di dati nascosti è uno strumento utilizzabile per rimuovere dati personali o nascosti che potrebbero non essere immediatamente visibili quando si visualizza il documento che li contiene nel programma di Microsoft Office.

È possibile eseguire il componente aggiuntivo per la rimozione di dati nascosti su singoli file dal programma di Microsoft Office XP o di Microsoft Office 2003 o su più file dalla riga di comando. In entrambi i casi è necessario che nel computer sia installato il programma utilizzato per creare il documento.

Per ulteriori informazioni su questo strumento e su come ottenerlo, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=144E54ED-D43E-42CA-BC7B-5446D34E5360 (http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=144E54ED-D43E-42CA-BC7B-5446D34E5360)
Per ulteriori informazioni su altri problemi noti e argomenti non trattati nel file ReadMe, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
834636  (http://support.microsoft.com/kb/834636/ ) Problemi noti relativi al componente aggiuntivo per la rimozione di dati nascosti per Office 2003 e Office XP
842684  (http://support.microsoft.com/kb/842684/ ) Problemi noti relativi al componente aggiuntivo per la rimozione di dati nascosti versione 1.1 per Office 2003 e Office XP

Per determinare la versione dello Strumento per la rimozione dei dati nascosti installata nel computer, attenersi alla procedura descritta di seguito.
  1. Fare clic sul pulsante Start e scegliere Pannello di controllo.
  2. Fare clic su Installazione applicazioni.
  3. Nell'elenco dei programmi installati fare clic su Strumento per la rimozione dei dati nascosti, quindi scegliere Fare clic qui per informazioni sul supporto.
  4. Per determinare la versione dello strumento installata nel computer, consultare la tabella riportata di seguito.

    Riduci questa tabellaEspandi questa tabella
    Versione di rilascioVersione
    Remove Hidden Data Tool 1.111.0.6361.0
    Remove Hidden Data Tool 1.06.00.2600.0000

Informazioni

Di seguito è riportata la traduzione in lingua italiana del file ReadMe del componente aggiuntivo per la rimozione di dati nascosti, incluso nella seguente cartella dopo l'installazione del componente aggiuntivo:
Percorso\Programmi\Microsoft Office\Remove Hidden Data Tool\1033

File ReadMe di Microsoft Office 2003: componente aggiuntivo per la rimozione di dati nascosti

© 2003 Microsoft Corporation. Tutti i diritti riservati.

Questo documento contiene informazioni aggiornate sul componente aggiuntivo per la rimozione di dati nascosti di Microsoft Office 2003. Nella sezione Sommario sono elencate tutte le informazioni contenute in questo file; per informazioni aggiornate su specifici prodotti di Office, vedere il relativo file ReadMe.

Lo Strumento per la rimozione dei dati nascosti è un componente aggiuntivo per tutte le edizioni di Microsoft Office 2003 e per Microsoft Office XP che consente agli utenti di rimuovere in modo permanente dati nascosti e dati di collaborazione dai file di Microsoft Word, Microsoft Excel e Microsoft PowerPoint.

Informazioni sull'utilizzo di questo documento

Per visualizzare il file ReadMe sullo schermo, ingrandire la finestra del browser. Per stampare il file ReadMe, fare clic sul pulsante Stampa sulla barra degli strumenti.

Sommario

Cenni preliminari

Quando si distribuisce un documento di Office per via elettronica, il documento potrebbe contenere informazioni che non si intende condividere pubblicamente, quali informazioni di supporto per la collaborazione con altri utenti nella redazione e nella modifica del documento oppure informazioni nascoste che è possibile utilizzare per tenere traccia degli utenti che hanno lavorato sul documento.

Il componente aggiuntivo per la rimozione di dati nascosti è uno strumento utilizzabile per rimuovere informazioni personali o nascoste che potrebbero non essere immediatamente visibili quando si visualizza il documento che li contiene nell'applicazione di Microsoft Office.

È possibile eseguire il componente aggiuntivo per la rimozione di dati nascosti su singoli file dall'applicazione di Microsoft Office XP o di Microsoft Office 2003 o su più file dalla riga di comando. In entrambi i casi è necessario che nel computer sia installata l'applicazione utilizzata per creare il documento.

Note

Il componente aggiuntivo per la rimozione di dati nascosti deve essere eseguito sui file pronti per la pubblicazione, dal momento che alcune informazioni rimosse dallo strumento vengono utilizzate per le funzionalità di collaborazione di Office, quali le revisioni, i commenti e l'invio per la revisione e che tali funzionalità non potranno più essere utilizzate dopo l'esecuzione del componente aggiuntivo.

Il componente aggiuntivo per la rimozione di dati nascosti è progettato per rimuovere automaticamente e in modo permanente alcuni tipi di dati dai file di Office. Per impostazione predefinita, verrà chiesto di salvare il file elaborato mediante il componente aggiuntivo con un nuovo nome.

È consigliabile salvare sempre il file utilizzando un nuovo nome, anziché sovrascrivere il file originale con il nuovo documento, per preservare una copia del documento contenente i dati originali.

Per cambiare la lingua utilizzata per il componente aggiuntivo per la rimozione di dati nascosti, è necessario disinstallare e quindi scaricare una nuova copia del componente aggiuntivo per la lingua desiderata. Una volta installata la copia localizzata nella nuova lingua, la versione del componente aggiuntivo nella lingua originale verrà sostituita. Tutte le copie localizzate del componente aggiuntivo per la rimozione di dati nascosti includono una versione in lingua inglese che supporta lo strumento della riga di comando.

Questo strumento non consente la rimozione di dati nascosti dai seguenti tipi di file:
  • Documenti in cui sono utilizzate autorizzazioni per la gestione di diritti
  • Documenti protetti
  • Documenti provvisti di firma digitale
  • Cartelle di lavoro condivise
Se si tenta di eseguire lo strumento su un file corrispondente a una o più di queste condizioni, l'operazione verrà terminata e verrà visualizzato un messaggio di errore. Il file originale rimane invariato.

Requisiti di sistema

Sistemi operativi supportati: Microsoft Windows XP SP1 o versione successiva , Microsoft Windows 2000 SP4 o versione successiva o Microsoft Windows Server 2003

Il componente aggiuntivo è utilizzabile sulle seguenti applicazioni di Office:
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Installare Windows 2002 SP2 o versione successiva
  • Microsoft Excel 2002, SP2 o versione successiva
  • Microsoft Excel 2002, SP2 o versione successiva
Per eseguire il componente aggiuntivo è necessario che nel computer sia installata l'applicazione utilizzata per creare il documento e che la versione di Office sia la stessa del documento da elaborare o una versione successiva. È ad esempio possibile eseguire lo strumento su un documento di Office 2000 utilizzando un'applicazione di Office 2003, ma non su un documento di Office 2003 utilizzando un'applicazione di Office XP.

Il componente aggiuntivo per la rimozione di dati nascosti è utilizzabile su documenti di Word, fogli di calcolo di Excel, presentazioni di PowerPoint nonché pagine Web e pagine Web in file unico creati mediante Word, Excel e PowerPoint. Non è utilizzabile su documenti di altro formato.

Tipi di dati che è possibile rimuovere con il componente aggiuntivo

I seguenti tipi di dati vengono rimossi automaticamente.
  • Commenti.
  • Autori e revisori precedenti.
  • Nome utente.
  • Informazioni di riepilogo personali.
  • Revisioni. Verranno accettate tutte le revisioni specificate nel documento. Di conseguenza, il contenuto del documento corrisponderà alla visualizzazione Commenti finali sulla barra degli strumenti Revisioni.
  • Testo eliminato. La rimozione dei dati è automatica.
  • Versioni.
  • Macro di Visual Basic. Le descrizioni e i commenti vengono rimossi dai moduli.
  • Numero ID utilizzato per identificare il documento per l'unione delle modifiche nel documento originale.
  • Liste di distribuzione.
  • Intestazioni dei messaggi di posta elettronica.
  • Commenti relativi a scenari.
  • Identificatori univoci (solo documenti di Office 97).
Nota Viene inoltre attivata la funzionalità di rimozione delle informazioni personali. Per ulteriori informazioni su questa funzionalità, cercare "Rimozione delle informazioni personali" nella Guida dell'applicazione.

Problemi noti

  • Excel: in Excel 2002 i percorsi di stampante non vengono rimossi, mentre vengono rimossi in Excel 2003.
  • Excel: è possibile che il collegamento a una cartella di lavoro esterna di supporto non venga rimosso da una pagina Web in file unico di Excel.
  • Se il componente aggiuntivo per la rimozione di dati nascosti viene chiuso in modo imprevisto, è possibile che venga visualizzata una finestra vuota del Blocco note e che dalla directory temporanea del computer non venga rimosso un file di registro. Per chiudere la finestra del Blocco note, scegliere Esci dal menu File dell'applicazione. Per rimuovere il file di registro, eliminare il contenuto della directory temporanea nella cartella delle impostazioni locali.
  • Se si chiude il componente aggiuntivo per la rimozione di dati nascosti prima che sia terminata l'elaborazione, è possibile che uno o più file temporanei non vengano rimossi dalla directory di destinazione. Per rimuovere questi file, eliminarli dalla directory di destinazione.
  • È possibile che le pagine Web in file unico elaborate tramite questo strumento contengano un nome di file temporaneo generato casualmente nella forma file:///c:/<numero>/. Il numero utilizzato nel nome è basato sul nome di file della pagina Web in file unico e non può essere ricondotto al computer di origine.
  • I numeri casuali nascosti eventualmente presenti, utilizzati per migliorare l'accuratezza delle operazioni di unione e memorizzati nei file di Word, non vengono rimossi.
  • Se il componente aggiuntivo viene eseguito dalla riga di comando, i documenti XML creati in Word, Excel o PowerPoint verranno ignorati.

Utilizzo di base

Una volta installato il componente aggiuntivo per la rimozione di dati nascosti, aprire il documento da elaborare, quindi scegliere il comando relativo alla rimozione dei dati nascostidal menu File.

Nota Se tale comandodel menu File non è disponibile, verificare quanto segue:
  1. Scegliere Opzioni dal menu Strumenti, quindi fare clic sulla scheda Protezione.
  2. In Protezione macro scegliere il pulsante Protezione macro.
  3. Scegliere la scheda Autori attendibili.
  4. Selezionare la casella di controllo Considera attendibili tutti i modelli e i componenti aggiuntivi installati, quindi scegliere OK due volte.
Dopo aver specificato il nome del file, i dati nascosti specificati verranno rimossi automaticamente. Per ulteriori informazioni, vedere la sezione Tipi di dati che è possibile rimuovere con il componente aggiuntivo.

Note

È consigliabile salvare sempre il file con un nuovo nome, anziché sovrascrivere il file originale con il nuovo documento, per preservare una copia del documento contenente i dati originali.

Il componente aggiuntivo per la rimozione di dati nascosti non supporta il salvataggio di documenti come modelli.

Riga di comando

Per eseguire il componente aggiuntivo per la rimozione di dati nascosti dalla riga di comando, attenersi alla seguente procedura:
  1. Chiudere tutte le istanze di Excel, di Word, di Outlook e di PowerPoint prima di avviare lo strumento della riga di comando.
  2. Fare clic sul pulsante Start e scegliere Esegui.
  3. Digitare cmd e premere INVIO.
  4. Passare alla directory contenente il file OFFRHD.EXE. Per impostazione predefinita, è la directory in cui si è installato il componente aggiuntivo per la rimozione di dati nascosti.
  5. Al prompt dei comandi, digitare la sintassi appropriata per l'attività da eseguire.
Note

L'elaborazione del documento viene eseguita in background e non è visibile all'utente. Se viene visualizzata una finestra di dialogo, l'esecuzione del componente aggiuntivo verrà sospesa fino a che tale finestra non verrà chiusa. Se la finestra di dialogo rimane aperta per oltre 120 secondi, l'elaborazione del file verrà terminata e il componente aggiuntivo passerà al file successivo o verrà chiuso in mancanza di ulteriori file da elaborare.

È possibile fare precedere i parametri di comando da flag quali una barra (/) o un trattino (-). Nei flag non viene fatta distinzione tra maiuscole e minuscole.

Se si digitano più flag, verrà riconosciuto solo il primo.

È necessario immettere per primo il parametro /origine, eventualmente seguito dal parametro /destinazione. Per tutti gli altri parametri non è richiesto un ordine specifico di immissione.

Se si digita una barra (/) alla fine del nome della directory di origine, lo strumento non funzionerà.

La sintassi per l'utilizzo di OFFRHD.EXE è la seguente:
OFFRHD [/?] origine [destinazione] [/O] [/R] [/F:tipofile] [/L: fileregistro] [/A]
Riduci questa tabellaEspandi questa tabella
ParametroDescrizione
origineObbligatorio. Consente di specificare l'unità, la directory e i file dai quali si desidera rimuovere le informazioni personali. Può essere qualsiasi nome di percorso completo valido.
destinazioneFacoltativo. Consente di specificare un percorso per i file esaminati. Se non si specifica questo parametro, tutti i file verranno salvati nella stessa directory con un suffisso che rappresenta la data corrente. Il suffisso -C010503, ad esempio, rappresenterebbe il 5 gennaio 2003. Se il file di destinazione esiste già, verrà sovrascritto.
/OConsente di specificare che non verrà visualizzata alcuna richiesta di confermare la sovrascrittura di un file esistente.
/RConsente di specificare che verrà esaminato il contenuto della directory di origine e delle relative sottodirectory.
/F:tipofileConsente di specificare il formato dei file di destinazione.
/F:HConsente di specificare il formato HTML.
/F:MConsente di specificare il formato MHTML.
/F:BConsente di specificare il formato di documento binario. Se non si specifica questo parametro, in base all'impostazione predefinita il file verrà salvato nello stesso formato del file di origine.
/L:fileregistroConsente di specificare un percorso per l'archiviazione del file di registro. Se non si specifica questo parametro, il file di registro verrà visualizzato al termine dell'esecuzione dello strumento.
/AConsente di specificare la generazione di un rapporto dei problemi rilevati nel file senza che venga rimosso alcun dato.
/:?Consente di visualizzare un elenco di tutti i parametri disponibili.

File di registro

Al termine dell'elaborazione dei file mediante il componente aggiuntivo per la rimozione di dati nascosti, i risultati del processo vengono visualizzati in un file di registro. Tale file può essere salvato per successive verifiche.

Utilizzo del componente aggiuntivo per la rimozione di dati nascosti con IRM

In Office 2003 non è possibile utilizzare questo strumento su documenti protetti da Information Rights Management (IRM), a meno di essere il proprietario del documento o di avere ottenuto l'autorizzazione di "Modifica" con l'opzione "Accesso al contenuto a livello di programmazione".

Per concedere autorizzazioni per l'esecuzione del componente aggiuntivo per la rimozione di dati nascosti su documenti protetti da IRM, attenersi alla seguente procedura:
  1. Scegliere Autorizzazione, Limita autorizzazioni dal menu File.
  2. Selezionare l'account utente (solitamente il proprio) utilizzato per creare o aprire contenuto, quindi scegliere OK.
  3. Nella finestra di dialogo Autorizzazione fare clic su Altre opzioni.
  4. Fare clic sull'account utente a cui si desidera concedere l'accesso. Per utilizzare lo Strumento per la rimozione dei dati nascosti, è necessario che a questo account utente sia assegnata l'autorizzazione di Modifica sul documento.
  5. Fare clic su Accesso al contenuto a livello di programmazione, quindi scegliere OK.

Le informazioni in questo articolo si applicano a
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Chiavi: 
kbcommandline kbconfig kbtooltip kbinfo KB834427
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store