DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 871205 - Ultima modifica: mercoledì 29 agosto 2007 - Revisione: 3.2

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Sintomi

Quando si visita un sito Web, Microsoft Internet Explorer potrebbe non decomprimere contenuto HTTP. Questo problema può verificarsi quando sono vere tutte le condizioni seguenti:
  • Codifica Chunked è attivato il server Web.
  • Compressione HTTP è attivata il server Web.
  • I dati vengono inviati dal server Web utilizzando il protocollo HTTPS.
Potrebbero verificarsi diversi sintomi di questo problema, in base al contenuto che Internet Explorer sta tentando di decomprimere. Ad esempio, se il contenuto inviato dal server del sito Web è un file JavaScript, potresti ricevere un errore di scripting.

Cause

Questo problema si verifica quando si perde una notifica tra WININET e URLMON. Quando una notifica viene persa, un blocco codificato necessaria per la decompressione viene persa. Quando un blocco codificato viene persa, il programma di decompressione gzip ha esito negativo.

note
  • WININET (Wininet.dll) è il componente che riceve i dati HTTP. URLMON (urlmon.dll) è il componente che implementa il programma di decompressione gzip.
  • Compressione HTTP è anche noto come codifica gzip.

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389  (http://support.microsoft.com/kb/322389/ ) Come ottenere il service pack più recente per Windows XP

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Microsoft Internet Explorer 6 Service Pack 1 (SP1)
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   14-Jan-2005  17:21  6.0.2800.1489  581,632  Wininet.dll
Microsoft Internet Explorer 6 Service Pack 2 (SP2)
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   10-Jun-2005  01:38  6.0.2900.2695  658,944  Wininet.dll

Informazioni sull'installazione

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo aver installato questo aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Chiudere Internet Explorer.
  2. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  3. Individuare e selezionare la seguente sottochiave:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_RESET_SOCKET_FLAGS_KB871205
  4. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  5. Digitare Iexplore.exe e quindi premere INVIO.
  6. Fare clic con il pulsante destro del mouse su Iexplore.exe e quindi fare clic su Modifica .
  7. Nella casella dati valore digitare 00000001 e quindi fare clic su OK .
  8. Chiudere l'editor del Registro di sistema.

Workaround

Per ovviare al problema, disattivare la codifica chunked oppure disattivare la compressione HTTP nel server Web. Per visualizzare le impostazioni di compressione HTTP in Microsoft Internet Information Services (IIS) 6.0, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Strumenti di amministrazione e quindi fare clic su Gestione Internet Information Services (IIS) .
  2. Espandere il server Web, fare clic con il pulsante destro del mouse su siti Web e quindi scegliere Proprietà .
  3. Fare clic sulla scheda servizio e visualizzare le opzioni visualizzate in compressione HTTP .

Status

Microsoft ha confermato che questo problema riguarda Internet Explorer 6 Service Pack 1.

Informazioni

Questo problema è più probabile verificarsi su un computer che esegue Apache HTTP poiché Apache HTTP Server può utilizzare la codifica chunked su qualsiasi tipo di file. Include i file statici, ad esempio un file JavaScript o un un file GIF. Quando si verifica il problema descritto in questo articolo, il contenuto memorizzato nella cache di Internet Explorer potrebbe essere troncato o danneggiato.

Nota Per impostazione predefinita, Microsoft Internet Information Server non utilizza la codifica chunked. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
278998  (http://support.microsoft.com/kb/278998/ ) Come attivare la codifica con IIS di trasferimento chunked
I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o di altra natura, relativa alle prestazioni o all'affidabilità di questi prodotti.

Le informazioni in questo articolo si applicano a:
  • Microsoft Internet Explorer 6.0 SP1
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbqfe kbtshoot kbprb KB871205 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 871205  (http://support.microsoft.com/kb/871205/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store