DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 893310 - Ultima modifica: giovedì 11 ottobre 2007 - Revisione: 4.4

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Sintomi

Quando si stampa una pagina Web che utilizza i tipi di carattere Adobe Type 1, il documento stampato è errato. È possibile che si riscontrino i seguenti sintomi:
  • Caratteri dall'inizio o fine di una riga nel documento sono ripetuti nella riga successiva nel documento stampato.
  • Le parole all'inizio o alla fine di una riga nel documento vengono ripetute nella riga successiva nel documento stampato.
Ad esempio, si stampa il testo seguente da una pagina Web:
Cantami o Diva saltati over backup del the lazy dog.
Cantami o Diva saltati over backup del the lazy dog.
Cantami o Diva saltati over backup del the lazy dog.
Cantami o Diva saltati over backup del the lazy dog.
In questo caso, il testo stampato potrebbero non simile a quello riportato di seguito:
Cantami o Diva saltati over backup del the lazy dog.
eseguire il backup .Quick brown fox saltati over backup del the lazy dog.
eseguire il backup .Quick brown fox saltati over backup del the lazy dog.
eseguire il backup .Quick brown fox saltati over backup del the lazy dog.

Cause

Questo problema si verifica se si utilizza Microsoft Internet Explorer 6. Infatti, è presente un'incompatibilità con il rendering del tipo di carattere Adobe nel motore di stampa di Internet Explorer 6.

Durante il processo di layout di pagina, Internet Explorer misura la larghezza di carattere utilizzando il tipo di carattere dello schermo. Tuttavia, il componente MSHTML di Internet Explorer impone l'uso dei tipi di carattere TrueType. Questo è quanto alcuni tipi di carattere Adobe non sono i tipi di carattere TrueType e poiché il percorso di visualizzazione del codice in Internet Explorer verifica il supporto di destinazione. Di conseguenza, esiste un set diverso di larghezza per i caratteri che vengono stampati.

Risoluzione

Microsoft Windows Server 2003

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
È necessario Internet Explorer 6 Service Pack 1 (SP1) per installare questo aggiornamento rapido (hotfix).
Necessità di riavvio
Non è necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Nota Se viene utilizzato il file Mshtml.dll quando si applica questo aggiornamento rapido (hotfix), è necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.

Windows Server 2003, versioni a 32 bit
   Date         Time   Version       Size         File name
   ----------------------------------------------------------
   07-Apr-2005  21:32  6.0.3790.305  2,930,688    Mshtml.dll


Windows Server 2003, versioni a 64 bit
   Date         Time     Version       Size        File name
   ------------------------------------------------------------
   07-Apr-2005  19:30    6.0.3790.305  8,231,424   Mshtml.dll
   07-Apr-2005  19:32    6.0.3790.305  2,930,688   Wmshtml.dll
Informazioni sull'installazione di hotfix


avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo aver installato questo aggiornamento rapido (hotfix), è necessario impostare il valore di registro di sistema riportato di seguito per applicare le modifiche presenti in questo aggiornamento rapido (hotfix):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Nome valore: DO_NOT_FORCE_TRUETYPE_K893310
Valore di tipo: REG_DWORD
Dati valore: 0 x 1
In questo valore del Registro di sistema, il valore 0 x 1 attiva il supporto di compatibilità per i tipi di carattere Adobe, quando vengono utilizzati in Internet Explorer. Per disattivare il supporto di compatibilità per i caratteri Adobe in Internet Explorer, impostare questo valore su 0 x 0.

Microsoft Windows XP Service Pack 1 (SP1) e Windows Service di XP Pack 2 (SP2)

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
È necessario Internet Explorer 6 Service Pack 1 (SP1) per installare questo aggiornamento rapido (hotfix).
Necessità di riavvio
Non è necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Nota Se viene utilizzato il file Mshtml.dll quando si applica questo aggiornamento rapido (hotfix), è necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.

Windows XP Service Pack 1
   Date         Time   Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35  6.0.2800.1502  2,703,360   Mshtml.dll


Windows XP Service Pack 2
   Date         Time   Version        Size        File name
   -----------------------------------------------------------
   25-Mar-2005  06:04  6.0.2900.2640  3,011,584   Mshtml.dll
Informazioni sull'installazione di hotfix


avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo aver installato questo aggiornamento rapido (hotfix), è necessario impostare il valore di registro di sistema riportato di seguito per applicare le modifiche presenti in questo aggiornamento rapido (hotfix):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Nome valore: DO_NOT_FORCE_TRUETYPE_K893310
Valore di tipo: REG_DWORD
Dati valore: 0 x 1
In questo valore del Registro di sistema, il valore 0 x 1 attiva il supporto di compatibilità per i tipi di carattere Adobe, quando vengono utilizzati in Internet Explorer. Per disattivare il supporto di compatibilità per i caratteri Adobe in Internet Explorer, impostare questo valore su 0 x 0.

Microsoft Windows 2000

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
È necessario Internet Explorer 6 Service Pack 1 (SP1) per installare questo aggiornamento rapido (hotfix).
Necessità di riavvio
Non è necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Nota Se viene utilizzato il file Mshtml.dll quando si applica questo aggiornamento rapido (hotfix), è necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time    Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35   6.0.2800.1502  2,703,360   Mshtml.dll
Informazioni sull'installazione di hotfix


avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo aver installato questo aggiornamento rapido (hotfix), è necessario impostare il valore di registro di sistema riportato di seguito per applicare le modifiche presenti in questo aggiornamento rapido (hotfix):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Nome valore: DO_NOT_FORCE_TRUETYPE_K893310
Valore di tipo: REG_DWORD
Dati valore: 0 x 1
In questo valore del Registro di sistema, il valore 0 x 1 attiva il supporto di compatibilità per i tipi di carattere Adobe, quando vengono utilizzati in Internet Explorer. Per disattivare il supporto di compatibilità per i caratteri Adobe in Internet Explorer, impostare questo valore su 0 x 0.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o di altra natura, relativa alle prestazioni o all'affidabilità di questi prodotti.

Le informazioni in questo articolo si applicano a:
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server
Chiavi: 
kbmt kbautohotfix kbbug kbfix kbqfe kbwinserv2003presp1fix kbmbsmigrate kbhotfixserver KB893310 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 893310  (http://support.microsoft.com/kb/893310/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store