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Identificativo articolo: 897242 - Ultima modifica: lunedì 14 aprile 2008 - Revisione: 3.2

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importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Sintomi

Se si tenta di utilizzare Microsoft Internet Explorer 6 o Internet Explorer 6 Service Pack 1 (SP1) per aprire un file di immagine, il file di immagine non in Internet Explorer. In Internet Explorer, invece, viene visualizzata una casella vuota. Tuttavia, è possibile utilizzare il programma Visualizzatore di immagini di Windows per aprire e visualizzare il file di immagine.

Cause

Questo problema si verifica se le seguenti condizioni sono vere:
  • Il file di immagine viene codificato utilizzando la codifica PNG (Portable Network Graphics).
  • File PNG contiene uno o più blocchi IDAT di lunghezza zero.

Risoluzione

Informazioni sull'aggiornamento di protezione

Per risolvere questo problema, è necessario installare l'aggiornamento cumulativo della protezione più recente per Internet Explorer. Per installare gli aggiornamenti più recenti, visitare il seguente sito di Web di Microsoft:
http://windowsupdate.microsoft.com (http://windowsupdate.microsoft.com)
Per informazioni più tecniche sull'aggiornamento della protezione cumulativo più recente per Internet Explorer, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/technet/security/current.aspx (http://www.microsoft.com/technet/security/current.aspx)
Nota Questa correzione è stata innanzitutto inclusa nell'aggiornamento della protezione 947864 (MS08-024). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
947864  (http://support.microsoft.com/kb/947864/ ) MS08-024: Aggiornamento cumulativo della protezione per Internet Explorer


Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

È necessario disporre di Internet Explorer 6 o sia installato Internet Explorer 6 SP1 per poter applicare questo hotfix.

Necessità di riavvio

È necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Date         Time   Version            Size    File name
--------------------------------------------------------------
20-Apr-2005  21:11   6.0.2800.1504     38,912   Pngfilt.dll

Istruzioni di installazione dell'hotfix

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.Dopo avere applicato questo aggiornamento rapido (hotfix), per eseguire la procedura aggiungere il nuovo FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242 sottochiave nel Registro di sistema:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. In a sinistra riquadro espandere HKEY_LOCAL_MACHINE, espandere SOFTWARE, espandere Microsoft, espandere Internet Explorer, espandere Main e quindi espandere FeatureControl.
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242 per denominare la nuova chiave.
  5. Fare clic su FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242 , scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  6. Digitare iexplore.exe per denominare il nuovo valore.
  7. Fare clic con il pulsante destro del mouse su iexplore.exe e quindi fare clic su Modifica .
  8. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  9. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  10. Digita explorer.exe per denominare il nuovo valore.
  11. Fare clic con il pulsante destro del mouse su explorer.exe e quindi fare clic su Modifica .
  12. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  13. Chiudere l'editor del Registro di sistema.

Status

Microsoft ha confermato che si tratta di un problema di Internet Explorer 6.

Informazioni

La specifica di PNG consente l'utilizzo di un blocco IDAT zero byte. Per ulteriori informazioni sulla specifica PNG, vedere RFC 2083 presso il seguente sito Web:
http://www.faqs.org/rfcs/rfc2083.html (http://www.faqs.org/rfcs/rfc2083.html)
Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono pertanto soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza delle informazioni sul contatti-altri produttori.

Le informazioni in questo articolo si applicano a:
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
Chiavi: 
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Clicca qui per visualizzare la versione originale in inglese dell’articolo: 897242  (http://support.microsoft.com/kb/897242/en-us/ )
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