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Identificativo articolo: 897663 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 4.3

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Aggiornamento tecnico, 31 agosto 2005

Microsoft ha rilasciato un advisory Microsoft sulla sicurezza relativamente a questo problema per professionisti IT. L'advisory sulla sicurezza contiene ulteriori informazioni correlate alla protezione relative a questo problema. Per visualizzarlo, fare clic sul seguente collegamento (informazioni in lingua inglese):
http://www.microsoft.com/technet/security/advisory/897663.mspx (http://www.microsoft.com/technet/security/advisory/897663.mspx)

In questa pagina

Sintomi

Se si crea un'eccezione modificando il Registro di sistema di un computer che esegue Microsoft Windows XP Service Pack 2 (SP2) o Microsoft Windows Server 2003 Service Pack 1 (SP1), tale eccezione potrebbe non essere visualizzata nell'interfaccia utente grafica di Windows Firewall.

Cause

Ciò avviene se non si specifica un nome quando si aggiunge un'eccezione modificando la chiave del Registro di sistema. Ad esempio, questo comportamento ha luogo se si aggiunge una porta al Registro di sistema e quindi si imposta il valore su 12345:TCP:*:Enabled. Tale valore apre la porta TCP 12345. Tuttavia, nell'interfaccia utente grafica di Windows Firewall ciò non viene segnalato poiché il valore non contiene un nome. Il valore seguente è quello corretto:
12345:TCP:*:Enabled:nome dell'eccezione

Risoluzione

Per risolvere questo problema in Windows XP Service Pack 2, installare l'aggiornamento per Windows XP KB897663. Questo aggiornamento fa in modo che un'eccezione del firewall creata mediante il Registro di sistema venga elencata nell'interfaccia di Windows Firewall come se fosse stata creata nell'interfaccia stessa. Per scaricare e installare l'aggiornamento per Windows XP KB897663, visitare il seguente sito Web:
http://www.microsoft.com/downloads/details.aspx?familyid=478FD24B-B2C4-4207-B1B9-1C988698C888&displaylang=it (http://www.microsoft.com/downloads/details.aspx?familyid=478FD24B-B2C4-4207-B1B9-1C988698C888&displaylang=it)

Prerequisiti

A causa delle dipendenze dei file, questo aggiornamento richiede Windows XP Service Pack 2.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389  (http://support.microsoft.com/kb/322389/ ) Come ottenere il service pack più recente per Windows XP

Richiesta di riavvio

Dopo l'applicazione dell'aggiornamento software non è necessario riavviare il computer.

Informazioni sui file

La versione in lingua inglese di questo aggiornamento presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in formato UTC (Coordinated Universal Time, tempo universale coordinato). Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione        Dimensione   Nome file
   ------------------------------------------------------------
   04/08/2005  01.44  5.1.2600.2732   80.896       Firewall.cpl

Status

Si tratta di un comportamento legato alla progettazione del prodotto.

Workaround

Per risolvere questo problema, adottare uno dei seguenti metodi:

Metodo 1: Aggiungere un nome al valore del Registro di sistema

Per ovviare a questo problema, aggiungere un nome al valore del Registro di sistema. Ad esempio, cambiare 12345:TCP:*:Enabled in 12345:TCP:*:Enabled:nome dell'eccezione.

Metodo 2: Utilizzare il comando netsh firewall

Per ovviare al problema, è possibile visualizzare le eccezioni create nel Registro di sistema utilizzando il comando netsh firewall. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd, quindi scegliere OK.
  2. Digitare netsh firewall show state verbose = enable, quindi scegliere OK.
  3. Ricercare quanto segue nel testo di output:
    Ports currently open on all network interfaces
    Le porte e i programmi elencati nella sezione Ports currently open on all network interfaces non sono bloccate. Inoltre, questi programmi e queste porte non bloccati rappresentano eccezioni di programma o di porta abilitate.

Informazioni

Per ulteriori informazioni su come configurare Windows Firewall, visitare i seguenti siti Web Microsoft (informazioni in lingua inglese):

Guida operativa per Windows Firewall

http://technet2.microsoft.com/windowsserver/en/library/c52a765e-5a62-4c28-9e3f-d5ed334cadf61033.mspx (http://technet2.microsoft.com/windowsserver/en/library/c52a765e-5a62-4c28-9e3f-d5ed334cadf61033.mspx)

Configurazione manuale di Windows Firewall in Windows XP Service Pack 2

http://www.microsoft.com/technet/community/columns/cableguy/cg0204.mspx (http://www.microsoft.com/technet/community/columns/cableguy/cg0204.mspx)
Per ulteriori informazioni su come risolvere i problemi di impostazione di Windows Firewall, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
875357  (http://support.microsoft.com/kb/875357/ ) Risoluzione dei problemi relativi alle impostazioni della funzionalità Windows Firewall in Windows XP Service Pack 2

Le informazioni in questo articolo si applicano a
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
Chiavi: 
kbtshoot kbqfe kbfirewall kbsecurity kbhotfixserver kbsecadvisory KB897663
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