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Identificativo articolo: 898061 - Ultima modifica: giovedì 11 ottobre 2007 - Revisione: 3.3

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importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Sintomi

Autenticazione non riesce da un client basato su Microsoft Windows XP se sono vere le seguenti condizioni:
  • L'autenticazione utilizza IAS (Internet Authentication Service) in un computer basato su Microsoft Windows Server 2003.
  • L'autenticazione utilizza Extensible Authentication Protocol-Transport Layer Security (EAP-TLS).
  • Il client utilizza un certificato che non contiene un utilizzo chiave esteso (EKU).

Cause

Questo problema si verifica poiché l'implementazione corrente di EAP-TLS richiede la presenza di sia l'autenticazione del server EKU e l'autenticazione client EKU del certificato utilizzato dal client.

Risoluzione

Questo aggiornamento rapido (hotfix) include le versioni per Windows XP e Windows Server 2003. Per risolvere il problema, attenersi alla seguente procedura:
  1. Applicare la versione di Windows XP di questo aggiornamento rapido (hotfix) sul client.
  2. Applicare la versione di Windows Server 2003 di questo aggiornamento rapido (hotfix) sul server IAS.
  3. Creare e attivare la voce di TlsServerUseAllPurposeCert del Registro di sistema sul server IAS dopo avere applicato gli aggiornamenti rapidi.

Windows XP

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario Windows XP Service Pack 2 installato nel computer. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389  (http://support.microsoft.com/kb/322389/ ) Come ottenere il service pack più recente per Windows XP
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello data e ora nel Pannello di controllo.
Windows XP, versioni x 86
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
RASTLS.dll5.1.2600.2719112,64014 / 07 / 200503: 06x 86
Arpidfix.exe5.1.2600.271930.72014 / 07 / 200500: 03x 86
Windows XP, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
RASTLS.dll5.2.3790.2487242,68813 / 07 / 200512: 28x 64SP1SP1QFE
Wrastls.dll5.2.3790.2487184.32013 / 07 / 200512: 28x 86SP1WOW
Arpidfix.exe5.2.3790.248743.00813 / 07 / 200512: 28x 64NessunoNon applicabile

Windows Server 2003

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Creare e attivare la voce del Registro di sistema TlsServerUseAllPurposeCert dopo avere applicato questo aggiornamento rapido (hotfix). Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
  3. Fare clic con il pulsante destro del mouse su questa sottochiave del Registro di sistema, scegliere Nuovo , quindi Valore DWORD .
  4. Digitare TlsServerUseAllPurposeCert come nome della voce del Registro di sistema e quindi premere INVIO.
  5. Fare doppio clic sulla voce del Registro di sistema TlsServerUseAllPurposeCert .
  6. Nella finestra di dialogo Modifica valore DWORD , fare clic su decimale in base .
  7. Nella casella di testo dati valore , digitare 0 o 1 , come adatto alla situazione.

    Nota Quando questo valore è impostato su 1, il server IAS è solo invia al client un certificato che non contiene un EKU. Quando questo valore è impostato su 0, il server IAS è solo invia al client un certificato contenente un EKU.

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack più recente per Windows Server 2003. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100  (http://support.microsoft.com/kb/889100/ ) Come ottenere il service pack più recente per Windows Server 2003

Informazioni sull'hotfix

Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario Windows Server 2003 Service Pack 1 (SP1) installato nel computer. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100  (http://support.microsoft.com/kb/889100/ ) Come ottenere il service pack più recente per Windows Server 2003
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello data e ora nel Pannello di controllo.
Windows Server 2003, versioni x 86
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
RASTLS.dll5.2.3790.2487184.32014 / 07 / 200502: 49x 86
Arpidfix.exe5.2.3790.248732.25614 / 07 / 2005/ 05 / 01x 86
Windows Server 2003, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
RASTLS.dll5.2.3790.2487437,76013 / 07 / 200512: 28IA-64SP1SP1QFE
Wrastls.dll5.2.3790.2487184.32013 / 07 / 200512: 28x 86SP1WOW
Arpidfix.exe5.2.3790.248774.75213 / 07 / 200512: 28IA-64NessunoNon applicabile
Windows Server 2003, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
RASTLS.dll5.2.3790.2487242,68813 / 07 / 200512: 28x 64SP1SP1QFE
Wrastls.dll5.2.3790.2487184.32013 / 07 / 200512: 28x 86SP1WOW
Arpidfix.exe5.2.3790.248743.00813 / 07 / 200512: 28x 64NessunoNon applicabile

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema è stato innanzitutto corretto in Windows Server 2003 Service Pack 2.

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional
Chiavi: 
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Clicca qui per visualizzare la versione originale in inglese dell’articolo: 898061  (http://support.microsoft.com/kb/898061/en-us/ )
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